Running msc files in Admin ? Solved

  1.    04 May 2016 #1

    Running msc files in Admin ?


    If I want to run Group Policy editor in administration mode, what command must be used before gpedit.msc so the group policy editor runs in Administrator mode ?
      My ComputerSystem Spec

  2. Ztruker's Avatar
    Posts : 6,784
    Windows 10 Pro X64 1809 17763.134
       04 May 2016 #2

    Run it from a Elevated Command Prompt?????
      My ComputersSystem Spec


  3. Posts : 129
    Windows 10 Professional x64
       04 May 2016 #3

    Ztruker, that seems very valid.

    You can also find it in here "C:\Windows\System32\gpedit.msc" with the file explorer, right-click and choose run as admin. But beware when playing with this, since I suppose you're new to Windows !
      My ComputerSystem Spec

  4.    04 May 2016 #4

    That is what I was trying to do, why I posted the message. Hrm, alright thanks.
      My ComputerSystem Spec


  5. Posts : 129
    Windows 10 Professional x64
       04 May 2016 #5

    If you're looking for an easy way to get an elevated command line, right-click on the start menu icon, you will get a menu with an appropriate option.

    EDIT : Sorry I read too quickly, you want to know what to put before gpedit to have it run as an admin. Well, to my knowledge there's no secure way to do this. You could use the runas command, but it asks for the password outside User Account Control, which is bad. However, you could modify a copy of the Microsoft Management Console executable's manifest, changing its requested execution level from asHighest to asAdmin. This can be done with the CFF Explorer utility, part of the Explorer suite freely available at ntcore.com.

    Then type the following on the command line :

    yourmmc gpedit.msc

    You will then get an elevation prompt. But considering you'll get a UAC prompt anyway, I suppose the solution in my previous post remains better !
    Last edited by NovHak; 04 May 2016 at 22:05.
      My ComputerSystem Spec

  6.    04 May 2016 #6

    NovHak thanks for the tip, I did manage to get Local Group Policy to run as an Administrator. :) Problem solved :)
      My ComputerSystem Spec


 

Related Threads
When I try to rename or delete a file Windows Explorer freezes for an average of 20 seconds. I opened my running processes to see what I could find, and during this 20 second period it reads "Not Responding" next to Windows explorer (as seen in...
Admin password unknown and missing files after upload in User Accounts and Family Safety
Ok, I know these questions have been asked, but I have tried everything I can understand. Need to be spoken like a noob - step by step please. Win10 put on my system everything initially fine, then discovered files missing - tried to install a...
Solved Trouble running .bat files in General Support
Hi, I'm trying to run .bat files on Windows 10, but it tells me that "This app can't run on your PC". It doesn't matter what I use it for, .bat files just won't run anyway. Are .bat files no longer supported? (ran fine on Windows 7) Any...
Problem with running .exe files in Software and Apps
Hi everyone, my friend having a problem with running .exe files. I thought it would be the best to ask here. He can't run .exe files. Sorry for my bad English. http://oi58.tinypic.com/spvnh1.jpg
Can't access Admin acct., admin files are still there in User Accounts and Family Safety
I just transferred from Windows 7, and everything worked except for the fact that the admin account on the computer (also the superuser account) cannot be accessed. The account shows up in the Users file under the Local Disk, but I can't access it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:50.
Find Us