Page 1 of 3 123 LastLast
  1.    27 Apr 2016 #1
    Join Date : Mar 2016
    Posts : 4
    Windows 10

    File Explorer keeps crashing/restarting/flickering


    I am having an incredibly frustrating set of problems that I believe started in the past two weeks or so. It's happening on two different computers but both are virtually identical: Windows 10, nVidia Quadro 4000m, Dell 5k monitors, and basically the same software installed on each.

    I believe the problem is related to File Explorer. Here are the symptoms:
    • File explorer crashes constantly. I can generally open File Explorer and navigate fine, but double-clicking on any new folder or drive opens at least one new window, but more often than not two new windows. I have open each folder in same window selected.
    • If I try to double click a file to do something (open, view, etc.) the file will open but all the open explorer windows will crash. If I right-click and choose open or a specific action (e.g. open with Notepad++) File Explorer does not crash for some reason. Still have the problem saving to the desktop.
    • If I save anything to the desktop, the icons flash/disappear and reappear, as if Explorer has crashed and restarted. Opening anything from the desktop also causes the desktop to refresh (and move icons around).
    • File views (desktop and in other folders) do not always refresh (list new files and not list deleted files) automatically.


    Here's what I've tried so far that hasn't helped:
    • Change DPI from 250% to 100%. Didn't help. I have a 5k monitor, so 250% is the best DPI for me, but it didn't matter if I went down to 100% on either computer. I also made sure custom DPI was not set at the same time as the Windows DPI setting. They can both be on at the same time. This seemed to help for a minute, but not sure it wasn't an illusion.
    • Made sure AV and Malware protection were off.
    • Made sure open each folder in the same windows was selected but tried changing that setting and going back and forth.
    • Tried open Window in separate process setting.
    • Changed start in Quick Access to My PC (and back)
    • Tried sfc /scannow but it shows now errors (it did and couldn't repair it but the error went away after the in place upgrade...File Explorer problem still persists)
    • Tried disabling 3rd party context menu extensions with ShellExView
    • Ran CCleaner on the registry to clean it out
    • Completely uninstalled the nVidia drivers (using DDU for a clean uninstall in safe mode) and installed a version that I know worked. I also tried the latest drivers and the four releases in between the known driver and the latest.
    • Did a system restore to three previous versions but the problem either was there or came back quickly, perhaps after an update.
    • Turned off running background programs that seemed unnecessary.
    • Tried Safe mode. It happens in Safe Mode too but in Safe Mode I get an error "A new guard page for the Stack cannot be created." Tried searching for bushell.dll but I don't have Norton on either computer.
    • Do an in place upgrade/refresh using the Windows 10 media creation tool.
    • Curse continually at both computers.

    I'm about to do a full reinstall, but I'm worried about this just happening again. Any suggestions?
    Last edited by Tlon; 27 Apr 2016 at 09:42. Reason: Added additional details
      My ComputerSystem Spec
  2.    27 Apr 2016 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,138
    Win 10 Pro (1703)

    Hi, you've tried many standard procedures which is great. Key things I note are:
    1. Symptom present until a couple of weeks ago
    2. Happens also (or sthg happens) in Safe Mode

    This suggests some interaction with a program you've installed or updated.
    Compare:
    Program Crash - Nigel W. - WebSite X5 Answers
    where "A new guard page for the Stack cannot be created" is also reported in safe mode.
    and this:
    explorer.exe System error | MajorGeeks.Com Support Forums

    Is there anything interesting in Reliability History or the event log?
      My ComputerSystem Spec
  3.    27 Apr 2016 #3
    Join Date : Mar 2016
    Posts : 4
    Windows 10
    Thread Starter

    Thanks so much. Your answer at least gives me a few more things to try!

    I hadn't thought to look in Reliability History. There are many, many critical events (stopped working) with Windows explorer, Host Process for Windows Services and explorer.exe. They seem to be happening with 3 dll's.

    windows.storage.dll (the large majority)
    KERNELBASE.dll (1)
    ESENT.dll (2)

    Here's what I can glean, but if there is anything else that'd be helpful to share, please let me know. I don't know how to review the logs, so any help there would be appreciated?

    Tried deleting the BagMRU and Bags subkeys (Windows 10 File Explorer crashing regularly - Super User) didn't help.
    Last edited by Tlon; 27 Apr 2016 at 14:49.
      My ComputerSystem Spec
  4.    27 Apr 2016 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,138
    Win 10 Pro (1703)

    Um, those don't obviously prompt anything...
    As a thought, try to identify an event log or reliability history report with the safe mode crash.

    Also, try to work out what changed over the last two weeks, as I guess you have similar software configurations. What autoupdated or was updated or installed in that time?

    Do you have any restore points? (Probably too far back).
      My ComputerSystem Spec
  5.    27 Apr 2016 #5
    Join Date : Mar 2016
    Posts : 4
    Windows 10
    Thread Starter

    Thanks! I'll keep trying. The event logs (not yet from safe mode) show a number of crashes with iastordatamgrsvc.exe as well as the windows.storage.dll.
      My ComputerSystem Spec
  6.    11 Nov 2016 #6
    Join Date : Nov 2016
    Greece
    Posts : 4
    Windows 10 Pro x64

    Hello Everyone!
    I was about to make a new thread, as I couldn't find any similar problems with me, and got onto this one..

    I have the very very same problem. I use windows 10 x64 Pro, and had been experiencing this issue since before the anniversary update. Just as the TS describes. Every time I try to run a file, explorer.exe restarts (crashes). Happens everytime. And everytime I go into "this pc" and double click on a hard drive to open, it opens in one or two new window(s).

    Here's the story:

    Yesterday was the third time , i 've been experiencing this. 1st was at July 27. The anniversary update solved the problem, which led me to believe it was a windows update issue. After some days ,saw the same problem all over again. (5 August). Then I had a virus called sality (from an external way too old drive), and I thought that was the problem. I clean installed at 7th of August.
    Yesterday the problem came back, no viruses no nothing this time.

    The common pattern is that I keep seeing those in event viewer:
    Code:
    Faulting application name: explorer.exe, version: 10.0.14393.447, time stamp: 0x5819bde0
    Faulting module name: windows.storage.dll, version: 10.0.14393.206,
     time stamp: 0x57dacb3f
    Exception code: 0xc000041d
    Fault offset: 0x0000000000079fdf
    Faulting process id: 0x1afc
    Faulting application start time: 0x01d23bea4b0de9d2
    Faulting application path: C:\Windows\explorer.exe
    Faulting module path: C:\Windows\System32\windows.storage.dll
    Report Id: eb7b4715-fb7c-475d-a222-3ec6875f061d
    Faulting package full name: Faulting package-relative application ID:
    and

    Code:
    Faulting application name: explorer.exe, version: 10.0.14393.447, time stamp: 0x5819bde0
    Faulting module name: ntdll.dll, version: 10.0.14393.447, time stamp: 0x5819bc32
    Exception code: 0xc0000005
    Fault offset: 0x000000000004839c
    Faulting process id: 0x11e4
    Faulting application start time: 0x01d23bea6ff5f529
    Faulting application path: C:\Windows\explorer.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: 170714d1-bf1f-4967-a171-34d42dbeb401
    Faulting package full name: Faulting package-relative application ID:
    Searching for the exception codes, I was not able to justify the problem. The first and second time I got across the issue, I was only getting the "windows.storage.dll" faulty module, and the first exception code ( 0xc000041d ). The very first time I tried all of the above that the TS tried. I found no solution.

    Common at all times was that the "EVENT ID " was called "Event 1000 (100) "
    Searched for this, and came across to many really old problems, that were caused by windows updates and others from conflicting programs.
    The fact here is that I had just updated (at November 9) to "Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB3200970)" and had some problems (I manually updated , cos the update itself from windows update, could not be completed).

    In reliability monitor, I see "Windows Camera successfully updated" at 4:45 pm and some redistributable reconfigurations, at 3:10 pm due to Steep Open Beta Game installation through Uplay Client.
    The first explorer crash, indicated at 6:09pm.
    I am sorry for the long post, but noone , just noone could help me more, as the problem it seems that can be caused from about Anything... If anyone found anything on this ,will be much appreciated!
    Last edited by tommybertsen; 11 Nov 2016 at 03:32.
      My ComputerSystem Spec
  7.    11 Nov 2016 #7
    Join Date : Nov 2016
    Posts : 1
    Windows 10

    I had this same problem. I disabled the quick access and recent files item and it stopped the crashing.

    Update:

    It reappeared and clearing the recent items (even though it was disabled) stops it crashing and it appears to be associated network shares (in my case a samba share). As soon as I access that share file explorer starts to exhibit this behaviour.

    zb.
    Last edited by zabullet; 11 Nov 2016 at 10:26.
      My ComputerSystem Spec
  8.    11 Nov 2016 #8
    Join Date : Nov 2016
    Greece
    Posts : 4
    Windows 10 Pro x64

    Quote Originally Posted by zabullet View Post
    I had this same problem. I disabled the quick access and recent files item and it stopped the crashing.

    Update:

    It reappeared and clearing the recent items (even though it was disabled) stops it crashing and it appears to be associated network shares (in my case a samba share). As soon as I access that share file explorer starts to exhibit this behaviour.

    zb.
    I completely disabled quick access. I mean , from registry. I cleared everything as well. The problem didn't occur for one or two times, when I accessed files. And then , it did it again

    So , what do you excactly mean when you say about network shares? I just have one more pc in my network. The network, when the problem first occured (back in July ) , was Public. Now , it is Private ( I see no difference whatsoever). Do you still got the problem ?
    Thanx for the info though!

    edit: Completely disabling quick access causes some other issues (I cannot go to "system properties" directly (I have to go all the way to control panel). I re-activated it , I restarted manually the explorer, it didn't do it for some times again, and then it did it again. I just cannot understand what causes this... I am frustrated to the maximum. It's not like this is a super big problem, but it is frustrating to say the least..

    Edit 2 : As I watch my pc, it really slowly uses more memory (ram). It reaches using half my memory after 20-30 hours uptime. Than was never happening , and I cannot find what uses that amount of memory. I will just watch for some more days and then I will clean install windows once again , as this becomes more and more frustrating. For example, today it froze for about one minute, and then was everything ok , back to normal.
    PS: I did a memtest for the whole night , and it came out completely successful (just to rule out memory issues).

    Edit 3: I did clean bootup , and nothing changed.. After that, I rebooted at safe mode (with networking). The only thing was happening was the opening to another one or two windows. But explorer.exe didn't restart...

    Update: The problem , I am pretty assured, that is connected with windows permissions. I don't know why, but it crossed my mind to make a new (offline ) user account, and log in (gave admin rights first). It just logged in , and the problem disappeared!
    Making a new user account though, is complex, cos u have to set it all the way from the start. It's like formatting ,without formatting.

    Last edit ( I HOPE) . I did copy the files from old user account to the new one, EXCEPT the "ntuser" files. Everything came back to normal. I will watch how it goes and I will delete the old one, I made this as an admin , logged to my ms account, and it's just fine, the problem went away!
    Last edited by tommybertsen; 13 Nov 2016 at 13:40.
      My ComputerSystem Spec
  9.    10 Jan 2017 #9
    Join Date : Nov 2015
    Albany, NY
    Posts : 16
    Windows 10 Professional x64

    I have the exact same issues. Windows 10 x64 Enterprise (not the machine in my specs). Got a new laptop from my work and this has been driving me absolutely INSANE.

    Code:
    Faulting application name: explorer.exe, version: 10.0.10586.672, time stamp: 0x580ee8b2Faulting module name: windows.storage.dll, version: 10.0.10586.672, time stamp: 0x580ee6c4
    Exception code: 0xc000041d
    Fault offset: 0x000000000018305d
    Faulting process id: 0x33ac
    Faulting application start time: 0x01d26b745debd8ea
    Faulting application path: C:\windows\explorer.exe
    Faulting module path: C:\windows\system32\windows.storage.dll
    Report Id: 449a6a29-a5c8-4661-9a32-3153db52f6ba
    Faulting package full name: 
    Faulting package-relative application ID:

    I've tried the context menu stuff, different drivers, etc. etc. to no avail. Bumping this thread in hopes someone has come across a fix.
      My ComputerSystem Spec
  10.    10 Jan 2017 #10
    Join Date : Jan 2015
    UK, Midlands
    Posts : 11,138
    Win 10 Pro (1703)

    If it's a permissions issue, try Tweaking.com's free cautious repair tool (easy to find), following the cautious steps and selecting only the potentially relevant repairs.

    If you then still find you have no problems in a new user profile, then that suggests either
    a. Something is running or configured under the old profile that is causing this that is not running or configured in the new one
    or
    b. The old profile is corrupt

    If the same problem is experienced in both the existing and a new user profile, you can try an in-place upgrade repair install.
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
File Explorer keeps crashing
Hello guys! First of all, I am so sorry if this is the wrong section to post this problem in but I had a hard time locating where I should post it. After upgrading from Windows 8.1 to Windows 10, my file explorer simply keeps crashing when...
General Support
Solved Explorer.exe crashing and restarting loop.
About a minute after starting up, my desktop begins to start flashing to black and coming back in a continuous loop. The file explorer, however is completely unaffected. Is there any fix for this? Using Google I have found that this occurred back in...
General Support
File explorer keeps restarting
Hay guys. I have windows 10. And i have a problem. I installed windows 10 several months ago on one partition of my hard drive. This partition was just intended for testing windows 10, and i had another partition with my usual windows and one...
General Support
File Explorer Keeps Crashing
I have seen this on other threads but I haven't been able to fix it yet. I run Windows 10 on a Surface Pro 3 with 2 additional screens, a Dell and an LG. Everything has worked fine for the first few months, but in the last week I have had the...
Performance & Maintenance
File Explorer constantly crashing
I am having a problem with file explorer constantly crashing. If I click on the icon in the toolbar, file explorer will open, it will say "working on it," but then it crashes, the screen flashes, and it goes back to the desktop. If I try to open...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums