Windows 10: no bios

Page 2 of 2 FirstFirst 12
  1.    25 Mar 2015 #11

    Every source that I've read says it's the DEL key to get to the BIOS on a Gigabyte mobo.
    Have you tried rapidly tapping the DEL key as soon as you turn it on, and keep tapping it until it either boots to the BIOS or boots to Windows?

    If that doesn't work, then try another keyboard (and try another keyboard port).
      My ComputerSystem Spec

  2.    25 Mar 2015 #12

    For the record, I have a Gigabyte MB and I just simply press and hold DEL after turning on the PC and keep doing it till the Setup menu appears. Works for me everytime.
      My ComputerSystem Spec

  3.    25 Mar 2015 #13

    For legacy (non UEFI) BIOS it doesn't matter which OS or even if an OS is installed, you should be able to access it with it's default key.
      My ComputerSystem Spec

  4.    25 Mar 2015 #14

    Mark Phelps said: View Post
    Then, I must have an "abnormal" machine -- because it uses the old "legacy" BIOS and I have no problems getting into it, whether FastStartup is enabled or disabled. Besides, I thought FastStartup only affected the new "hibernation" implemented initially in Win8. I've not seen anything linking it to boot problems.

    Are you sure you're not meaning Fast Boot -- which is entirely different?
    I have seen numerous reports of issues trying to access the BIOS on boot up with Windows Fast Startup enabled. I don't know if its a UEFI thing or not, just that it does happen. Turn it off and you can then access the BIOS. It appears to be a result of the hybrid sleep mode the PC goes into instead of a full shut down.
      My ComputerSystem Spec

  5.    23 Oct 2016 #15

    Old post but new reply


    Hello everybody. I know it's an old thread, but this might work for some of you.
    Make sure your keyboard is plugged in an USB 2.0 port and not an USB 3.0 port.
    I do have a logitech G19 with a lot of LED-ligths and I could see that win10 does not recognize it in the early state of booting, but it works like a charm when I use an USB 2.0 port.
    Hope to save a few people from just a little frustration ;O)
    /Bentebom
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Just curious .. Not sure if it makes much difference , but should I pick Win 8 or other OS in my bios?
Greetings. I found a newer BIOS to my mobo, ASUS Maximus Ranger VII, but I'm not sure, that ASUS' EZflash will run/work in windows 10. Does anybody know something about this?
Hi everyone, It's not a Windows 10 thing, but maybe someone can help me ! I'm trying to revive a very old computer here. It's a 15 year old machine. I intend to install Windows 2000 on it. It's more for fun, I really don't need the machine,...
Used this tool, Download Microsoft® Hardware-Assisted Virtualization Detection Tool from Official Microsoft Download Center No go VMware said the same thing boo-hoo anyone have instruction to enable in bios ? Spec's are added, Cheers.
This is as serious as it sounds. When cold booting my Acer the Acer splash screen has lost the "Press F2 for setup" option. I can't now enter the BIOS. I tried three times. Shutdown and boot. No BIOS options. Fortunately by booting into a working...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:41.
Find Us