Host Process for Windows Services Stopped working

  1. Posts : 583
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon
       23 Apr 2016 #1

    Host Process for Windows Services Stopped working


    For quite some time now, on my main (primary) OS, which is Windows 10 Pro build 10586.218, I am getting this error:

    Host Process for Windows Services: Stopped working.

    I see this in my Reliability History. It might appear even several times per day! I clean my Reliability History with CCleaner and all my Event Viewer logs with a command from a tutorial from this site. After a little while, after I will reboot a couple of times, the error appears again!

    What is this and how can I fix it? Why am I getting it?

    I am not posting any screenshots for the time being but I will, as well as anything else asked, if considered necessary.

    Thank you.
      My ComputerSystem Spec

  2.    23 Apr 2016 #2

    That could be for a variety of services. Sometimes I'll get that error if I'm not connected to the internet and Windows Update isn't able to check for updates.

    Since that process goes to all Windows services, it may be difficult to know which service may be failing for you.
      My ComputerSystem Spec

  3. Posts : 583
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon
    Thread Starter
       23 Apr 2016 #3

    Hello and thanks for your reply.

    I've just checked my Reliability History and this error appeared four times today already! This morning I've cleared my Rel. History and now it's there four times already!

    Here is a screenshot from the technical details. It is exactly the same in all four instances.

    Click image for larger version. 

Name:	1.png 
Views:	4 
Size:	41.5 KB 
ID:	76367

    What is ESENT.dll?
    Why is it failing and how can I fix this?

    Thank you.
      My ComputerSystem Spec

  4.    23 Apr 2016 #4

    That DLL file used to run with Windows Update on Windows Vista, 7, and 8/8.1. Not sure if it's still with Windows 10

    Open an elevated command prompt.

    Type sfc /scannow

    This will check for system file corruptions
      My ComputerSystem Spec

  5. Posts : 583
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon
    Thread Starter
       23 Apr 2016 #5

    SFC /SCANNOW found corrupted files and successfully repaired them, as it claimed. Right afterwards I've cleared my Reliability History and my Event Viewer and rebooted. Immediately after rebooting the same error appeared!

    The only thing that SFC "repaired" was the openCL.dll in my SysWoW64 folder by turning it into a 27kb file...
    Now I have to clean-install the NVIDIA driver again.

    Is there anything else I can do about this?

    My computer functions well; I do not get any crashes, glitches, problems or BSODs, and I get all the updates, too. It's just that this error appears many times in my Reliability History and I don't know why..
      My ComputerSystem Spec

  6.    23 Apr 2016 #6

    Try this link.
    How to Fix

    Sorry about the opencl issue. That is a common issue right now as Microsoft has their own file of opencl and NVIDIA has their own version, so when sfc scans it, it sees it as a different version and replaces it with the Microsoft version. I apologize.

    This article relates to Windows Vista, but highly relevant.
      My ComputerSystem Spec

  7. Posts : 583
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon
    Thread Starter
       23 Apr 2016 #7

    Thanks for your help!

    I have tried a few suggestions from that article without any success though. I do not have ATI, I've booted in Safe Mode and the error still appears (I've cleared my Rel. history and the Event Viewer before that).

    This period I am also running the latest Insider build on my other SSD (dual boot). In the Insider preview this error does not appear, my history there is clean. It's true that on this primary OS I have applied a whole bunch of tweaks because I use it as my main OS and I wish to have FULL control. The Insider build I keep untouched besides a few suggestions from the well known "Sean's SSD Optimization guide for Win 8 / 8.1"

    Both Operating Systems have been clean installed, in both the latest drivers (from for my system have been used.

    No worries.

    Soon the Anniversary Edition will come so a clean installation will be performed again. I will keep this error in mind and check it out at that point in time.

    Thanks again :)
      My ComputerSystem Spec

  8.    23 Apr 2016 #8

    I'm getting the same error all the time too and Windows Update fails to work at times. So it's a new bug with the 10586.218 update.
      My ComputerSystem Spec

  9. Posts : 583
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon
    Thread Starter
       24 Apr 2016 #9

    lmaneke said: View Post
    I'm getting the same error all the time too and Windows Update fails to work at times. So it's a new bug with the 10586.218 update.
    Thanks a lot for this post of yours! For a moment I doubted myself in regard to my settings and the procedures I follow. Let's hope it will be fixed with a new update soon. My Windows Update by the way, works flawlessly but all I get is updates for Windows Defender - and some times, rarely, for Office 2016 Pro 32 bit, that I am using this period.
      My ComputerSystem Spec

  10.    24 Apr 2016 #10

    I had some Microsoft office updates and not all of them were downloading. It would download a couple and stop.had to restart my computer to get it to finish downloading. Never had that before.

    I currently use office 2007
      My ComputerSystem Spec


Related Threads
Hello I have a Teclast X2 Pro with Win 10 Teclast X2 Pro Review - A Powerful Surface Clone Now it has stopped working, it takes forever to log in and everything just freezes after just a couple of minutes. I have tried to format my drive...
windows 10 stopped working in General Support
I have gone back to windows 7 and will not go back to windows 10 , I have had nothing but problems with it for at least 3 weeks now , not sure what the last update edid but it screwed up my computer so I couldn't do anything on it , I couldn't...
I have an iMac dual booting Mac OSX and Windows 10 under Bootcamp. I have the normal iMac wireless keyboard. Windows has been running normally for several years since the day I got the computer. Windows 10 has been running normally since the...
Hello Everyone, I've never seen this problem with the previous O.S., Windows 7, but Windows 10 is throwing me this error message approximately 70% of the time when I run the network troubleshooter...either from the Control Panel, or by right...
Sometimes I get this Windows Error "Application Host Manager has Stopped Working" it will then show the progress bar and then disappears. Has anyone else experienced this or how do i fix this? Thanks
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:20.
Find Us