Windows 10: GPEdit Error Solved


  1. Posts : 113
    Windows 10 (2), Win 8.1 (1), Win 7 (1)
       14 Apr 2016 #1

    GPEdit Error


    After the latest Windows update, Group Policy Editor displays an error when starting. After clicking OK twice, the error clears. This is the second error that has occurred with GPEdit with Windows 10. A similar error occurred after the November update. Is there an easy way to fix this?

    JohnD
    Attached Thumbnails Attached Thumbnails GPEdit_Error.jpg  
      My ComputerSystem Spec

  2.   My ComputerSystem Spec


  3. Posts : 113
    Windows 10 (2), Win 8.1 (1), Win 7 (1)
    Thread Starter
       14 Apr 2016 #3

    Thanks. You really have to wonder what kind of testing MS is doing before they release these updates.

    JohnD
      My ComputerSystem Spec

  4.    17 Apr 2016 #4

    You're welcome and seems we are the test for their updates
      My ComputerSystem Spec


  5. Posts : 1
    Windows 10 Pro 32-bit
       24 Apr 2016 #5

    That "fix" was problematic for me. Although it fixed the Group Policy error message, when I ran SFC /SCANNOW it found corruption that it couldn't repair. So I ran DISM /online /cleanup-image /restorehealth and it restored the component store corruption. Then, SFC /SCANNOW was able to fix the corrupted file. After looking in the CBS log, the file that it "repaired" was the WindowsStore.admx that I modified using that link. So, I think for now, I'd prefer to live with the gpedit.msc error message.
      My ComputerSystem Spec

  6.    25 Apr 2016 #6

    Or simply uninstall the update and hide it, pending resolution..
    https://support.microsoft.com/en-us/kb/3073930

    (But don't hold your breath...)
      My ComputerSystem Spec

  7.    10 May 2016 #7

    Just copy back the old WindowsStore.admx. It will be necessary change permissions of the file. First set the new owner (right click the file -> properties -> security -> advanced -> change owner). Then edit the permissions for the administrator (full control). Delete the file and copy the old one. Remember to set Trustedinstaller as the owner of this old file (to do this add "nt service\Trustedinstaller" and set it's permissions to full control).

    The file is in the folder c:\Windows\Policy Definitions.
      My ComputerSystem Spec

  8.    11 May 2016 #8

    It seems to have been fixed in today's update for me, I don't get the error anymore.
      My ComputerSystem Spec


  9. Posts : 113
    Windows 10 (2), Win 8.1 (1), Win 7 (1)
    Thread Starter
       11 May 2016 #9

    I agree. Now fixed.

    JohnD
      My ComputerSystem Spec


 

Related Threads
Solved gpedit.msc not working in General Support
hi, sorry if this is in the wrong section, anyways when i open gpedit it says "MMC could not create the snap-in" I've googled etc but only fixes i can see are for older windows versions, tried one or two things just in case and nothing worked....
Solved Error when opening gpedit.msc in General Support
Started to get it a couple months ago. Time to look into it. Not really sure how. Copy of the closest file name I could find <?xml version="1.0" encoding="utf-8"?> <!-- (c) 2006 Microsoft Corporation --> <policyDefinitionResources...
Solved Error running Gpedit.msc in General Support
Was checking to see if build 1511 changed anything. It didn't. Not sure about understanding this error. TNX
Gpedit on Windows 8.1 home in General Support
I have installed this program: How to Enable (gpedit.msc) in Home and Starter Editions of Windows 7 and Later - AskVG on my Windows 8.1 home machine. Now i would like to back up the gpedit settings before installing windows 10, because windows 10...
Windows Defender and gpedit.msc in AntiVirus, Firewalls and System Security
It seems my Windows Defender disabled for forever, I tried to turn it on back but it said something like turned off using Group Policy, so I run gpedit.msc then I search Windows Defender under Administrative Templates but there's no Windows Defender...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:27.
Find Us