Windows 10: Windows 10 - Class not registered and urlmon.dll errors

  1.    13 Apr 2016 #1

    Windows 10 - Class not registered and urlmon.dll errors


    Hey all, hopefully somebody there can help.

    I have been getting the same errors over and over again on my desktop. I cannot access my start menu or Cortana. My task bar isn't always functional either. When I try to open up settings via task manager (ms-settings, try to open something recently downloaded through Firefox, or try to create a new profile, I get an error message saying Class not registered.

    I have tried some solutions online, none have worked.

    I have tried:
    - scf /scannow on cmd.
    - Using Powershell to run: Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    - Renaming and/or deleting my Tiledatalayer folder in AppData/Local

    Also I keep getting this error stating "C:\WINDOWS\SYSTEM32\urlmon.dll is either not designed to run on Windows or it contains an error." This message ends with "Error status 0xc000012f".

    Has anybody come across this?

    Thanks in advance.
      My ComputerSystem Spec

  2.    14 Apr 2016 #2

    HI and welcome to the forums


    I don't believe you have posted this in the correct section, but they will move it for you.


    If i'm correct URLMON.DLL is used by windows to go "online" and retrieve information (i'm not 100% sure).


    The sfc /scannow command scans all protected system files and replaces incorrect versions with correct MS-versions.
    When the scan was completed, did the tool indicate integrity violations?

    Dit you recently install any new software? Maybe some software is holding it back, therefore I would suggest for you to do a clean boot.
    With a Clean boot you will eliminate software conflicts that occur when you install a program or when you run a program in Windows.
    Check if the issue persists when you do a clean boot, if not you can go from there and try to eliminate what's causing the issue.


    How to perform a clean boot in Windows
    https://www.tenforums.com/tutorials/41804-clean-boot-perform-windows-10-troubleshoot-software-conflicts.html








    Last edited by zztemp; 14 Apr 2016 at 02:51. Reason: provided better tutorial
      My ComputerSystem Spec

  3.    14 Apr 2016 #3

    Thank you for the reply, sorry I'm in the wrong area, I'm new here . I haven't installed anything new lately, but do have Windows updates set to automatic, big mistake there I'm now guessing.
      My ComputerSystem Spec


 

Related Threads
Hello. I have all updates applied to the Windows 10 Professional x64 bit machine. Started Windows 10 this morning and tried to open a JPEG file, i.e., double click any.jpg. Windows 10 comes back with, "Class not registered". Cleaned all the...
Hi, I recently upgraded to win 10 from 8.1 and I am running into a few problems. I'll start with this very annoying one and than open a different thread for the others. So I like to save URL links on my desktop - used to work fine on 8.1. Now...
Hi i Click on (Change adapter settings) and i get a error pops up 51519 how can i fix this? i have done SFC 6-times did not work:(
I have only had Windows 10 for a few days --- mostly it is working well but a major fault is that when searching from Cortana, or clicking on a link, I almost always get the error 'class not registered'. Yesterday I was prevented from installing...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:44.
Find Us