Windows 10: Cannot make system image - VSS error 12289 Solved

Page 3 of 4 FirstFirst 1234 LastLast

  1. Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       11 Mar 2015 #21

    Thanks for the update adam,

    Here are some disk references:
    How was Win8.1 installed? Was it pre-installed on the machine or did you install it?
    You probably already visited these Windows on Mac (WoM) pages:

    Boot Camp - Apple Support

    Boot Camp 5.1: Frequently asked questions about installing Windows 8 - Apple Support
    • Things that stood out as I scanned the page, I have no idea if they apply or not.
    • On one of the pages it recommends Boot Camp 5.1 - make sure you're MAC is up-to-date. I didn't see any other important updates on the download page, but you'd be a better judge of that. I'm sure you run the Mac Update periodically.
    • To install Windows and the Boot Camp Support Software, you need a flash drive or other USB media, which must be formatted for the FAT file system. But later it discusses using an ISO for Windows ??????
    • Thunderbolt devices ???

    How to install Windows using Boot Camp - Apple Support

    Set up a Windows partition on your Mac - Apple Support
    • Things that stood out as I scanned the page, I have no idea if they apply or not.
    • If you have more than one internal drive and the drive you're partitioning is not in the first drive bay, remove the drives in the lower-numbered bays, then reinstall them after installing Windows.
    • If the installer says that it couldn't create a new partition or locate an existing one, disconnect any Thunderbolt storage devices connected to your Mac

    That's about all I can think of - hope it helps or points you in the right direction.

    Good luck,

    Bill
    .
      My ComputerSystem Spec


  2. Posts : 804
    10 Pro Preview x64
    Thread Starter
       11 Mar 2015 #22

    Thanks Bill. I installed 8.1 on one partition (which is fine and supported according to your technet links as long as you don't want to use bitlocker) and upgraded that to 10. Then I wiped and did a clean install on the same partition. Your links confirm that there is no requirement to have a separate system partition.

    I've always installed windows using mbr on macs using one partition and it has been fine.

    The question is about system images - while the partitioning could be an issue it wasn't at eight so something has changed (either a bug or a requirement change I've not seen).

    I may try creating another partition but it isn't trivial as mbr only supports 4. I'd have to move the OSX recovery partition next to the EFI and extend the GPT protective partition to cover it before I could create another. I'd also have to manually create the contents of the system partition as the windows installer wouldn't do it. I guess that would work but according to technet installing BIOS based windows on 1 partition is OK anyway.
      My ComputerSystem Spec


  3. Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       11 Mar 2015 #23

    Thanks again for the feedback - yep, I understand the issue is about System images, specifically VSS.

    I asked Lee to see if the issue exists on her machine (Windows on Mac) and to weigh in on your thread if the same issue occurs or if the issue is not present.

    I wouldn't bother trying to create a another partition - the next Win10 release will be here soon, it might be 'fixed'.

    Did you feed MS the information?

    Glad you were able to confirm things, sorry it didn't help much.

    I tested System Image on my setup and one thing I noticed is that it picked a partition that was too small, I had to change it to one that could contain the image. That begs the question: Where are you storing the image?

    Also, please launch an elevated Command Prompt and type
    reagentc /info
    exit
    Post what Windows thinks about the Recovery Environment.

    Thanks,

    Bill
    .
      My ComputerSystem Spec


  4. Posts : 804
    10 Pro Preview x64
    Thread Starter
       11 Mar 2015 #24

    I'd certainly be interested if someone else running 10 on a mac (not in a VM) can make a restore point. It would be good to rule that out.

    For recimg and restore points I was using C: which is 80% free. I also tried a backup to a 32GB SD card (more than big enough) and it failed with the same error.

    I'll report on the feedback app also - I was hoping to be able to put more than "it doesn't work" though

    Here is the reagent info. Partition 4 is my C: drive
    PHP Code:
    C:\>reagentc /info
    Windows Recovery Environment 
    (Windows RE) and system reset configuration
    Information
    :

        
    Windows RE status:         Enabled
        Windows RE location
    :       \\?\GLOBALROOT\device\harddisk0\partition4\Recovery\WindowsRE
        Boot Configuration Data 
    (BCDidentifier79f196fe-c34e-11e4-8aa0-97095480a43b
        Recovery image location
    :
        
    Recovery image index:      0
        Custom image location
    :
        
    Custom image index:        0

    REAGENTC
    .EXEOperation Successful.


    C:\> 
      My ComputerSystem Spec


  5. Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       11 Mar 2015 #25

    Thanks, hopefully Lee will drop by.

    VSS tracing is out of my league, but these references might help:

    How to: VSS Tracing - Ask the Core Team - Site Home - TechNet Blogs

    Using Tracing Tools with VSS (Windows)
      My ComputerSystem Spec

  6.    11 Mar 2015 #26

    Hi guys. . . Hopefully this will help. 1.) I use VMWare for the Mac or Parallel for running different OSs. 2.)I also use Boot Camp in which I am running windows 7 at the present time. Now if someone is unable to run windows 10 they could attempt to load up windows 7 or 8 in boot camp then try to do an upgrade to either one of those OSs with win 10. As to doing a clean install with Windows 10 in Boot Camp I have yet to try. . .sorry wasn't planning on doing so until the final hits the street. 3.) Now you could go over to Mac Rumors: Apple Mac iOS Rumors and News You Care About, and then to the Boot Camp forum to see if maybe someone can help you out there. Haven't have time as of yet to explore it, will try to make time later this eveinging. . .good luck. . .
      My ComputerSystem Spec


  7. Posts : 804
    10 Pro Preview x64
    Thread Starter
       12 Mar 2015 #27

    I've got 2 MBP - one with clean install of 9926 one with 8.1 upgraded to TP (also now on 9926). Both have the same issue in bootcamp (native Windows boot) I've not tested with VMs as I rarely use OSX but I will set one up today. I asked on the mac forum also.

    Thanks to Bills links I managed to download the SDK and make a trace of creating a restore point and recimg using this command vsstrace.exe +f 0xffff -o C:\temp\recimg.txt. The trace files are huge and I don't know where to start looking really. I've uploaded them in case anyone else knows what to look for. There is some stuff about it writing OK to the backup location but then messages about aborting.

    Code:
    [19:26:31.803 P:1480 T:1EE4 INCICHLH(0200)    IOCTL] Opening a handle to \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy7 (access = 0x00000000, share = 0x00000003)
    [19:26:31.803 P:1480 T:1EE4 INCICHLH(0300)    IOCTL] The object '\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy7'. was opened under the device handle 0x000001e4
    [19:26:31.803 P:1480 T:1EE4 INCICHLH(0451)    IOCTL] IOCTL sent: 53019c on device \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy7
     Input buffer size: 0, Output buffer size: 4096
    [19:26:31.803 P:1480 T:1EE4 INCICHLH(0549)    IOCTL] IOCTL 53019c succeeded on device \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy7 - 0x000001e4. 
     Output buffer: size received = 108
    Code:
    [19:26:31.808 P:1FFC T:1D54 CORSOFTC(0163)    COORD] EXIT[CVssSoftwareProviderWrapper::Release] Time spent: 00:00:00-0000; total: 0; HRESULT: 0
    [19:26:31.808 P:1FFC T:1D54 CORSNPSC(1217)    COORD] EXIT[CVssSnapshotSetObject::ThawWriters] Time spent: 00:00:00-0015; total: 0xf; HRESULT: 0x80042306
    [19:26:31.808 P:1FFC T:1D54 CORSNPSC(0828)    COORD] HRESULT exception caught: hr: 0x80042306
    [19:26:31.808 P:1FFC T:1D54 CORSNPSC(0831)    COORD] ENTER[CVssSnapshotSetObject::DoSnapshotSet_failure_block] 
    [19:26:31.809 P:1FFC T:1D54 CORSNPSC(0850)    COORD] Abort detected while commiting the snapshot set 0x80042306
    Cannot make system image - VSS error 12289 Attached Files
      My ComputerSystem Spec

  8.    12 Mar 2015 #28

    Unfortunately, there's not a large number of MacBooks running BootCamp with Win10 for us to check on.
    I only get 1 or 2 a month at work. with 8.1 installed.

    There's a large number of Windows Update failures in the WER section of MSINFO32
    Have you checked for updates recently?

    The only thing that I spotted in the reports that I'm not familiar with is the EMET toolkit (Enhanced Mitigation, Experience Toolkit).
    Have you tried removing that?

    Beyond that, I'd be interested in seeing if you can run the commands on a completely fresh install of 10 using a new copy of the installation media. That'll help to rule out the OS itself and the installation media.

    Good luck!
      My ComputerSystem Spec


  9. Posts : 804
    10 Pro Preview x64
    Thread Starter
       12 Mar 2015 #29

    John, Everything is up to date in Windows update. I uninstalled EMET but the issue is the same. I'll download a fresh copy of 9926 and try it again without installing anything at all.

    Thanks all for keeping suggesting things as I sure would like to be able to make backups...
      My ComputerSystem Spec


  10. Posts : 804
    10 Pro Preview x64
    Thread Starter
       12 Mar 2015 #30

    The cause is the Apple HFS driver applehfs.sys.

    This happens with bootcamp version 3.2 (driver creation date 10/15/2010) and 5.1 (creation date 1/31/2014).

    If the driver is disabled through Autoruns for Windows then after reboot system image, recimg and restore points all work. I've tested this on 2006 core 2 duo running the old driver version and 2012 MacBook pro running the new one and in both cases disabling this driver is sufficient. Note that enabling this driver will delete all restore points you may have made.

    It does mean you can't see HFS partitions which is a bit of a bugger but there we are. Perhaps Apple will make a Windows 10 compatible driver one day.

    Thanks for the input everyone - there is no Windows error here.
    Attached Thumbnails Attached Thumbnails AutoRuns.PNG  
      My ComputerSystem Spec


 
Page 3 of 4 FirstFirst 1234 LastLast

Related Threads
Backup & Restore Create System Image in Windows 10 in Tutorials
How to Create a System Image in Windows 10 A system image is an exact copy of all system disks which can be used to restore your PC to the state it was in at the time the image was made. By default, a system image only includes the drives that...
How to Create Hardware Independent System Image for Installing Windows 10 In this tutorial we will prepare a Windows 10 image customizing the default user profile and install software we want to include in a clean Windows installation. When...
I installed the 32 bit version of W10 on an old Acer laptop to get back up to speed with developments, and one of the first questions or issues that cropped up is when using W10's disk image utility to make a system image. I deliberately wished to...
I have made a little video for someone on another forum who wanted to make a quick image and mount that image in order to retrieve some data. Don't ask me why he wanted to go that route. I made him a little video explaining the process and I want to...
Solved How can we make a hidden operating system in Installation and Upgrade
Please can some one tell me how to make a hidden operating system in Windows 10 without using True Crypt. Basically I want to have a dual boot system with one of the operating system's being hidden/encrypted. Similar to the way True Crypt does it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:59.
Find Us