Windows 10: Problem Ejecting Sandisk Flash Drive


  1. Posts : 2
    Windows 10 Professional
       26 Feb 2016 #1

    Problem Ejecting Sandisk Flash Drive


    Whenever i try to eject my Sandisk flash drive, by right-clicking on it's icon and clicking on "Eject Cruzer",
    I get an error window with the title, "Problem Ejecting USB Mass Storage Device".
    The message says, "Windows is unable to stop the device 'USB Mass Storage Device'.
    Don't remove this device while it is still in use. Close any programs using this device and then remove it."

    This only happens the first time I attempt to eject my flash drive since connecting it.
    The second time I try to eject it, it always works.

    Does anyone have any idea what the problem could be?
    I know it's not a problem with my flash drive, because it works just fine on other computers.

    I tried uninstalling and reinstalling the driver for the flash drive in the Device Manager, but that didn't work.
      My ComputerSystem Spec

  2.    26 Feb 2016 #2

    Hi retroboy87,

    I don't why that's occurring, but just so you know, you should be able to configure the flash drives so they are safe to just pull out, rather than "safely removing them." I know this is not an answer, but more of a 'work-around' if needed. It should already be defaulted that way as well. More HERE.

    Click image for larger version. 

Name:	ScreenShot001.jpg 
Views:	25 
Size:	54.8 KB 
ID:	66569


    b1rd
      My ComputerSystem Spec

  3.    26 Feb 2016 #3

    The safely remove is there to make sure that all write buffers have been written. That is normally the case if you give it a couple of seconds. The 'false' busy signals can be ignored at that time.
      My ComputerSystem Spec


  4. Posts : 2
    Windows 10 Professional
    Thread Starter
       26 Feb 2016 #4

    Thanks for the replies.

    I already have Quick Removal enabled.
    I know I can just pull my flash drive out without safely removing it, but I want figure out what's causing this problem.
    I'm fine with using Quick Removal in the mean time though.
      My ComputerSystem Spec


  5. Posts : 14,942
    Microsoft Windows 10 Pro 64-bit 14393, Windows 10 Insider Fast Ring, Windows 8.1 Update, Ubuntu
       27 Feb 2016 #5

    Is any program using it?
    I mean is it music that a media player is pointed to, is it being used to back up data?
    Is it mounted in File Explorer?
    You can also try running chkdsk in case it was pulled once when writing wasn't finished.
      My ComputersSystem Spec


 

Related Threads
Solved USB Flash Drive UEFI problem in Installation and Upgrade
Hello Tenforums.com No matter what I do, my Lenovo Flex 2-14 doesn't seem to recognise my USB as an UEFI Windows bootable flash device, despite following this guide...
now im a computer tec and i know that memory cards and hdd are sold as "base 10" like 1gb=1000mb to them instead of 1024mb but im revisiting this question because i was looking into this for some time now and there are some people claiming thats its...
Hi, I've had win10 about 2 months now and mail app wouldn't work and weather app stopped after the first day, this week Photo app stopped and usb 3 port locked up and some games graphics were slow. I made a recovery drive on a flash drive and...
Solved Problem with my 16 GB Sandisk OTG in Drivers and Hardware
Problem with my 16 GB Sandisk OTG I tried all USB ports with no success. Computer does make the sound suggesting that the device is connected but nothing shows up on screen.My pendrive shows as ... (3 dots) in " Safely Remove hardware and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:03.
Find Us