Windows 10: Intermittent failure to run startup programs Solved

  1. Posts : 19
    Win10 Tech Preview
       11 Feb 2015 #1

    Intermittent failure to run startup programs

    Apologies if this is posted elsewhere. but I haven't been able to find anything recent about it.....

    I'm running build 9926 and I find that, intermittently, no startup programs (i.e. programs registered under registry "Run" keys - both HKLM and HKCU - or in Start Menu\Programs\Startup etc.) do not run either on restart or reboot from shutdown. Sometimes everything starts fine, and sometimes it doesn't!

    I have found something similar related to shortcuts with elevated permissions, but I do not believe that is the case with my problem, since the problem is not consistent, and I cannot find anything to relate it to.

    Has anyone else noticed this, and is there any workaround?

      My ComputerSystem Spec

  2.    17 Feb 2015 #2

    Then please run the following DISM commands to see if there's any problems with the system (from an elevated (Run as administrator) Command Prompt). Press Enter after each one:
    Dism /Online /Cleanup-Image /ScanHealth
    Dism /Online /Cleanup-Image /CheckHealth
    Dism /Online /Cleanup-Image /RestoreHealth
    FYI - I have repaired systems using the last command even though problems weren't found with the first 2 - so I suggest running them all.

    From this article: Repair a Windows Image

    You can also run sfc.exe /scannow from an elevated (Run as administrator) Command Prompt to check for further corruption.
    Last edited by Brink; 17 Feb 2015 at 11:13. Reason: added tutorial link for more info
      My ComputerSystem Spec

  3. Posts : 19
    Win10 Tech Preview
    Thread Starter
       17 Feb 2015 #3

    Thanks for your suggestions. I ran the 3 DISM commands with these results:

    Click image for larger version. 

Name:	dism 2-17-15.JPG 
Views:	26 
Size:	88.5 KB 
ID:	12807

    (Hope you can read them!)

    SCANNOW failed with the following message after "Verification 3% complete":

    "Windows Resource Protection could not perform the requested operation"

    The final line in sfcdetails.txt reads:

    2015-02-17 12:05:39, Info CSI 0000001d [SR] Cannot repair member file [l:20{10}]"secdrv.sys" of Macrovision-Protection-SafeDisc, Version = 10.0.9926.0, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, file cannot be decompressed

    From what I can gather from further googling, secdrv.sys is a regular part of Windows. I believe it arrived on my system from a clean install of Win8.1 immediately prior to installing build 9926 of the Win10 TP from downloaded iso file obtained from

    Please let me know if sending you the DISM log would be of any benefit!

    Thanks again for your help.


    Edit: I have since attempted to run sfc from boot following the suggestions in the link. I believe my boot directory is C:\ (thats what Disk Management indicates) and the windows directory is c:\windows. I use those parameters for offbootdir and offwindir, but the process comes to completion in about 30 seconds. I don't think that's right!!!!
    Last edited by greybat; 17 Feb 2015 at 19:04. Reason: add additional information
      My ComputerSystem Spec

  4. TechnoMage's Avatar
    Posts : 352
    Win 7 Pro/32, Win 10 Pro/64/32
       19 Feb 2015 #4

    The first time I installed Widows 10, there were some weird problems. So I wiped the drive and installed W-10 again.
    The second time everything worked OK. Go figure!

    But we has similar problems on the beta versions of Win-8. Nothing new!

      My ComputerSystem Spec

  5. Posts : 19
    Win10 Tech Preview
    Thread Starter
       19 Feb 2015 #5

    Funny you should say that.....

    I'm just about finished doing just that, and the problem seems to have gone away. This time I re-formatted the hard drive, then re-installed from bootable flash drive.

    Thanks for your help.
      My ComputerSystem Spec

  6.    20 Feb 2015 #6

    Sometimes the OS seems to need a kick in the behind to get it working properly.
    Glad that it worked for you!
      My ComputerSystem Spec

  7. Posts : 19
    Win10 Tech Preview
    Thread Starter
       22 Feb 2015 #7

    I think I may have a clue as to the cause of this problem, in case anyone else experiences the same symptoms!

    I suspect that the cause is related to the Atheros Combo Wireless & Bluetooth driver (version that I acquired from the Acer website. My computer is an Acer E5-511 model.

    I noticed yesterday that the existing BT driver updated by Win10 appeared to be working, but would not identify and pair with any BT devices. So I ran the setup program for the (Win 8.1) driver from Acer, which installed OK, and I was then able to pair with BT headphones. However, the next restart did not run the startup programs.

    So, I have done a System Restore and it appears the problem has gone away again. Not only that, I can still pair my BT headphones! So I guess I will stick with the Win10 driver!

    Edit: Also tried to update the Atheros AR956x WLAN driver only (no BT component) to Same problem, so maybe it's the WLAN driver component causing the problem.
    Last edited by greybat; 22 Feb 2015 at 18:20.
      My ComputerSystem Spec


Related Threads
hello guys, In task manager I can see all programs which are supposed to start together with windows, however, none is starting… Every time I start windows I have to start these programs manually. Anybody else with the same behavior?
Hi, I'm not sure IF this is the appropriate section to post this thread, I'm going to do it anyway, though. On Windows 10 build 10162 I have tried for the first time ever the Virtual Desktop feature. It is awesome! I wish to have at least one...
Hey, I installed a large update today that I assume was my upgrade to Windows 10 Pro from the Insider Preview (as it's no longer plastered all over the bottom-right corner of my screen). All was well, until earlier when I was playing World of...
failure got any other suggestions? in Drivers and Hardware
Spent most of yesterday downloading the recommended 10076 and installation on my Dell latitude D 510. Ok not only don't the sound and video drivers load (Same problem as old system 9926 ) This install did not load the browser so I can't even get...
Solved SSD Failure in Drivers and Hardware
Last year I replaced an aging hard drive in my Mum's pc with a slightly less aging OCZ Vertex 2 SSD. This morning she was using the pc just fine then left it until this evening when it suddenly would not boot and reported sata drive failure. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:20.
Find Us