Cannot open Windows 10 Settings - ImmersiveControlPanel repair/rebuild


  1. Posts : 1
    Windows 10 10240
       #1

    Cannot open Windows 10 Settings - ImmersiveControlPanel repair/rebuild


    Issue: Cannot open settings app in Windows 10 - corrupt ImmersiveControlPanel repair/rebuild:

    What fixed my settings app incase of "TL-DR":

    Folder Location: C:\Windows\ImmersiveControlPanel\

    Running cmd as admin:
    From C:\
    cd Windows
    rename ImmersiveControlPanel ImmersiveControlPanel.old
    SFC /scannow

    SFC will rebuild ImmersiveControlPanel.

    Settings was working immediately after.


    Hello everyone,
    My Windows 10 install was suffering from this issue for some time. I finally decided to try and work out a fix since it's a public holiday and I have time. This issue was annoying but since It only really affected the settings app I left it in the "I'll get to it later" basket, A typical self employed tech with no time for their own computers. Other functions like apps, appstore and start menu in Windows were unaffected.

    Being a computer tech it frustrated me not being able to find any info on what fixed this in the end for me. I am sure this info is out there somewhere but I could not find it. I've decided to post this here so it can benefit someone just like me when trying to find a solution to this obscure problem.

    The only persistent Windows 10 issue I've come across where I couldn't justify a fresh install was on my own computer. No firm idea on what caused it, But I suspect it likely would have cropped up about the time when I had a few random graphics driver crashes and BSOD (nvidia fixed this in the next driver). That was a few months ago (october-november) and that was when I last remembered my settings app was working fine.

    My symptoms:
    • Cannot open Settings from Start Menu (Will flash on screen then close - No useful info in event manager)
    • Cannot open Settings from shortcut (If manually created)
    • When opening other functions to do with settings would get errors refering to ms-settings for example on display settings:


    "ms-settting:display This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel"



    • No issue with start menu or the opening of other apps (not related to settings) including app store
    • Could browse and install/open new apps
    • While this issue persisted Windows updates were not able to download or install
    • Windows was stuck on build 10240 - Could not install 1511 update


    Any other function that relied on the Settings app would not work - for exampleisplay settings


    • Personalisation settings
    • Lockscreen settings
    • Windows update (for me)
    • etc


    Fixes that I have tried:
    • CHKDSK /F and /R from within Windows and Live CDs (Only minor issues found)
    • SFC /Scannow (Before my fix in the end it did not fix anything)
    • System Restore
    • Tried the powershell Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} fix
    • Tried the DISM /Online /Cleanup-Image /RestoreHealth fix
    • Create a new user
    • Could not upgrade with 1511 Windows disc


    The fixes that did not fix my issue above may still have enabled my fix to be successful later however.

    Anyway, If anyone has an issue similar hopefully this is helpful for them in some way. Hopefully this issue will become searchable now. I'm sure that I am not the only person to have had this although I have only ever seen this on my own computer. Perhaps I am the only one?

    Cheers
      My Computer


  2. Posts : 1
    Windows 10
       #2

    This worked perfectly! After trying absolutely everything else and having no luck what so ever I'm incredibly grateful for your help!
    Last edited by Brink; 06 Sep 2016 at 12:38. Reason: removed quote of 1st post
      My Computer


  3. Posts : 1
    Windows 10
       #3

    PogmaN suggestion to RENAME IMMERSIVECONTROLPANEL/SFC SCAN worked perfectly, after months of troubleshooting. The issue was on a Surfacepro 4 everytime they Docked or UNDOCKED.
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:28.
Find Us




Windows 10 Forums