Screen flashes after windows startup

Page 1 of 3 123 LastLast

  1. Posts : 52
    Windows 10 Version 1703 (x64)
       #1

    Screen flashes after windows startup


    Hi everyone,

    I'm having a weird issue since i installed windows 10, After installing, drivers, apps, etc., suddenly after using the PC for a few days, after startup apps finish loading and everything, when i try to open any application (browser, explorer, something with uac prompt, anything..) The screen flashes and turns off for a second and then everything come back to normal, This is my 2nd fresh installation for windows 10, I thought there could be something wrong with the drivers, i double checked them, I even replaced all of the apps that i used to have! , spent lots of time to look for alternatives (Avira instead of Kaspersky, 7zip instead of WinRAR, etc.), It may seems like a simple problem, But it's really frustrating for me, I never had this issue with windows 8.1, I hope that someone would help me with that .

    OS Version: Microsoft Windows 10.0.10586 Enterprise 1511 TH2 (x64)
      My Computer


  2. Posts : 3,264
    Windows 11 Pro 64 bit Version 21H2
       #2

    Welcome to Ten-Forums !
    How about Graphics Card drivers, updated also ? Sound like an issue there with Graphics card or drivers, although screen flicker was an old issue at first when Windows 10 came out but i believe most were solved.
      My Computer


  3. Posts : 52
    Windows 10 Version 1703 (x64)
    Thread Starter
       #3

    Hi jds63, I've uninstalled the driver many times, even used a third party application (Display Driver Uninstaller) to totally remove it, re-downloaded and installed the latest version of my ATI driver again.
      My Computer


  4. Posts : 3,264
    Windows 11 Pro 64 bit Version 21H2
       #4

    Surreal90 said:
    Hi jds63, I've uninstalled the driver many times, even used a third party application (Display Driver Uninstaller) to totally remove it, re-downloaded and installed the latest version of my ATI driver again.
    Recently make any changes to PC, hardware or software ? When screen turns off is there a light on monitor that goes out or turns a different color, does it say no signal on the screen at that time ? Check to make sure you are using the native resolution and refresh rates for monitor and card. Check cables are secure to monitor and card. Feel this does point to the graphics card, driver or conflict with something else on system, another hardware driver or process.
      My Computer


  5. Posts : 52
    Windows 10 Version 1703 (x64)
    Thread Starter
       #5

    Haven't made any new changes sw/hw, I even thought that could be the problem, so i changed almost all the apps i used to use, the monitor itself flash and goes black, and before it goes back to normal, it looks like windows interface is like building up or something like that, you know. I'm using the proper resolution, refresh rate, latest gpu driver for my PC, What do you think that would be?
      My Computer


  6. Posts : 3,264
    Windows 11 Pro 64 bit Version 21H2
       #6

    Surreal90 said:
    Haven't made any new changes sw/hw, I even thought that could be the problem, so i changed almost all the apps i used to use, the monitor itself flash and goes black, and before it goes back to normal, it looks like windows interface is like building up or something like that, you know. I'm using the proper resolution, refresh rate, latest gpu driver for my PC, What do you think that would be?
    O.k. this happens with just about everything you do or use on PC ? Building up, like pixelating (square blocks) ? How old is the AMD card ? I am just thinking if anything is loose or Card has issue and or drivers. Try checking the card in the case, make sure fan is working, try reseating the card and possibly check temps with HWInfo.
    http://www.hwinfo.com/
      My Computer


  7. Posts : 52
    Windows 10 Version 1703 (x64)
    Thread Starter
       #7

    It always happen once i start my pc and try to open any application (any browser, music player, that applies even for the windows explorer), It's not like "pixelating" It's like.. some parts of the interface are black and get built up in less that a second, while the screen is giving this giving this flash, my AMD card is not that old, got it less that a year ago i think (AMD Radeon R7 265), I checked the fans now and both of them are running, Also checked the temp and it's 39
      My Computer


  8. Posts : 3,264
    Windows 11 Pro 64 bit Version 21H2
       #8

    Surreal90 said:
    It always happen once i start my pc and try to open any application (any browser, music player, that applies even for the windows explorer), It's not like "pixelating" It's like.. some parts of the interface are black and get built up in less that a second, while the screen is giving this giving this flash, my AMD card is not that old, got it less that a year ago i think (AMD Radeon R7 265), I checked the fans now and both of them are running, Also checked the temp and it's 39
    So not really and kind of flicker. And only happens once, something i was not certain of. Try it in safe mode to see if it occurs, this can tell me if something else on system is causing this.
    https://www.tenforums.com/tutorials/2...dows-10-a.html
      My Computer


  9. Posts : 52
    Windows 10 Version 1703 (x64)
    Thread Starter
       #9

    I went through my installed apps and drivers, Uninstalled AMD driver, monitor driver, changed UAC settings to max, and restarted my pc , It seems that i'm not getting any flashes so far, gonna try to restart it a couple of times open some apps and stuff and see whether it would happen again or not..
      My Computer


  10. Posts : 3,264
    Windows 11 Pro 64 bit Version 21H2
       #10

    Surreal90 said:
    I went through my installed apps and drivers, Uninstalled AMD driver, monitor driver, changed UAC settings to max, and restarted my pc , It seems that i'm not getting any flashes so far, gonna try to restart it a couple of times open some apps and stuff and see whether it would happen again or not..
    Uninstalled your AMD driver, but which version of this driver did you replace it with ? Monitors rarely need particular manufacturer drivers and UAC to max is going to cause you too many alerts if i have this correct what you did. Here

    Screen flashes after windows startup-untitled.jpg
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:11.
Find Us




Windows 10 Forums