Page 1 of 2 12 LastLast
  1.    07 Dec 2015 #1
    Join Date : Dec 2015
    Posts : 9
    Windows 10 N

    Cant open pictures. Remote procedure call failed


    Hello community,

    I have a really frustrating problem with Windows 10 N (fresh installation, no upgrade from 7) and I'd really appreciate your help!

    I'm getting this error:Click image for larger version. 

Name:	screenshot.png 
Views:	17 
Size:	794.4 KB 
ID:	52527
    ... when I try to open any picture (jpeg, gif).

    I have followed different forum topics for solutions and so far I:
    - Double checked that RPC service is running & on automatic. RPC Locator is not started & on manual
    - Previously had some issues with opencl.dll being corrupted, but following Kyhi's suggestions here:
    Error DISM restorehealth - Windows 10 Forums
    .. I managed to fix it (as you can see from the screenshot, the sfc shows no errors anymore)

    In the event viewer I get these:

    Activation of app Microsoft.Windows.Photos_8wekyb3d8bbwe!App failed with error: The remote procedure call failed. See the Microsoft-Windows-TWinUI/Operational log for additional information.

    ActivateApplicationForContractByAcidAsUserWithHost of the app Microsoft.Windows.Photos_8wekyb3d8bbwe!App for the Windows.File contract failed with The remote procedure call failed..

    Activation of the app Microsoft.Windows.Photos_8wekyb3d8bbwe!App for the Windows.File contract failed with error: The remote procedure call failed..

    Activation via contract helper of the app Microsoft.Windows.Photos_8wekyb3d8bbwe!App for the Windows.File contract failed with The remote procedure call failed..

    ... when I try to open a jpeg file.

    Any help will be much appreciated!

    Best regards,
    Marin
      My ComputerSystem Spec
  2.    07 Dec 2015 #2
    Join Date : Aug 2015
    Posts : 369
    Windows 10 Pro

    What happens if you simply attempt to start Photos app through Start Menu?
      My ComputerSystem Spec
  3.    08 Dec 2015 #3
    Join Date : Mar 2015
    UK
    Posts : 5
    Windows 10 Pro Build 10586

    Same thing happened to me today. I thought it was down to several system changes that I had made like installing Kaspersky Safe Kids, however this was not the case. It appears that the latest Windows 10 build changes the Photo Viewer to another which causes the computer to throw this Remote procedure call failed. At first I thought that some malware had stopped the RPC Service from running however this was not the case. I found the simple answer is to switch back to the Windows Photo Viewer in the new apps settings menu.

    1. Click "Start", then click "Settings".
    2. Click the first option "System".
    3. On the left side second from the bottom, click "Default Apps".
    4. Click the name of the App under "Photo Viewer" (Should currently say "Photos").
    5. Select "Windows Photo Viewer".

    Open a photo and you will see that the icon has changed now every photo now matter the format will now open I am using Windows 10 Pro Build 10586.
    Attached Thumbnails Attached Thumbnails default-apps.png  
    Last edited by SpideRaY; 08 Dec 2015 at 15:58. Reason: to add screen dump
      My ComputerSystem Spec
  4.    08 Dec 2015 #4
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,555
    Windows 10 x64 Home Build (Redstone(1)) 15063.608

    I can recommend the one posted by SpideRaY I use it myself.
      My ComputerSystem Spec
  5.    08 Dec 2015 #5
    Join Date : Nov 2015
    Posts : 4,779
    windows 10 Home threshold2

    Phot Viewer is no longer listed in Windows 10.
    It has been replaced by Photo app.
    If you want to use Windows Photo Viewer, you will need to restore it.
    Use this tutorial :
    How to Restore Windows Photo Viewer in Windows 10
    https://www.tenforums.com/tutorials/1...dows-10-a.html

    excerpt from Information section of the tutorial :
    Usually you could use Windows Photo Viewer to view your image files in a variety of ways. You can also print, order prints, attach pictures to an e‑mail message, burn, or open photos in another app on your PC.

    Windows 10 uses the Photos app as the default app to open image files with instead now. By default, Windows Photo Viewer is no longer listed in Open with, and only has .tiff files associated with it in Default Programs.

    This tutorial will show you how to restore Windows Photo Viewer to be able to select to open image files in Default apps, Default Programs, and Open with for all users in Windows 10.

    You must be signed in as an administrator to be able to restore Windows Photo Viewer.
      My ComputerSystem Spec
  6.    08 Dec 2015 #6
    Join Date : Aug 2015
    Posts : 369
    Windows 10 Pro

    "Windows Photo Viewer" is the classic photo viewer from Windows 7. It is immediately available in Windows 10. However, since Windows 7 it suffered from a serious color management bug, which Microsoft stubbornly ignored. Once you enable color management in Windows, Windows Photo Viewer will display all pictures as very dark.

    This is actually why the new Photo app is very welcome (if only it did not have a half-life of two weeks or so).

    In any case, switching to WPV is not a real fix. Note that problems with Photo app are typically "fixable" through creating a new account.
      My ComputerSystem Spec
  7.    08 Dec 2015 #7
    Join Date : Mar 2015
    UK
    Posts : 5
    Windows 10 Pro Build 10586

    System File Checker


    The Photo app has worked fine for me over the last few months. I only started causing me problems today after Windows 10 update the build the day before. I use a variety of software to open photos and pictures so I guess whatever was updated in build 10586 caused the RPC error in this particular app ?

    I have just performed System File Checker using the Admin Command prompt (sfc /scannow) and all seems fine I am gonna stick with the Windows 7 WPV for now as I normally use third party software rather than the system to access my pictures.

    Also this little tool WinFix maybe worth a look @ http://www.thewindowsclub.com/downloads/FixWin10.zip
    Last edited by SpideRaY; 08 Dec 2015 at 16:51. Reason: to add WinFix Link
      My ComputerSystem Spec
  8.    09 Dec 2015 #8
    Join Date : Dec 2015
    Posts : 9
    Windows 10 N
    Thread Starter

    Thank you all for your suggestions!
    I did another preinstall of the OS and now the Photos are working.
    I have no idea what went wrong the first time.
      My ComputerSystem Spec
  9.    10 Dec 2015 #9
    Join Date : Mar 2015
    UK
    Posts : 5
    Windows 10 Pro Build 10586

    Found this excellent website by Thomas Vanhoutte that allows you to purge your Windows Apps using and Admin Windows Power Shell https://thomas.vanhoutte.be/miniblog...indows-10-apps

    Copy and paste this to the Power Shell this also seems to work without a restart. When finished
    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    Click image for larger version. 

Name:	purge windows apps.png 
Views:	5 
Size:	14.5 KB 
ID:	52977

    This fix may also remove the WPV and you will be left with only MSP so if you still want use Windows Photos Viewer then download this reg tweak from Shawn Brink on this very forum @ https://www.tenforums.com/tutorials/14312-windows-photo-viewer-restore-windows-10-a.html
    Last edited by SpideRaY; 10 Dec 2015 at 12:28.
      My ComputerSystem Spec
  10.    10 Dec 2015 #10
    Join Date : Aug 2015
    Posts : 369
    Windows 10 Pro

    Quote Originally Posted by SpideRaY View Post
    Copy and paste this to the Power Shell also seems to work without a restart
    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    This command is rather well-known way to redeploy universal apps. Unfortunately it is unlikely to fix many typical problems with Photos app. The damage that prevents Photos from starting apparently resides in the user profile, which this command does not fix (while creating a new user profile often "fixes" the issue)

    On top of that, when I last time tried using this command, it dumped a bunch of entries with cryptic ultra-long names into my Start Menu.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
The open procedure for service miApRpl, MSDTC, LSA, ESENT, BITS...
Does anybody out there know how to solve these event log errors? EventID 1008 Windows 10 x64 Pro (1511 bld10586.3) The usual solutions on Internet are all talking about WSS_WPG ( Windows SharePoint Services Worker Process Group) but likely...
Performance & Maintenance
Cryptographic Services failed while processing the OnIdentity() call
I am seeing the following errors in my Windows 10 Pro x64 event log: Cryptographic Services failed while processing the OnIdentity() call in the System Writer Object. Details: AddLegacyDriverFiles: Unable to back up image of binary...
General Support
Windows 10 Print Spooler stops & Remote Procedure Call Issue
I've had Windows 10 since Monday, I haven't been able to print anything, even making PDF files because the print spooler will not start. Or more accurately, it will start and then when you try to add a printer, it will stop. When I run the printer...
General Support
Remote Procedure Call (2)
Ever since downloading the updates for 10130 on my Surface Pro 3 (after a clean install) the Service Host: Remote Procedure Call is going crazy, running constantly at 50%+ CPU, as a result of which the device is constantly running hot and battery...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums