I started getting these odd delays. Cortana's button would no longer open her. when I pressed the windows key or pressed the start menu, it took about 2 seconds to pop up...
Very odd, my PC has an i7 4790k, and 8gb of RAM, and an r9 290 in it all on an SSD with plenty of space. None of my resources were being utilized or filled. Never had this issue before, similar stubborn Cortana issues around release, but definitely not on this install, and it didn't occur as aggressively or as situationally.

I may have narrowed it down, and wonder if there are other causes/cases to this problem?

When I make Cortana do make by searching in the bar, she displays it in a popup as the top result.
Now, usually, you can click that top result, and be taken into a mini-calculator environment inside of the cortana window, at least, it was like that last week...
Today when I clicked that (i do lots of math), it came up with a "Thinking...." message, but never redirected to the internal calculator. Thought nothing of it, until a minute or two later, this delayed start/cortana won't open glitch started.

I sfc Scannow'd my PC, DSM Restore Health'd it, tried reinstalling all apps through powershell again ("BAD idea, first service package DOES NOT like this, corrupted all my apps, had to restore to previous point). Even after a restore back, this issue remained. Very very odd to me.

Ending Cortana's process doesn't even fix it. Once this glitch is triggered, it does it every 2 minutes again even if you don't type in any more math problems. I have to either repeatedly end SearchUI.exe in details and Cortana at the same time before the other starts up again, or sign out of my computer, restart from the logn screen (can't restart logged in, or the issue comes back) then sign in again after restart....

Have yet to confirm if other interfaces of Cortana give me an eternal "Thinking...." or this new glitch yet. This just happened today to me, and I've never seen Cortana "Think..." so hard before.

EDIT: searching "forecast" and clicking the little box with the temps and weather condition makes her "Think..." as well. What could be wrong here? It's like all of Cortana's little features are broken, all I can do is search apps or search online, but her integrated search tools are busted. All of the Notebook cards in Cortana still display and operate correctly, it's Cortana's internal apps that aren't behaving.

Such an odd glitch, not an ounce of this troubleshooting seems to make sense, why what I am trying helps it, or why this even happens in the first place. Even tried uninstalling the last update, still here though. Must be some odd hotfix in Cortana.

Anyone, let me know if you experience this start menu delay/unresponsive cortana recently and let me know your troubleshooting and/or possbile solutions.