Page 2 of 3 FirstFirst 123 LastLast
  1.    25 Nov 2015 #11
    Join Date : Oct 2015
    Posts : 1,966
    Windows 10 Pro X64

    Hi guys,

    Unfortunately I'm in the same boat as TS.
    No matter what I do the error keeps on coming back at every reboot. It's driving me up the walls really.

    This is a clean install with hardly anything on it except for Win 10 build 10586 and its updates to V14.

    TIA,
      My ComputersSystem Spec
  2.    25 Nov 2015 #12
    Join Date : Aug 2015
    Posts : 82
    10 Ent 64
    Thread Starter

    What I see is that it say authority needs to be given "to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19)". But I tried the other suggestions and used admin as last owner and got 181 errors after reboot. Then I restored and back to the 1 error and a couple of 7031s. Gonna live with it as long as it's not hurting anything. Thanks
      My ComputerSystem Spec
  3.    25 Nov 2015 #13
    Join Date : Oct 2015
    Posts : 1,966
    Windows 10 Pro X64

    Hi,

    That SID is Local Service itself.
    I just finished checking the settings on my Enterprise install (10240) and all these reg keys belong to "Trusted Installer" and I don't see any events flags regarding DCOM there.
    IOW, settings were exactly the same as before we started changing ownerships in the registry.

    Strange..........

    Cheers,
      My ComputersSystem Spec
  4.    26 Nov 2015 #14
    Join Date : Aug 2015
    Posts : 82
    10 Ent 64
    Thread Starter

    Yea I didn't have them with the 10240 ent. either but they popped up with the TH2 update.
      My ComputerSystem Spec
  5.    26 Nov 2015 #15
    Join Date : Oct 2015
    Posts : 1,966
    Windows 10 Pro X64

    Hi,

    I don't recall seeing them on an upgrade install I did but this error shows up on a clean install (empty disk) and a Windows to Go USB drive I created as well.

    So I guess there must be plenty of other machines out there with this error popping up in Event Viewer.
    Other than that it doesn't seem to do any harm.
    What annoys me though is that I can't seem to come to grips with it (but that's just me).

    Cheers,
      My ComputersSystem Spec
  6.    26 Nov 2015 #16
    Join Date : Nov 2015
    Posts : 1
    Windows 10 Insider Preview

    After many weeks of toiling with this issue I discovered a pretty effortless way to fix the issue and created a post about it here: etcetera Fixing 10016 on Windows 10: The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
      My ComputerSystem Spec
  7.    26 Nov 2015 #17
    Join Date : Aug 2015
    Posts : 82
    10 Ent 64
    Thread Starter

    Can't remember seeing that msg and I'm to the point that even though its there it don't hurt nothing so I'm gonna give up unless someone comes up with an easier surefire way to fix this; like maybe a bat file or something. Old people like me have a hard time just getting up in the mornings. Thanks
      My ComputerSystem Spec
  8.    26 Nov 2015 #18
    Join Date : Oct 2015
    Posts : 1,966
    Windows 10 Pro X64

    Hi,

    Can't remember seeing that msg
    I sure did and you do need to accept it otherwise you wont be able to add "Local Service".

    So, after having tried out just about everything I could think of including cpriest's method which is quite similar to what I'd tried already, nothing changed.
    In fact it only got worse.

    I decided to restore a backup from an upgrade install that was error free only to notice that after a few reboots the same problem cropped up.
    So I started a new fresh install. Once that was done it did take long for the same events to pop up again.
    My conclusion is that it must be a rather harmless bug and I'll just leave it unless a magical solution is offered. I keep my fingers crossed......

    I had 10240 as clean as a whistle though so even though TH2 seems to offer some advantages, I can't say I'm entirely happy with it. Guess that's how this game works, right ?

    Cheers,
      My ComputersSystem Spec
  9.    26 Nov 2015 #19
    Join Date : Oct 2015
    Posts : 1,966
    Windows 10 Pro X64

    Hi,

    Reinstalled and lo and behold there were these errors in event log.
    Ran sfc/scannow then DISM and used the wim file from my install ISO.

    All errors are gone now.

    Previously I'd used a different wim file that ran fine and reported no errors as far corrupted files go but........ .

    Lesson learned. IOW, I found a way to fool sfc and dism but shot myself in the foot in the process.....Hehe.

    Wouldn't have happened if sfc hadn't reported corruption in the first place. After a clean install?? Shouldn't happen.

    Cheers,
      My ComputersSystem Spec
  10.    27 Nov 2015 #20
    Join Date : Aug 2015
    Posts : 82
    10 Ent 64
    Thread Starter

    I ran sfc with a new iso download also but the 10016 and 7031s popped up; they will return, they're gremlins.
      My ComputerSystem Spec

 
Page 2 of 3 FirstFirst 123 LastLast


Similar Threads
Thread Forum
Windows 10 Event ID 10010 and 10016 Errors With DistributedCOM
I am having a number of events that seem to be located repeatedly with the source: DistributedCOM Event ID: 10010 and Event ID: 10016 also getting repeatedly Service Control Manager Event ID: 7031
Performance & Maintenance
Solved Error 9/22/2015 3:40:32 PM DistributedCOM 10016 None
I do THANK all whom has helped me on my memory DUMp Error it was bad memory!!T This has happened serval time this month so far Now I have one more BSOD error details in ZIP thanks for all the Help :( Error 9/22/2015 3:40:32 PM...
BSOD Crashes and Debugging
event ID 10016 - immersive shell
Hello - I have implemented the permissions I've seen advised on here and the MS answers forum, but the error is still occurring. Perhaps a fresh pair of eyes will spot something. Here's the error from the event viewer, and an image from dcomcnfg...
General Support
Persistent SMART error on cloned drives (Error code: 2000-0151)
I am on my 4th SSD in my Windows 10 laptop that has been getting SMART error 2000-0151. We have replaced the motherboard, the SSD, and the connector cable between the SSD and motherboard. One thing is that I've been using Macrium Reflect to clone...
Drivers and Hardware
Event 10016, DistributedCOM
Since upgrading to Windows 10, my error log is flooded with this message. Over 520 incidents in the past week. The instructions provided for that error in Windows 8 do not work with 10, since it is impossible to grant full permission to the...
Performance & Maintenance
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:17.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums