Still getting this error code after the recent upgrade. Any suggestions on solving this issue