Windows 10: W10 changes timestamps on executables after running them. Normal?

Page 2 of 2 FirstFirst 12
  1.    02 Oct 2015 #11

    I am almost pretty sure it happens when any AV puts an executable in quarantine and you release it. It happened again with an executable quarantined in the destination usb drive by Panda Antivirus. It had its date updated for the time when it was scanned by the AV. I guess all AV programs do this then.

    I am still investigating though.

    PS - That was on a Windows 7 machine, just to clarify.
      My ComputerSystem Spec


  2. Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc
       02 Oct 2015 #12

    Is the executable part of a regular program or stand alone app? I have one old game title VIPRE loves to see the main exe file locked up repeatedly despite adding it to the exceptions list. Never saw any time stamp change however.

    In fact I checked it now and it shows August 10, 2015 when I saw the clean install replace the pooched upgrade I ran with for the first week. For some reason the newer 2016 beta as well as the 2015 versions saw it as a bug while the 2014 never saw that come up.

    While I suspect restoring something might be the av program simply copying it back to the drive I doubt you see numerous files each with their own time stamp changed thar were never locked up but possibly being backed up and restored in some manner. If the av program should happen to modify not copy particular files that would account for some seeing this. In years past AVG would clean files that got buggy back in the XP days however.
      My ComputerSystem Spec

  3.    03 Oct 2015 #13

    I think I have may nailed it down to those antimalware software that uses AutoIT.
      My ComputerSystem Spec


  4. Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc
       03 Oct 2015 #14

    I figured it would end up being a 3rd party source you would need to track down. If it was simply a Windows bug nothing would work right! The system processes would be all over the place!
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
I don't use touch, I don't have touch, I don't want touch. So why am I locked with a monster big calculator? Is there a way to get the old small calculator back? I have tried to just copy the calc.exe from windows 8.1, but that don't work. If...
Solved BSOD under normal use. in BSOD Crashes and Debugging
Hello, This is a Asus ux305. I've had it less than a month and is mostly used for my school. I have installed very little on it. Was just browsing the internet on chrome when it crashed. Thanks in Advance.
I'm running the RTM on a netbook and have noticed that, unlike in Windows 7/8/8.1, I'm no longer able to hit Start and type in an executable. I have a bunch of portable apps that I typically type in and pull up. Now, the Start menu search pulls up...
Hello Usually when you hit start and begin typing the name of the program you want to start, it shows up right away, right? I have a clean install of windows 10 on my C: drive and programs on the F: drive that are from when I used w7 (not ok i...
X86 install in Oracle VB works as normal in Installation and Upgrade
Just finished installing Win 10 Preview X86 in a Oracle VB (2GB ram). Installed fine and runs fine. Looks and feels like Windows 8.1. The new Start menu is okay but I prefer Stardock's Start8 (so far). Too much intermix of normal Start menu...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:48.
Find Us