How to fix windows boot manager on dual boot (Linux) system?


  1. Posts : 76
    win 10
       #1

    How to fix windows boot manager on dual boot (Linux) system?


    Not sure where to post, so will try here first.

    I have a PC with Windows 10 and Linux Mint on. Each time I start up, I'd press an F button to call up the boot menu, offering Ubuntu Windows Boot Manager / SSD model number. Selecting Ubuntu would take me to Linux's boot menu (GRUB), where I continue with Linux or tap down to Win Boot Manager. It should make a difference, but thought I'd mention the extra step for me at the beginning - usually, normal systems are presented with just the GRUB menu. To be honest, I'm not sure if having a dual boot environment affects the issue I've described below.


    When I select Windows Boot Manager in either menu, I would get the 'Preparing Automatic Repair' message, then the 'Diagnosing your PC' message. Then I'm just presented with the message saying automatic repair couldn't repair .....

    Going into Advanced Options and choosing start up repair also yields nothing.

    I have also tried using Macrium's fix bootup problems - it seem to do something to the BCD but ultimately unable to boot upon restart. I am just presented with the following:

    Recovery
    Your PC / device needs to be repairs
    The operating system couldn't be loaded because the system registry file is missing or contains errors.

    File: \Windows\system32\config\system
    Error code: 0x0000225

    It then goes onto say

    Press Enter to try again
    Press F1 to enter Recovery Environment
    Press F8 for startup settings


    I had a similar issue on a standalone Win 10 system in the past, but gave up.

    Is there a sure-fire way of fixing this issue please?
      My Computer


  2. Posts : 9,750
    Mac OS Catalina
       #2
      My Computer


  3. Posts : 76
    win 10
    Thread Starter
       #3

    @bro67

    Thanks for the link and info - will give it a read and am sure it'll come in useful for future ref.

    On this occasion, I think it's just a Windows boot issue, hence I'm not posting under Linux forums as I don't want to mess up the GRUB.

    Re. Windows, I was going to try the BOOTREC cmd prompts after loading a windows recovery disk and going into 'Repair your computer', but I believe this is only valid for EFI systems?

    Looking at my disk in Macrium, the disk is configured as GPT (not LBA); has a primary partition labelled Recovery of 529mb and a primary formatted FAT32 (LBA) partition of 100mb. Not sure if this info helps in further diagnosing the solution to my non-bootable Windows install?

    Thanks for any guidance.
      My Computer


  4. Posts : 9,750
    Mac OS Catalina
       #4

    You are over thinking this. If you are going to run Linux alongside Windows, use WSL or a VM no Dual Boot.
      My Computer


  5. Posts : 76
    win 10
    Thread Starter
       #5

    bro67 said:
    You are over thinking this. If you are going to run Linux alongside Windows, use WSL or a VM no Dual Boot.
    Thanks, but I don't think I'm overthinking anything. I'll bear in mind your suggestion for running Linux alongside Windows in future, but doesn't exactly help me with the issue I currently have at hand.

    Maybe forget the fact that it's a dual boot machine; I just think it's more of a windows boot issue.

    Being a specialist site, I'm surprised not many more have responded with suggestions to a resolution.

    I've tried the bootrec commands and followed a few YT videos, but to not avail. One bootrec command (/fixboot) returns an Access denied message - any ideas?

    I think I may have an image of the drive from a while back, but I don't just want to restore that image, as files & programs would have changed in both Windows and Linux envrionments.

    Bearing in mind my drive configuration (GPT; non-EFI drive but has Recovery partition of 529mb and FAT32 (LBA) partition of 100mb), would I be able to copy boot / registry config files from the good image and paste that into my current problematic drive? If it's a viable solution, which files would I need to copy?

    Thanks
      My Computer


  6. Posts : 9,750
    Mac OS Catalina
       #6

    It is not a Windows boot issue. When you install LInux and choose to use Grub, it can redo the EFI partition and Windows tends to not want to work alongside Linux in dual boot situations. Use a VM or WSL if you want to run Linux. I posted the information and there is plenty of information on here on how to correct your problem.
      My Computer


  7. Posts : 76
    win 10
    Thread Starter
       #7

    Not sure it's a Linux / GRUB issue, as has been working fine until one day I decided to boot into Windows, it gave me the problem I've described. As mentioned, I've experienced this in the past, but on a standalone Windows PC.

    If it was a GRUB boot issue, I wouldn't have been able to boot into Linux and reply to you here within Linux.

    As an experiment, I took an image of this dual boot config in Macrium before I started playing around to try and fix the issue. The idea is, if I try the various solutions and doesn't work, I can always restore Windows to it's corrupted state before I messed about trying to find a solution.

    With this in mind, I left the Linux partitions as they were, but deleted the Recovery, FAT32 (LBA) and main C: NTFS partitions, restoring them with the imaged copies. Linux still boots fine, but it is Windows boot / start up which is giving me a headache.

    Hence I'm asking experts here to confirm where and which boot files I should be looking out for, IF I can find a past image which booted fine into Windows.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:46.
Find Us




Windows 10 Forums