Can't boot after running mbr2gpt


  1. Posts : 2
    Windows 10
       #1

    Can't boot after running mbr2gpt


    Hello all.
    I was recently working on upgrading one of my workstations from Window 10 to Windows 11.
    The first step should have been making a backup, but of course I skipped that.

    I ran mbr2gpt /validate - Validation completed successfully
    Then I ran mbr2gpt /validate /allowFullOS - Validation completed successfully
    Finally I ran mbr2gpt /convert
    and here is what it kicked out:

    MBR2GPT: Attempting to validate disk 0
    MBR2GPT: Retrieving layout of diskMBR2GPT:
    MBR2GPT: Validating layout, disk sector size is: 512 bytes
    MBR2GPT: Trying to shrink the OS partition
    MBR2GPT: Creating the EFI system partition
    MBR2GPT: Installing the new boot files
    MBR2GPT: Performing the layout conversion
    MBR2GPT: Migrating default boot entry
    MBR2GPT: Adding recovery boot entry
    MBR2GPT: Fixing drive letter mapping
    MBR2GPT: Conversion completed successfully
    Call WinReReapir to repair WinRE
    MBR2GPT: Failed to update ReAgent.xml, please try to manually disable and enable WinRE.
    MBR2GPT: Before the new system can boot properly you need to switch the firmware to boot to UEFI mode!

    I then went into the bios and changed to UEFI and enabled Secure Boot but Windows was unable to boot.
    I attepted startup repair - no luck.

    I then tried to start with a Windows 10 install disk. When I did this, I was unable to see the drives.
    I then changed back from UEFI to Legacy and started up with the Windows 10 install disk. Now I could see the disks.
    I ran chkdsk /r and then rebooted

    Instead of Windows loading, I'm getting a softthings technologies display that shows when the drive was erased (from before we purchased it). Strange.
    Just as an FYI - it shows this data if it is helpful

    Dell Precision 5820 Tower
    NVMe PC601 NVMe SK hynix 512 GB - 476.94 GB - NVME ( - MBR)
    NVMe Micron 2200S NvMe 1024GB - 953.87 GB - NVME( - MBR)
    [] - 0.00 GB - Unknown (C - MBR)

    As I'm writing this, I'm running clonezilla to backup the data from the drive.

    This thread appears to be identical to my issue: Need Help with MBR2GPT

    But the issue is, if I'm stil in UEFI, I can run reagentc /info BUT I can't run the following:
    reagentc /disable
    reagentc /enable

    I've still got about 30 minutes left before my backups are done but would love to get your feedback.

    Thanks in advance!
      My Computer


  2. Posts : 42,943
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #2

    Seems your Recovery partition in your original build may not be properly configured.

    However, this seems to be a problem some experience.

    See:
    MBR2GPT Failed to Update ReAgent.xml on Windows 10? [Full Fix]

    - after the alternative approach suggested (use Minitool) there are more suggestions.
      My Computers


  3. Posts : 23,172
    Win 10 Home ♦♦♦19045.4291 (x64) [22H2]
       #3

    @rheide99


    I don't know what your BIOS looks like... but these were things I needed to do to be able to boot after changing from MBR to GPT disk...

    For... Boot Device Control, I had to choose either UEFI and Legacy OPROM or UEFI only

    Under Secure Boot, I had to choose... Windows UEFI Mode




    Can't boot after running mbr2gpt-image1.jpg
      My Computer


  4. Posts : 2
    Windows 10
    Thread Starter
       #4

    Thanks for your responses.

    Once my backup is done, I will run through the 4 main ideas from the page and provide images.

    Also, I'll try to get some images of my BIOS as well as images of diskpart, etc. so you can see what I'm dealing with.

    Thanks again!

    - - - Updated - - -

    Quick update:
    I was stilling having issues accessing the drives so I ordered a new NVeM drive from Amazon.

    I created a bootable Windows 11 usb drive.
    With UEFI enabled, I had similar issues where the drive was not found.

    Made sure BIOS was up to date - it was.

    The BIOS can clearly see the drive so it didn't see like the BIOS was the issue.
    I then download the Intel Rapid Storage Technology Enterprise Driver and copied the files to another USB Drive
    https://www.dell.com/support/home/en...driverid=660hv

    This time when Windows said it couldn't find any drives, I browsed to the extra usb drive and loaded the drivers and BOOM. It found the files and is now installing Windows.

    This doesn't solve the original issue but I thought it might spark some additional ideas.

    Once Windows is done installing, I'm going to go back and work on getting the original drive to work.

    - - - Updated - - -

    Here is what the original NVMe drive looks like when connected to another computer.
    I believe there should only be 3 partitions so that is probably 1 item I need to fix!

    Can't boot after running mbr2gpt-diskpart.png
    Can't boot after running mbr2gpt-diskmgr.png
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:08.
Find Us




Windows 10 Forums