FOlder Read-Only Keeps Resetting

  1. Posts : 238
    win10 20H2

    FOlder Read-Only Keeps Resetting


    got a plugin filter thing for Photoshop, installed it and works fine [legit thing from a proper company]. Issue is, you can save settings for a particular filter set-up but when i do i got the "no permissions" error. I'm logged in as admin, went to the folder, unchecked the read-only button, apply/ok, it vanished. same error appeared; checked the folder, read-only button is checked. retried unticking it, the next folder levels up etc, happens the same on each - how to i get the damn thing to stay writeable?
    folder is in
    c: -> program files -> Adobe -> Photoshop cs5 -> plugins.

      My Computer

  2. Posts : 68,823
    64-bit Windows 11 Pro for Workstations


    If the box has a solid black square in it, then it's not read-only. Only if it's checked.

    You can try an option in the tutorial below to unset the Read-only attribute for the folder.

    Set or Unset Read-only Attribute of Files and Folders in Windows 10
      My Computers

  3. Posts : 16,901
    Windows 10 Home x64 Version 22H2 Build 19045.4170

    Brink is correct.
    - To put it all a different way, whatever your problem is it is not that read-only checkbox shown by File explorer for that folder.
    - File explorer's read-only checkbox on folders is virtually meaningless; Windows ignores it so you might as well ignore it as well. Things have been like this for over a decade.
    If you have nothing useful to do and want to waste part of your life, you can study these explanations.
    folder read-only indicator [KeithM] - TenForums
    Read Only (Folders) - [Fred Long, LemP] MSA forum
    You cannot view or change the Read-only or the System attributes of folders [Win7 etc] - MSSupport
    I have studied them but, since I do not hate you, I do not suggest that you study them.

    Your problem is with the Permissions set for the folder that the plug-in's options are saved to.
    I imagine that you must run that PhotoShop plug-in [or perhaps PhotoShop itself] as Admin in order to be able to save its settings.
    Doesn't the plug-in's publisher provide guidance on setting it up?

    Best of luck,
      My Computer

  4. Posts : 238
    win10 20H2
    Thread Starter

    thanks for the replies guys.
    i *seems* the issue was photoshop - i think being open, it had some hold/lock on the folders? i closed it down, tried the folder settings again and fired up PS again and had no issues.
    Odd the explorer thing changed the radio button box etc w/ no errors.

    re above, there was nothing special about the plugin, it literally just plugs in, and has a simple Save option where you can save a setting to the folder where all the packaged settings are.

      My Computer

  5. Posts : 16,901
    Windows 10 Home x64 Version 22H2 Build 19045.4170

    wolfie138 said:
    Odd the explorer thing changed the radio button box etc w/ no errors.
    Yes, it's a real botch job.
    I get the impression that awkward to achieve changes are just left to be considered in future major re-writes. It's just like leaving the crack in the bathroom wall until you need to re-plumb the house.

    All the best,
    And thanks for the rep,
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:24.
Find Us

Windows 10 Forums