Desktop PC not sleeping since KB5022834


  1. Posts : 3
    Windows 10
       #1

    Desktop PC not sleeping since KB5022834


    I use an old Windows 10 PC as a kind of home server. I have it set up so it sleeps once no one is using it. It has been working nicely for years.

    However, yesterday morning it installed KB5022834 and now it won't sleep. I tried the usual diagnostics - there are no requests and it's not a wake problem - it's just refusing to sleep even though it should be idle. But then I looked at the system sleep diagnostics and - whoa - since the update there are *no* user not present intervals. It seems like the PC is never going idle at all.

    Then I tried uninstalling KB5022834 and that didn't help. So now I'm just completely baffled. I'm not sure how to find what's keeping it awake and I'm not even sure that KB5022834 is the problem - maybe the reboot just triggered something else or maybe it's just a coincidence. All I know is that it has been working for a long time and suddenly stopped.

    It's running 22H2 (19045.2604) and should be fully up to date with patches etc.

    Any ideas about what it could be or diagnostics I should try?
      My Computer


  2. NTN
    Posts : 969
    W10 19045.2546
       #2

    You probably have done things right, but you could just check this article about the problem.....

    "https://www.freecodecamp.org/news/windows-10-is-not-going-to-sleep-how-to-fix-sleeping-on-pc/#:~:text=Step%201%3A%20Press%20WIN%20%2B%20I,while%20plugged%20in%20(charging)."

    Too long to post here, so you better read it. May there is something you have missed.

    How to Fix Sleep Mode Not Working on Windows - Make Tech Easier
      My Computers


  3. Posts : 3
    Windows 10
    Thread Starter
       #3

    I figured that something was resetting the idle timer, maybe a buggy device or something. Though it was hard to believe, given that there is more or less only a mouse connected . Anyway I found this autohotkey script

    Code:
    loop
    {
      Sleep, 500
      Tooltip, %A_TimeIdle%
    }
    
    ESC::
    ExitApp
    from here Windows 10 Desktop PC will not go to sleep automatically based on set idle timer no matter what I try. What else can I try? - Super User which shows the idle timer. And from that I could tell that the idle timer was counting up as expected so that was not the problem.

    So, as a last resort I thought I would check for any system file corruption. So I did the usual:

    Code:
    DISM.exe /Online /Cleanup-Image /RestoreHealth /Source:C:\RepairSource\Windows /LimitAccess
    
    sfc /scannow
    and to my surprise the sfc did fix something, though I couldn't really work out what. And now it's working again!

    To be honest sfc has never worked for me before and it was really a last resort. But now I'm happy again.

    - - - Updated - - -

    Well that was weird. It worked fine for about 12 hours, sleeping and waking as expected. And now the problem is back. No sleep. Seems like the system file check didn't work: it was just a coincidence. I've retried it and no problems found.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:46.
Find Us




Windows 10 Forums