Cannot copy files to a new drive


  1. Posts : 106
    Windows 10 Pro 20H2
       #1

    Cannot copy files to a new drive


    I just installed an M.2 drive for my D: storage drive. The mobo has two M.2 slots & I got a good deal on a Samsung NVMe drive & figured why not.

    I'm able to create new folders but cannot copy data into them. I copied data from old PC to EHD to PC with the new SSD.

    Initially I was able to copy Firefox profiles onto the new drive & they worked. Then I went to copy Thunderbird profiles & only the first 5 files get copied & I get the following error message.

    "An unexpected error is keeping you from copying the folder. If you continue to receive this error. You can use the error code to search for help with this problem.
    Error 0x800701B1: A device which does not exist was specified."

    I tried different USB ports but to no avail. Also I cannot deleted these files & get the same error message. I tried a different EHD & have the same problem.

    I created a new folder for documents, IOW the drive is letting me write to it. Then I tried to copy a folder of documents & again only the first 5 files get copied, but they can't be deleted either.

    Any suggestions on how to fix this would be appreciated.
    Thanks
      My Computer

  2. Pejole2165's Avatar
    Posts : 868
    Windows 10 Pro
       #2

    If you are certain the drive is supported by your boards M.2 slots, check to see if there are any BIOS updates specifically dealing with M.2 drives with that board, it is not uncommon for some boards to require a compatibility update.
    Have you installed the Samsung NVME driver?
    Try re seating the drive.
    I would then try the drive in the second slot to see if maybe the first slot is faulty (one slot is from the CPU, the other is from the chipset).
    If still no joy can you try the drive in another machine?
    You could try CrystalDiskInfo or HD Sentinel or HD Tune or similar to see if the drive is reported as having issues and maybe determine where the issue originates.
    It is possible the drive itself is faulty.
    Can you read and write to the external HD without issue? Also use the above mentioned app types to test it (assuming the M.2 drive is ok), it is possible the external drive is faulty/ has data corruption.
    Have you tried copying files from your C: drive to the M.2 drive and the external drive (and vice versa)?
    I am assuming from reading your post that you are trying to copy the files from the external drive to the M.2 drive. Do any of the above tests/ checks in which ever order makes most sense to you, it is just a list of tests I would try if having the same issue.
      My Computer


  3. Posts : 106
    Windows 10 Pro 20H2
    Thread Starter
       #3

    The first slot has an M.2 NVMe SSD for the OS and I put the new M.2 in the second slot. And it did work - for a while.

    I was able to create a new document folder so I figured the drive was letting me write to it. I tried a different EHD but still could not copy to the M.2. Hmm - why can I write but not copy?

    After doing a ton of searching I rebooted the PC and the D: drive does not exist anywhere, including disk management. Bummer.
      My Computer

  4. Pejole2165's Avatar
    Posts : 868
    Windows 10 Pro
       #4

    It would seem to be a failing controller on the NVME, using it just pushed it over the edge. Must have been a Friday job.
      My Computer


  5. Posts : 106
    Windows 10 Pro 20H2
    Thread Starter
       #5

    I R&R'd the M.2 and screwed it back down. Turned on the PC & got a message there was a problem & it was being fixed. And it appears that it was fixed. The M.2 drive now shows up & I was able to copy stuff to it. Don't know why or how resetting the memory made a difference because it only goes in one way & is screwed down.

    When I looked at Disk Management last night the drive showed a 2MB partition to the right side that was not there before. I don't recall if it said unallocated or not. But the main part did show the correct 931.5GB. IOW there were 2 partitions which were not there previously.

    Today it's back to the normal single partition of 931.5GB & working.

    - - - Updated - - -

    I should mention -
    I did have a problem with the EHD that was being used to copy files from the old PC to the new PC. I could not "safely remove" it from the old PC after I copied some files to it & had to shut down the PC. I was under the impression that would close out any open programs, but maybe it didn't. When I connected the EHD to the new PC it said there was a problem with the EHD & corrected it. But that should not have affected the M.2 D: drive. However since the copying was from the EHD to the M.2 D: drive, it makes me wonder if something got corrupted with the new M.2 setup when fixing the EHD.
      My Computer

  6. Pejole2165's Avatar
    Posts : 868
    Windows 10 Pro
       #6

    Most times a disk fails to safely remove because Defender or Indexer is working on it or an app you used to save a file to the disk didn't release it's file lock properly, occasionally it can happen because there is a physical error on the drive (bad cluster) and Windows is still trying to complete a write operation (think i remember somewhere there is a default setting of 1000 attempts before giving up).
    I think you are right, killing the power corrupted some data, there are utilities that can tell you which app has a file open still even when it should have released it.
    I would keep an eye on that NVME, random partitions appearing and disappearing is not usual behaviour, maybe a normally hidden partition got given a drive letter by mistake and a restart cleared it.
    But if all is working as expected now that is good.
      My Computer


  7. SIW2's Avatar
    Posts : 2,368
    trying to install win10
       #7

    Then I went to copy Thunderbird profiles & only the first 5 files get copied & I get the following error message.
    Is it fixed now?
      My Computer


  8. Posts : 106
    Windows 10 Pro 20H2
    Thread Starter
       #8

    I first went into disk management & clicked on "Off line", which I read supposed to make it safe to disconnect the USB drive. Then I turned off the power to the old PC.

    When I restarted the new PC last night it acted normally, except there was no D: drive.

    Today I re-seated the M.2 and turned on the PC and got the message there was a problem & it was fixed in a couple seconds. The D: drive appeared and did not have that extra 2MB partition.

    Why didn't I get the problem message last night after I powered up the PC? Did the PC think a hardware change was made because the M.2 drive was temporarily removed & put back in? But how would it know since the power was turned off when that was done?

    It's allegedly fixed, but I am a bit concerned about the NVMe because I don't know what happened & will keep an eye on it.
      My Computer


  9. Posts : 106
    Windows 10 Pro 20H2
    Thread Starter
       #9

    Well it happened again. Turned on the PC & everything appeared normal except the D: drive was missing.

    Rebooted the PC & a message came up but caught me off guard. Why didn't it appear when I first turned on the PC? Anyway it happened so quickly I was not prepared to write down the error code. It also said it was fixing the problem & it did. The D: drive now appeared.

    I posted the problem on the mobo forum & will see what responses I get.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:04.
Find Us




Windows 10 Forums