Dell P66F001 Stuck Loading Windows

Page 1 of 2 12 LastLast

  1. Posts : 87
    Windows 10

    Dell Inspiron 15 5000 Stuck Loading Windows

    A friend had given me a Dell Inspiron Inspiron 15 5000 Series (Intel ) - 5567 P66F laptop to repair. It belongs to his teenage son who uses it for school. It tries to boot into windows from the HD but gets stuck on the Dell Logo trying to load windows with a turning circle. My guess is that it happened after some kind of an update. I could not get into windows or windows tools from the HD so I booted from a Win 10 installation usb to get into advanced options and Windows repair tools. Here is what I have done so far.

    1- I tried startup repair but it failed
    2- I used system restore but both restore points failed
    3- I ran command prompt sfc /scannow but it failed to run properly
    4- I ran chkdsk but it failed to run properly
    5- I tried to do an upgrade repair install from the USB to keep files and settings but i got a message that that this can only be done from within windows. The problem is I can't boot into win 10 from the HD.
    6- I removed the HD and tested the drive on another machine and did a disk check and defrag and it appears to be working fine.

    In the BIOS have the option to revert to the factory shipping condition. I could also do a clean Win 10 install. The problem is that would remove all apps and personal files which is not what I want to do.

    I would like to either get Win 10 to boot, or try an upgrade repair install that keeps files and apps. The problem is I can't get into Windows to do the install to keep files and apps.

    Your thoughts and suggestions would be appreciated.

    Kind regards
    Last edited by Chris Nicola; 12 Jun 2021 at 06:07.
      My Computer

  2. wiganken's Avatar
    Posts : 497
    Windows 10 Professional 64-bit

    Clutching at straws here but have you looked on the DELL website to see if they provide any recovery tools specifically suited to DELL machines?
      My Computers

  3. dalchina's Avatar
    Posts : 32,579
    Win 10 Pro (1903) (2nd PC is 21H1)

    Hi, it would help if you can determine the history that led to this. E.g. did owner turn PC off in the middle of an upgrade?

    As you've discovered, an in-place upgrade repair can only be run if you can boot and log in normally.

    The first thing I'd do is use a live boot disk (various around- iso freely downloadable), boot the PC from that and check the disk. E.g. with a portable disk checker like Crystal Diskinfo, or one on the live boot disk.

    chkdsk and
    6- I removed the HD and tested the drive on another machine and did a disk check and defrag and it appears to be working fine.
    do NOT tell you if the physical disk is ok.

    If the disk is dying, nothing but recovery or hope owner has done backups.

    Presumably the owner hasn't been using disk imaging.

    That System Restore failed is unfortunate, but may not actually help if you can't boot. Depends where the problems lie.

    Here's what I'd do.
    a. Check the disk as above (you could also remove it and test it in a caddy as a USB disk).
    b. If ok, create Macrium Reflect's bootable disk, boot the PC from it, try the useful 'Fixboot' utility on that disk and examine the report.
    c. If that fails, you're down to recovering what you can (what backups are there?), informing the owner about the value of using disk imaging and proper maintenance, and a clean install, possibly to a new disk.

    If so, painful school lesson learnt.
      My Computers

  4. FreeBooter's Avatar
    Posts : 4,237
    Windows 10 Pro 64-bit

    Please boot your computer with Windows Installation Media and from Windows Recovery Environment start the Command Prompt.

    Please execute below command and reboot your computer to see issue resolves.

    mkdir C:\scratch
    DISM    /Image:C:\     /Cleanup-Image   /RevertPendingActions /ScratchDir:C:\Scratch

    Please replace all the partition letter C: with Windows installed partition letter. When the computer boots into Windows Recovery Environment (WinRE) environment the drive letter assign to Windows partition may not be C: drive letter because Windows 7, 8 , 8.1 and 10 creates a separate system partition when it's installed from scratch. The system partition contains boot files WinRE assigns the system partition the C: drive letter and the Windows installed partition will be assigned any other drive letter, usually D: drive letter is assign to Windows installed partition. The Bcdedit /enum | find "osdevice" command can be used to find out the drive letter of the Windows installed partition the output of the Bcdedit command is similar to this osdevice partition=D:. The drive letter after partition= is the drive letter of the Windows partition.
      My Computer

  5. Posts : 87
    Windows 10
    Thread Starter

    Thank you all for your replies. I will try the suggestions and report back soon

    Kind regards
      My Computer

  6. mngerhold's Avatar
    Posts : 784
    W10-2009 19042.1116

    Chris Nicola said:
    6- I removed the HD and tested the drive on another machine and did a disk check and defrag and it appears to be working fine.
    I would start by putting the drive back in the other machine and copying all the 'obvious' files from the X:\users folder. If folder re-drirection has occurred, you may need to hunt for the folders on another partition. Doing this before any attempts to restore Windows seems a no-brainer to me.

    Of course, you can also do this from a USB boot device if you have one, as Dalchina mentions.
      My Computer

  7. fireberd's Avatar
    Posts : 2,413
    Win 10 Pro, 21H1

    Dell P66F001 appears to be a battery part number. A search doesn't show up what the actual laptop model is.

    If the Laptop originally came with Win 10, F12 at bootup will get you to the Dell recovery options (if that is still on the drive).

      My Computers

  8. Posts : 87
    Windows 10
    Thread Starter

    Thank you all for your helpful answers and support. I apologise, the correct model number appears to be Dell Inspiron 15 5000 Series (Intel ) - 5567 P66F.

    Wiganken and Fireberd, it took me a while, but I did find the Dell recovery options and decided to use them. With this particular laptop, this seemed the best solution as it enabled me to restore to the default Factory programmes and keep Microsoft accounts, settings and personal files. The Windows install media did not allow me to do this.

    Thanks Mngerhold, I followed your advice and made a backup of all the user files before attempting a repair.

    Dalchina, thanks for your advice. The exact cause of the OS loading stall is still unknown but my guess it that it was a failed update. A power failure may have had something to do with it. The battery only worked for a couple of minutes and then died. The battery was severely bloated and stopped the touchpad from working so I removed it permanently and continued on mains power. While the laptop was open, I removed the fan and heat sink and cleaned years of grime, and put on new thermal paste. I removed the HD, did a backup and tested with CrystalDisk and the HD checked out fine. I am glad to say no user files were lost.

    Microsoft Win 10 installation media boot tools and Dell support assistant could not repair the boot problem. Windows still would not load properly. I did not try Macrium boot tools but I will keep that in mind for next time.
    Dell P66F001 Stuck Loading Windows-crystal-disk.jpg

    Freebooter, thank you for this advice. I booted from Windows installation media and ran all those commands but Windows would still not load. I appreciate your help as I learned something new that might help on a future occasion.

    So what was the final solution for me? It took me a lot of searching to find out that Dell have a bootable rescue software. The built in Dell support assistant available using F12 recovery options failed with an error message that I needed to use the latest version to do a factory reset. This defeats the purpose, because I could not install the latest version without getting into Windows.

    Someone else had the same problem:

    The solution is found here:

    I needed to install and run the Dell recovery software on another working machine to create a 16Gbt bootable recovery usb. During the process it asked for the special support code printed on the back of the laptop with the problem.

    So I booted the laptop from the recovery usb and had the option to do a factory reset from a generic cloud image, update windows 10 and restore all the user files accounts and settings. During the recovery process I had to connect a portable HD so the files and accounts could be backed up and restored. I left it running overnight and it was all ready in the morning.

    Thank you all again for your help. I really appreciate it.

    Kind regards
      My Computer

  9. FreeBooter's Avatar
    Posts : 4,237
    Windows 10 Pro 64-bit

    If you open the log file, you’ll be shown details of all the tests performed by Startup Repair, with any errors discovered detailed. We can use this information to help diagnose and get to the root cause of the problem.

    To open log file from the Windows Recovery Environment, click and open the Command Prompt. When the Command Prompt is open, type Notepad and press Enter key to open the Notepad application. The Startup Repair log file is located at:


    You will need to navigate to the drive on which you have Windows installed (usually the C: drive) to see the SrtTrail.txt log file.
      My Computer

  10. Posts : 87
    Windows 10
    Thread Starter

    Thanks Freebooter. The file SrtTrail.txt was available on the backup I made before the factory reset. I had a quick look but can't understand what the original problem was.


    Kind regards
      My Computer

Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:21.
Find Us

Windows 10 Forums