Windows 10: All folders are read only, and it's causing problems Solved


  1. Posts : 3
    Windows 10 Pro 64 bit
       21 Aug 2015 #1

    All folders are read only, and it's causing problems


    Hi!


    Since I have upgraded to Windows 10 Pro, I noticed that all my folders' attributes are read only . Even if I create new folders, they are read only on creation. When I try to remove the read only attribute in the folder properties, it looks like it's removed, but when I check it again, it shows that it's read only. I tried other methods, like diskpart, and tried to take ownership of the folders, but so far I haven't found a solution.


    Is there any way to fix this problem? I can create new files and modify existing files in the folders without any problem, but it's really annoying, for example Steam says it can't install games and updates, because the folder what I choose to install games is in read only mode, the only solution is to run it as an administrator. I need to run almost every program as an admin, to make them usable, or they report problems with read only folders. The OS itself is up to date.
      My ComputerSystem Spec

  2.    21 Aug 2015 #2

    Read only is not your problem. If you read the properties it clearly tells you that read only applies to files only. The properties box will always show the same thing for folders concerning read only, a filled in a box (not a check mark.)

    More likely your issue comes from the permissions that are set for the old system. You need to update those permissions for your new system.
      My ComputerSystem Spec

  3.    21 Aug 2015 #3

    Its the security feature built in to Windows. My Mum has this problem as well.

    Follow this guide and hopefully it'l help you out.
      My ComputersSystem Spec


  4. Posts : 3
    Windows 10 Pro 64 bit
    Thread Starter
       21 Aug 2015 #4

    swarfega said: View Post
    Its the security feature built in to Windows. My Mum has this problem as well.

    Follow this guide and hopefully it'l help you out.
    I tried this solution. Created a new folder, took ownership of it and tried to install games in it with steam. When I selected the folder no error message was displayed, and the game I choose to download finished downloading without any problem and ran.

    Do I need to do this with every folder in the future if I run into the same problem, or is there another one time solution, which would work in the future without taking ownership of folders?
      My ComputerSystem Spec

  5.    21 Aug 2015 #5

    You should do it every time you encounter this problem. Its what I'm doing on my Mum's computer and seems to be working so far.
      My ComputersSystem Spec


  6. Posts : 3
    Windows 10 Pro 64 bit
    Thread Starter
       21 Aug 2015 #6

    Alright, thanks for the help.
      My ComputerSystem Spec

  7.    22 Aug 2015 #7

    Be afraid, be very afraid!


    There's a major risk if you try to change ownership of your Windows directory, either specifically or by doing a total ownership change on your C: drive! (https://www.tenforums.com/tutorials/3...dows-10-a.html)

    Brink isn't kidding about this; I bricked one PC and had to perform a clean install to salvage it.
      My ComputerSystem Spec


 

Related Threads
since installing Windows 10, I can not save updates to word files or anything to a folder. I've read I should change the user settings that default to 'read-only' in the system folder. I've done this 3 times. The fix doesn't work. Help!
I was just creating a folder on my C drive (SSD) when I noticed that the attribute is set to read-only. I've tried clearing the attribute many ways using the link below but to no avail. Right-clicking on the folder does not show the option to Take...
Im installing windows 10 on ssd and i have a spinning drive i plan to put frequently changes windows data(temp) and rarely used windows data(Installer). From what i gathered, it is not recommended to do so in audit mode. So, I wonder, is it okay...
I had made a clean install of Windows 10 on an older computer without any issues. Then I tried to do a clean install on a newer EFI-based computer. I had trouble like many others once I tried to install to a GPT partition having booted from a USB...
Mpc-hc causing problems...9879 in Software and Apps
Seems that mpc-hc causes issues on the task bar, and the start menu. Anyone else..??
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:18.
Find Us