Cannot access Surface rt uefi boot mode

Page 1 of 2 12 LastLast

  1. Posts : 8
    Win 10/win 7/ surface RT
       #1

    Cannot access Surface rt uefi boot mode


    Hi hope all is well, I am not able to access the uefi mode on my surfacert when I hold the volume button up and press the power button ,the surface seems to die and I have to go through the reset procedure (press the power button for 30 secs. in order for it to turn on again,once it does it will just continuously reboot to the surface screen. Right now I can't get to the uefi screen, am I doing something wrong or is their another way to boot into the uefi mode for a surfacert,any help given is appreciated.
      My Computer

  2. Macboatmaster's Avatar
    Posts : 872
    10, 8.1 and 7 all Professional versions, and Linux Mint
       #2

    I am not sure if you are trying the vol up and power with the surface ON
    the correct procedure is
    The UEFI settings can be adjusted only during system startup. To load the UEFI firmware settings menu:

    Shut down your Surface.

    Press and hold the volume-up button on your Surface and at the same time, press and release the power button.

    When you see the Surface logo, release the volume-up button.
    The UEFI menu will display within a few seconds.
      My Computer


  3. Posts : 8
    Win 10/win 7/ surface RT
    Thread Starter
       #3

    Hi hope all is well, the tablet is shutdown when I try to boot into uefi mode,I press the vol. up button and press then release the power button,my apologies if I wasn't clear about that,thanks for replying.
      My Computer

  4. EdTittel's Avatar
    Posts : 4,116
    Windows 10
       #4

    You can also use the Advanced Startup ("Restart now") option in Start --> Settings --> Update & Security --> Recovery as well.
    WARNING!!! Once you press "Restart now" it will indeed restart your PC immediately. Be sure to save all work and get ready before pushing that button. FYI, this force-boots your PC into the Windows Recovery Environment (WinRE) from which BIOS/UEFI is accessible as an option.
    HTH,
    --Ed--

    Cannot access Surface rt uefi boot mode-image.png
      My Computers

  5. Macboatmaster's Avatar
    Posts : 872
    10, 8.1 and 7 all Professional versions, and Linux Mint
       #5

    Good point was not sure you could go that way on a Surface
    If of course you cannot load to windows and that is why you are trying to enter UEFI then - please post at what stage the windows loading fails
    https://support.microsoft.com/en-us/...4-95f45eb1c3f9
    Select Start > Settings > Update & security > Recovery.

    Under Advanced startup, select Restart Now.

    Under Choose an option, select Troubleshoot > Advanced Options > UEFI Firmware Settings, and then select Restart.

    UEFI menu options
      My Computer


  6. Posts : 8
    Win 10/win 7/ surface RT
    Thread Starter
       #6

    Cannot access Surface rt uefi boot mode


    Hi hope all is well with everyone. First things first, Thanks for your replies and help. I did not have the option of applying your recommendations for (restart now which would force the the tablet to reboot into Windows Recovery Environment (WinRE) from which BIOS/UEFI is accessible as an option). I used the link provided by Macboatmaster <=(Thanks) to create another recovery usb and then attempted a full reset on the tablet and now the installations fails when it reaches 56% consistently. Startup repair fails with the message starup repair couldn't repair your computer, also I am still not able to access uefi mode, the tablet still dies when I attempt that procedure and I have to hold down the power button for 30 sec. to bring it back. when I use the cmd prompt I ultimately I run into the error message virtual disk service: The object is not found.
    IE: list partitions, list volume, create partition primary, format fs=fat32, all of these cmd's return that message. I tried to attach some images but apparently I don't have permission for that so I am typing in the information from the diskpart detail disk cmd.
    Hynix HBG4e
    Disk ID: 00000000
    Type:SD
    Status=Online
    Path=0
    Target=0
    LUN ID=0
    Location Path : UNAVAILABLE
    Current Read-Only : No
    Boot Disk : No
    Pagefile Disk : No
    Hibernation File Disk : No
    Crashdump Disk : No
    Clustered Disk : No
    There are no volumes.

    QUESTION: Is there a (WinRe) usb stick that also contains the option to boot into uefi mode
      My Computer

  7. Macboatmaster's Avatar
    Posts : 872
    10, 8.1 and 7 all Professional versions, and Linux Mint
       #7

    What is the full model details of your surface as UEFI is only available on some surface tablets
    From the link I sent
    UEFI replaces the standard BIOS only in the Surface models listed in this article. The following models do not feature UEFI and still use the earlier BIOS.

    So on the link and under the heading
    Standard BIOS continues to support these Surface devices
    you will see that
    Surface Pro or Pro2
    Surface 3 and Surface Pro 3

    do not support UEFI therefore on those devices - the settings - advanced - restart - uefi mode is NOT available
    Boot to UEFI Firmware Settings from inside Windows 10
    This only applies if your PC's motherboard has a UEFI firmware chip instead of a BIOS chipset
    .

    so please confirm the full model AND what is shown diskpart - list disk
    as that detail disk with the hynix is as you can see NOT the boot disk - also am I right in thinking that the Hynix is only 32GB and what is known as flash storage
      My Computer


  8. Posts : 8
    Win 10/win 7/ surface RT
    Thread Starter
       #8

    Cannot access Surface rt uefi boot mode


    Hi hope all is well. The model of the tablet is Windows RT Surface 32GB I verified this via. the s/n on the Microsoft and yes the hynix is flash/SSD storage. I actually posted this issue with my second post after joining this forum under the title (Surface RT Virtual Disk Service: The Object Is Not Found) I will paste it here and I apologize to you in advance if it's more than you care to read.

    Surface RT Virtual Disk Service:The Object Is Not Found

    Good morning hope all is well.
    Current Issue:
    *when powered on tablet (surface rt 32 mb) displays surface logo in a continuous boot loop.
    *when attempting to boot to uefi mode the tablet displays a black screen( shuts down) and will not restart unless a 15 to 30 sec. hardboot is performed.
    *when booted from a ver. 2.0 USB with Microsoft surface rt image Surface2_BMR_102.1.9.0 and using parameters reset pc and fully clean, it stops installing @ 1% with a generic message ( ran into a problem and cannot continue).
    *When attempting to boot from the refresh your pc option: the operation fails with error message ( The drive containing windows is locked).
    *Whe attempting startup repair, the operation fails with message (ran into problem cannot continue).
    COMMAND PROMPT REPAIR ATTEMPTS:
    DISKPART:
    *list disk shows 29gb/29gb free/gpt
    Detail disk shows disk information and also shows there is no volume for disk
    *clean disk operation succeeds
    *create partition primary operation fails with message virtual disk service/the object is not found
    *format fs=fat32 fails with msg virtual disk service/the object is not found.
    So far the best positive is that disk detail does show the ssd drive information so I know that it can be seen.
    ORIGINAL HISTORY:
    *Tablet had low battery and died during software update.
    *Tablet was secured with bitlocker key but key was lost and has since been found albeit to late for what trouble shooting steps subsequently followed while it was misplaced.
    *As remedy to not having the bitlocker key a full clean and reset was performed via the USB stick recovery software for the tablet.
    *Upon reinstalling the operating system the errors contained in this message manifested themselves.
    From what I can tell,it seems that diskpart cannot see the ssd for anything beyond knowing that it's there and that may be one of the reasons that the installation media has nothing to install to. 🤔
    NOTE:
    I believe that I was able to run chkdsk and scan disk successfully but can't remember however I will try again just to be sure.
    I am taking a pretty good whipping on this one but I don't mind because it's all about learning except now I am not sure of what questions to ask myself and it's really difficult to learn that way, that's when I know that I need help, so someone, anyone, everyone lol :) please chime in if you will.

    MOTTO:
    At the end of the day you have to stay upbeat and strive to stay in the positive or strive to be upbeat and strive to stay in the positive
      My Computer

  9. ArazelEternal's Avatar
    Posts : 359
    Windows 10 Pro x64
       #9

    So, it seems you are able to boot from a USB drive. If you have another working computer with an internet connection, I would download KYHI's Recovery (linked in my sig), follow the instructions, install it on a USB drive, and boot from that. If I remember right, it has a tool like Minitool Parition Wizard or Aomei Partition Assistant. Use either one it has to perform a disk wipe. The simplest one it has is sufficent (usually a 1 pass overwrite or an option that just fills the drive with zeros.) After doing that, try to reinstall Windows again. This may take care of anything that may still be hanging around on the drive that could cause issues.

    This is a very good reason why if someone is going to use bitlocker, they should make sure they keep a copy of the key that is in a secure, yet easily accessible place to be gotten at any time it is needed. Otherwise it can really turn things into a headache. I know this from personal experience.

    This is also why it is suggested so much on this forum that a backup of your disk is kept on an external device. Issues like this can be cleared up in as little as a half hour when you have a backup image to fall back on. Make use of something like Macrium Reflect or Acronis. It really makes things much easier to deal with.
      My Computers


  10. Posts : 8
    Win 10/win 7/ surface RT
    Thread Starter
       #10

    Hi hope all is well thanks for your reply and input. You are absolutely correct about backing up the drive contents and securing the bit locker key if one decides to use it,which I now have not one bit of desire to do(pun intended )lol🙂
    I will download the program that you recommend and hopefully this will help to get the tablet up and running again.
    Quick question? I saw a surfactrt for sale at $50, if I purchase it would I be able to make a back up image from it and used that image to recover the surfacert that's currently not working.
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:10.
Find Us




Windows 10 Forums