Cannot edit items in group policy editor

Page 1 of 2 12 LastLast

  1. Posts : 5
    Windows 10 pro 2004
       #1

    Cannot edit items in group policy editor


    Dell laptop, W10 Pro 64 bit, v. 2004.
    I just upgraded a Dell from W7 pro to W10 pro. I want to disable a few items in the group policy editor, but having a problem.
    I can open gpedit and get to the items, but when I double click only the description shows, not the options pane for editing. I spent the whole day researching this, but Google doesn't show any hits for this particular problem.
    I have another W10 laptop and a W7 machine, and don't have this happen with either one.
    Any clue, or is it reset time?
      My Computer


  2. Posts : 5,278
    Windows 11 Pro 64-bit
       #2

    See if you can open them at Microsoft Management Console.

    Type mmc.exe to Start Menu and from Microsoft Management Console click File --> Add/Remove Snap-in option.
      My Computer


  3. Posts : 5
    Windows 10 pro 2004
    Thread Starter
       #3

    I've tried that, but the snap-in for group policy won't stay added. I tried under the computers tab. When I click the users tab, all the user entries (administrator, etc.) says no , and I can't change them.
      My Computer


  4. Posts : 7,830
    Windows 11 Pro 64 bit
       #4

    Perhaps time for a repair install or recover from the last working backup. Repair Install Windows 10 with an In-place Upgrade
      My Computers


  5. Posts : 42,526
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #5

    Hi, this might give a hint:
    https://support.microsoft.com/en-us/help/555218

    Noted this refers to older Windows versions.. but it might point you towards a solution. There may be a more recent version of this.

    However, with due caution (check file exists first) I see no harm in trying the resolution:
    RESOLUTION


    To resolve this issue, re-register the appropriate MMC snap-in DLL that

    implements the missing functionality by issuing the following command at a Windows command prompt

    regsvr32 <snap-in DLL name>

    By default, all of the Group Policy related MMC snap-in DLLs can be found in %systemroot%\system32

    The following lists the default Group Policy snap-in DLLs that you can re-register:

    Administrative Templates and Scripts: gptext.dll
    Folder Redirection: fde.dll
    Internet Explorer Maintenance: ieaksie.dll
    IP Security: ipsecsnp.dll
    Public Key and Software Restriction: certmgr.dll
    Remote Installation Services: rigpsnap.dll
    Security: wsecedit.dll
    Software Installation: appmgr.dll
      My Computers


  6. Posts : 5
    Windows 10 pro 2004
    Thread Starter
       #6

    There aren't any snap-in dlls listed in the command prompt nor in the system 32.
    Also, when I click on "policy setting" at the top of the description, there is a script error.
    Is there a way to re-install the gp editor without doing a complete reset?
      My Computer


  7. Posts : 42,526
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #7

    Thank you very much for your reply.

    I don't know of any way to install the GP editor as such- it's part of Windows. It's not listed in Windows Features (Control Panel) for example.

    Has it ever worked since you upgraded? If not, an in-place upgrade repair is unlikely to help, as it's essentially the same thing you've just done in upgrading. (Note- an upgrade repair is not a 'reset').

    Was it working in Win 7?

    You could use this:
    Download Policy Plus - MajorGeeks
    - looks like the GP editor, and adds a useful 'find' feature.

    There are ways posted which are suppposed to add the GP editor to Home. I don't know if those might help you get it working. E.g.
    4 Ways to Fix Group Policy Editor (gpedit) Missing on Windows 10
    https://www.itechtics.com/enable-gpedit-windows-10-home/


    I would advise making an appropriate backup before attempting this. Hopefully you are routinely using disk imaging (e.g. Macrium Reflect - free/paid).
      My Computers


  8. Posts : 5
    Windows 10 pro 2004
    Thread Starter
       #8

    I haven't tried it in W7 on this machine. I enabled gp editing in the optional features, then again added group policy in the mmc console, but still no luck. I'm going to try a reset and see if that helps.
      My Computer


  9. Posts : 42,526
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #9

    You will lose all installed programs.
    Reset Windows 10
      My Computers


  10. Posts : 5
    Windows 10 pro 2004
    Thread Starter
       #10

    I did a hard reset and wiped the hd, and that fixed it. There wasn't much on it that needed reloading, it's just a backup machine.
    Thanks for the replies.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:18.
Find Us




Windows 10 Forums