Problem with Robocopy GUI, does not copy/mirror


  1. Posts : 242
    W 10 Home x64
       #1

    Problem with Robocopy GUI, does not copy/mirror


    Hi

    3 PC's Windows 10 fully updated

    I have used Robocopy on three PC's for a couple of years.

    I have a USB that I use at work then when I get home I
    mirror the USB to my PC's

    This has always worked well but now on one of my PC's
    nothing changes in the Target older.

    My Source Path is H:\Robert and Target Path is C:\Robert.
    I check / MIR on the Copy Options Tab.

    This definitely only does not work on one W10 PC

    What am I missing?

    Any help or comments appreciated.

    Regards

    Daniel
      My Computer


  2. Posts : 11,612
    Windows 10 Home x64 Version 21H2 Build 19044.1776
       #2

    Daniel,

    I use RoboCopy not its GUI.
    - Does the GUI allow you to keep a log so that you can examine it for evidence?
    - Have you checked that source & target paths exist?

    Denis
      My Computer


  3. Posts : 242
    W 10 Home x64
    Thread Starter
       #3

    Try3 said:
    Daniel,
    I use RoboCopy not its GUI.
    - Does the GUI allow you to keep a log so that you can examine it for evidence?

    Gui keeps a log but on the machine in question none is kept.
    - Have you checked that source & target paths exist?

    The paths exist, I select the folders by browsing to them
    and left clicking them.
    Denis
    Thanks Denis

    Regards

    Daniel
      My Computer


  4. Posts : 11,612
    Windows 10 Home x64 Version 21H2 Build 19044.1776
       #4

    Daniel,

    1 Try to create a text file just as a test in the target folder & in the folder the log is supposed to be written to.

    2 Try running the RoboCopy command manually in a command prompt window to see what it reveals. [If I recall correctly, RoboCopy GUI lets you extract the full command it is using]

    Denis
      My Computer


  5. Posts : 1,468
    Windows 10 Pro
       #5

    I find that Robocopy copy and/or mirror commands will often apply hidden attributes to the destination files/folders. I think this is what's happening to the OP .. they're there, but can't be seen. Try revealing hidden file and see if they're there.

    Consequently, I always include at the end of the copy/mir command line /a-:rsh
      My Computer


  6. Posts : 242
    W 10 Home x64
    Thread Starter
       #6

    Hi

    Thanks for your reply but I don't understand the comment.

    What is not there and where is it not there??


    Cheers

    Daniel
      My Computer


  7. Posts : 242
    W 10 Home x64
    Thread Starter
       #7

    Hi

    I solved the problem.

    I set file properties to "Run as Administrator" and it now works.

    I have not had to do that on my other PC's... Go figure.

    Cheers

    Daniel
      My Computer


  8. Posts : 13,957
    Windows 10 Pro X64 21H1 19043.1503
       #8

    Is the user account on that PC a Standard account or an Administrator account?
      My Computers


  9. Posts : 242
    W 10 Home x64
    Thread Starter
       #9

    Hi

    all of the accounts are the same, I am the only
    user on each and all installs were done by me
    under the same parameters.

    I assume I am the admin.

    Regards

    Daniel
      My Computer


  10. Posts : 13,957
    Windows 10 Pro X64 21H1 19043.1503
       #10

    Right-click the name (or icon, depending on the version Windows 10) of the current account, located at the left part of the Start Menu, then click on Change account settings. The Settings window will pop up and under the name of the account if you see the word "Administrator" then it is an Administrator account

    Is your Windows 10 user account an Administrator? Here's ...


      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:58.
Find Us




Windows 10 Forums