After Updating to Windows 10 2004 found only 1 minor issue:


  1. Posts : 293
    Windows 10 Home
       #1

    After Updating to Windows 10 2004 found only 1 minor issue:


    Hi. I updated my HP Desktop to Windows 10 2004 from version 1909 today. Everything appears to be working fine. The only thing I noticed is in Revo Uninstaller Pro, all program install dates are now showing 6/17/2020. Also many (not all) of my programs in the Programs and Features list are also showing the 6/17/2020 install date. The registry keys pertaining to the programs are showing the correct install dates. (I didn't check every program in the registry). I was wondering if anyone else noticed anything like this.
    Mark
      My Computer


  2. Posts : 13,301
    Windows 10 Pro (x64) 21H2 19044.1526
       #2

    Mcd73165 said:
    Hi. I updated my HP Desktop to Windows 10 2004 from version 1909 today. Everything appears to be working fine. The only thing I noticed is in Revo Uninstaller Pro, all program install dates are now showing 6/17/2020. Also many (not all) of my programs in the Programs and Features list are also showing the 6/17/2020 install date. The registry keys pertaining to the programs are showing the correct install dates. (I didn't check every program in the registry). I was wondering if anyone else noticed anything like this.
    Mark
    Nice catch mine does too

    Programs and features is different....hmmmmm

    Attachment 283865


    Attachment 283864
      My Computers


  3. Posts : 293
    Windows 10 Home
    Thread Starter
       #3

    thomaseg1 said:
    Nice catch mine does too

    Programs and features is different....hmmmmm

    Attachment 283865


    Attachment 283864
    Thanks for your response, thomaseg1. At least I know I'm not alone with this kind of issue. If this is the worst thing experienced after this update then we are both pretty lucky.
    Mark
      My Computer


  4. Posts : 7,130
    Windows 10 Pro 64 bit
       #4

    This is yet another obvious bug which due to poor software QA which should have been spotted by MS
      My Computers


  5. Posts : 303
    Windows 10 (2), Win 8.1 (1), Win 7 (1)
       #5

    This happens with each Feature Update. A number "Installed On" dates are changed. Don't know why.

    JohnD
      My Computer


  6. Posts : 293
    Windows 10 Home
    Thread Starter
       #6

    johnpd said:
    This happens with each Feature Update. A number "Installed On" dates are changed. Don't know why.

    JohnD
    These feature updates besides causing issues don't really seem to add anything useful (for most of us). Once a stable version is accomplished, MS should leave well enough alone. Windows 7 never had these kinds of issues. As always, thank you and everybody for your responses.
    Mark
      My Computer


  7. Posts : 3,257
    Windows 10 Pro
       #7

    This is not a bug, nor is it unexpected. The problem here is that you don't really understand how feature upgrades work.

    They are not "in place" updates. Instead, Windows is installed clean, but during installation all your apps and tools are re-installed in your instance, and all your data migrated over. This is why the dates on these are set for the current date, because in fact they ARE just installed.

    Essentially, your windows installation is renamed to Windows.old, your new version of Windows is installed to Windows, and migration from Windows.old to Windows occurs.
      My Computer


  8. Posts : 293
    Windows 10 Home
    Thread Starter
       #8

    Mystere said:
    This is not a bug, nor is it unexpected. The problem here is that you don't really understand how feature upgrades work.

    They are not "in place" updates. Instead, Windows is installed clean, but during installation all your apps and tools are re-installed in your instance, and all your data migrated over. This is why the dates on these are set for the current date, because in fact they ARE just installed.

    Essentially, your windows installation is renamed to Windows.old, your new version of Windows is installed to Windows, and migration from Windows.old to Windows occurs.
    This may be true but I don't recall this happening on previous feature updates. Also, I just found another glitch when I try to eject my external hard drive after making a Macrium Reflect backup, I get a pop up saying the device is still in use when it isn't and ultimately have to just pull out the the usb cable from the computer. However if I connect the external hard drive and don't do anything, I get the Safely Remove Hardware message. This has happened every time since the upgrade.
      My Computer


  9. Posts : 25,084
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #9

    Mcd73165 said:
    This may be true but I don't recall this happening on previous feature updates....
    Mine still shows the correct dates for apps that were installed back when this PC was running its OEM Windows 7, including some that were pre-installed by the OEM when it was built in 2011. The dates have survived every upgrade from the original W10 upgrade in 2015 up to today.

    After Updating to Windows 10 2004 found only 1 minor issue:-image.png


    Also, I just found another glitch when I try to eject my external hard drive after making a Macrium Reflect backup, I get a pop up saying the device is still in use when it isn't....
    That has been a problem on and off with previous versions too. One culprit can be Task Manager which can sometimes keep an external HDD 'in use' when all other apps are closed.

    Anyway, if install dates are the only issue you've noticed than you haven't been optimising you drives. In 2004 Defrag is unable to remember when it was last run after a restart.

    Optimize Drives>Never Run

    Also, this build of 2004 seems to still have some Insider hooks left in it. In Pro the ability to defer Feature updates or Quality updates are removed for Insider builds, and they are missing in the current public release of 2004 Pro too.

    Updated to v. 2004 and now "Choose when updates..." option is missing
      My Computers


  10. Posts : 293
    Windows 10 Home
    Thread Starter
       #10

    Bree, I always have optimized my drive weekly but not yet since the 2004 update which I installed yesterday (6/17). Also I am now getting the Safe to Eject Hardware message when ejecting my external back up drive. I guess I'll run the Defrag and Optimize Drives now. Also, the program installation dates are correct in Settings-Apps and Features. Revo Uninstaller Pro is showing all install dates as 6/17/2020 and some are showing the same install date in the Control Panel Programs and Features list. It's not really a big deal but seems to have happened to some of us. Thanks, Bree.
    Mark
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:37.
Find Us




Windows 10 Forums