How to PROPERLY adjust storage space size (maximum) after adding drive

Page 1 of 2 12 LastLast

  1. Posts : 3
    Windows 10 Pro x64
       #1

    How to PROPERLY adjust storage space size (maximum) after adding drive


    Ok, let's get some requirements of this post out of the way, as it's irrelevant and I've always had this issue but only joined tenforums.com just now to seek advice from other Windows 10 users:

    Microsoft Windows 10 Pro, 64-bit, Version 1909 (OS Build 18363.657)

    But I must repeat, I've ALWAYS had this problem after adding a drive, and the solution seemed to be always move everything out of the existing storage space and delete, and re-create. So here is my question:

    How do you properly adjust the storage space size (maximum) field once you add new drives to a pool? I've read the sticky post from Brink, and although I appreciate the tutorial, it didn't show anything of value in my situation. Seems like everytime I tried to address this issue, I'm playing a game of "guess my storage space size (maximum)" with Windows. My Pool and Storage Space situation is simple:

    1) I created a storage space and planned ahead knowing that I will be adding drives to my pool later once those drives were freed up. "Planning ahead" meant, over-provision the pool so that the correct cluster size will be implemented in the creation of this Pool to at least guarantee that I won't get the dreaded "exceed the size cluster" error message.

    2) The pool I created, has the size set to 40TB

    3) Initial creation of the the Storage Space in THIS 40TB pool (Item 2 above) is 4x 6TB drives, totalling to 24TB.

    4) This Storage Space has NOTHING SPECIAL. Just SIMPLE, no resiliency, it's just used to store a bunch of data that are disposable and "don't-care" if I lost all the volume (although it would be annoying, but it's not critical data).

    5) I added two FRESH drives, 8TB each, after removal from another pool. I removed the disks, deleted the pool where it came from, and went into Mini-Tools Partitition Wizard to remove any garbage partition that Windows leaves behind after a drive removal. So the ENTIRE DRIVE after the Partitition Wizard shows as Unused, no partition, so 8TB raw space per drive.

    6) After adding the two raw drives to the existing Pool (See item 3 for reference), I went back into that Storage Space and clicked on "Change" to change the attribute of this Storage Space.

    7) Please see attached screenshot for reference. In the field "Storage Space Size (maximum)" this is where the guessing-game begins. I tried to type in value of what's shown in the "Total Pool Capacity" but I get the error message "Specified size is not valid" and with "Change storage space" greyed-out so I cannot execute this change.


    So back to the general question, lots of info on the web about HOW to change the storage size, but I haven't found ANY that explains how to do it PROPERLY, to adjust this Storage Space to the maximum. Even on MS' own forums, the MS reps on there seems to dodge this question posed on there by asking the scripted questions like "What is your machine's configuration, did you make sure to apply the latest patch, etc." Bunch of unhelpful replies.

    But I've been a lurker on here for years and know that there are some Windows 10 power users that probably knows how to solve this. I would appreciate any help.

    Oh yeah, I did run into a post about using DISPART and EXTEND VOLUME # (where # is the volume number in the list after listing the volumes out with list volume command).

    How to PROPERLY adjust storage space size (maximum) after adding drive-storage-space-issue.jpg
      My Computer

  2. essenbe's Avatar
    Posts : 12,511
    Windows 10 Pro 1903
       #2

    Moved
      My Computers


  3. Posts : 913
    CP/M
       #3

    Do not use Storage Spaces applet in Control Panel, it mixes virtualdisk, partition, and volume into one fake "object".
    Use the "Resize-VirtualDisk" command; if it fails, you should see the reason in output under Extended Information header.
    https://docs.microsoft.com/en-us/pow...?view=win10-ps
      My Computer


  4. Posts : 913
    CP/M
       #4

    Tested in similar configuration (disk sizes), here are the results:

    The following commands
    Code:
    see post #16 for corrected code

    should work in most cases but not in your one, because of small cluster size, see the image.

    How to PROPERLY adjust storage space size (maximum) after adding drive-1.png

    You can:
    - reformat drive with cluster size 16kB or more (you lost your data), or
    - use some tool like Acronis Disk Director or Minitool Partition Wizard to change cluster size without data loss; sadly, only paid versions can do it.
    Last edited by muchomurka; 08 Jun 2020 at 22:11.
      My Computer


  5. Posts : 913
    CP/M
       #5

    After changing ntfs cluster size of storage spaces volume, there should be no problem to extend both virtualdisk & volume size to approx. 36TB (it takes same space from all physical disks so some capacity on 8TB disks remain unused):

    How to PROPERLY adjust storage space size (maximum) after adding drive-2.png

    As always: Storage spaces aren't for dummies, without powershell you're lost.

    Use this table for planning NTFS volumes:

    Cluster Size Max Volume Size
    4kB 16TB
    8kB 32TB
    16kB 64TB
    32kB 128TB
    64kB 256TB


    -------------------------------------------------------
    Note: For 16kB clusters, you can extend virtualdisk & volume up to 63TB (thin provisioning - more than real disk capacity); afaik this has no sense in simple environment with only one virtualdisk in storage pool.
    Last edited by muchomurka; 02 Apr 2020 at 18:10.
      My Computer


  6. Posts : 3
    Windows 10 Pro x64
    Thread Starter
       #6

    THANK YOU THANK YOU THANK YOU MUCHOMURKA!

    I'm going to use this as a guide, and it became super relevant as I just received a drive from WD from an RMA and I need to add that back into my storage pool. THANK YOU!!!
      My Computer


  7. Posts : 913
    CP/M
       #7

    You're welcome.
      My Computer


  8. Posts : 8
    Windows 10 Pro
       #8

    I trying to execute the procedure as described by muchomurka, but I get an error when I enter the add-physicaldisk command. Here's what I entered:

    PS C:\Users\Gary> $newdisks = Get-PhysicalDisk -canpool 1
    PS C:\windows\system32> Add-PhysicalDisk -storagepoolfriendlyname "disk array backup" -physicaldisks $newdisks
    Add-PhysicalDisk : The requested object could not be found.

    Can you please let me know what I'm dong wrong? I'm trying to create a single raid-0 volume using all 8 of the 16 TB disks in my JBOD array so I can mount it on a single drive letter in Windows 10.

    Thank-you.
      My Computer


  9. Posts : 913
    CP/M
       #9

    Incomplete error message posted so only guess of reason:
    Storage pool of that name does not exist.

    The procedure above describes how to extend already existing storage space pool/virtualdisk/partition by adding new physical disks. Afaik you need to create new storage space from scratch, so the procedure is not relevant to your case and generates errors.

    Warning: When adding disk to storage pool, all data on it become inaccessible! There is no way to migrate disks into storage space with data retained, new storage space is always empty.

    Imo storage spaces are not suitable for average users. But if you do want to have Storage Spaces Simple Resiliency RAID0 (striped, not JBOD), use NumberOfColumns parameter in New-Virtualdisk command. Storage Spaces applet in Control Panel always creates Simple Resiliency virtualdisk with one column only.

    ---------

    If you do want RAID0 over 8 disks (insane idea though, zero redundancy, all data lost if one disk fails), you can create Dynamic Disks Striped Volume in Disk Manager instead.

    Apologies and correction: not supported for your system, Dynamic Disk Striped Volume is limited to 2TB per disk, see Dynamic Disk Limitations in Windows for further info.
    Last edited by muchomurka; 07 Jun 2020 at 14:14.
      My Computer


  10. Posts : 8
    Windows 10 Pro
       #10

    I see. Your right, I didn't create the storage pool. I tired creating a pool, but was only able to get about 63 TB due to small cluster size, so I deleted the pool and found your PowerShell procedure and thought I'd give it a try. Microsoft really needs to improve their Storage Spaces control panel app. I'll try Disk Manager to create my RAID0 volume - that was my first thought but my QNAP JBOD app had a link to Storage Spaces, so I went down that path.

    Oh, I'm totally about data redundancy. My primary disk array is RAID-6 and holds my entire ripped collection of DVD and Blu-ray discs (1000+ discs). This JBOD array is just for on-site data backup, and I think I'll open it up from time to time to the internet so my friends can watch movies since they can't come over to my house right now. I also have a collection of 8 TB USB disks with another copy stored off-site that I update monthly. So, not to worry, my data is safe.

    Thanks for your help - I really appreciate it.
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:02.
Find Us




Windows 10 Forums