D:\ Access is denied - How do I resolve this?

  1. ArthurDent's Avatar
    Posts : 215
    Windows 10 Pro (x64) 20H2 (OS Build 19042.630)
       #1

    D:\ Access is denied - How do I resolve this?


    Hello folks

    Don't ever buy a Lenovo laptop with a SSD drive! This new laptop is giving me nothing but grief!!

    Procedure. Laptop has two m.2 NVMe sockets in it. Has run for the past few weeks with the OEM SSD (C: drive containing boot partition, OS and program files) and a second SSD (D: drive) in the other socket which contains all the documents & photos.

    Opened laptop. Took out D: drive and replaced with blank, unformatted, 256GB WD SSD. Initialized disk and formatted.
    Cloned OEM SSD using Macrium reflect. Took out clone and replaced D: drive.

    Suddenly, after cloning the C: drive D: drive has lost some folders and documents?!?

    So, I try to get them back and succeed in getting back *most* of the documents from an earlier backup (on an SD card).

    Now, when I try to access D: drive, I get the message that D: is not accessible. Access is Denied.

    I'm guessing it is down to permissions but can't make head nor tail of Microsoft's terminology.

    HELP before this 6 week old laptop takes a vertical dive onto the concrete patio one floor below.

    Art


    Windows 10 1909 (OS Build 18363.720)
    C: drive is 256Gb SSD containing boot partition, OS and program files
    D: drive is 512Gb SSD which *should* contain documents
    Last edited by ArthurDent; 28 Mar 2020 at 14:41.
      My Computers

  2. Berton's Avatar
    Posts : 10,526
    Win10 Pro Versions 2004 and 2009/20H2, Win10 Pro IP_Dev, Win10 Home 1909
       #2

    Here's a picture of the 2 types of drives available:
    SSD, Solid State Drives, Hybrid Hard Drives - Newegg.com
    I'd be concerned about one thing, everything in computing has to be precise/accurate and as far as I've seen there is no 520GB SSD, probably is a 512GB unless there's something wrong with the drive. Solid-State Drives and USB Thumb drives are usually multiples of 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, etc.
      My Computers

  3. ArthurDent's Avatar
    Posts : 215
    Windows 10 Pro (x64) 20H2 (OS Build 19042.630)
    Thread Starter
       #3

    Forgive me for not being accurate.

    I had hoped that your reply would address my main issue - that of not being able to access the D: drive (due to permissions?) rather than pulling me up on saying it is a 520Gb hard drive instead of 512Gb.

    Are you able to help me with my issue?

    I have tried right-clicking on the drive in question > Properties > Edit Permissions.

    Tried to make sure that all 'Allow' boxes are ticked (they were all clear)

    Clicked on 'Apply' and got error message 'An error occurred while applying security information to D:\
    Failed to enumerate objects in the container. Access is denied.'

    What the hell does that mean?!

    Regards

    Art
      My Computers

  4. Try3's Avatar
    Posts : 7,446
    Windows 10 Home x64 Version 20H2 Build 19042.928
       #4

    Art,

    I hope the patio is more than 2 metres down so you can then maintain the minimum social distance from the laptop that Boris recommends.

    You are not going to like my suggestion for your disk problem.
    - Copy all the recovered D:\ drive contents to an external backup disk
    - Restore whatever system image you made before you did the cloning [if that system image did not include the D:\ drive then reformat the D:\ drive so the computer knows you are starting from scratch]
    - Copy back to the D:\ drive the files you backed up
    - Write out one hundred times, "I will make & restore system images instead of cloning because cloning seems to have side-effects that drive me crazy.".

    Denis
    Last edited by Try3; 28 Mar 2020 at 15:18.
      My Computer

  5. thomaseg1's Avatar
    Posts : 13,331
    Windows 10 Pro (x64) 20H2 19042.804 & 21327.1000
       #5

    I for one haven't had much luck with cloning, as it is usually cloning a disk where files are
    active.

    Try replacing the disk and use Macrium reflect to make an image. and a rescue disk.

    put the new disk in and use the rescue disk to boot Macrium and restore the image to the drive.

    Image restore does well because no files are active and may not have been corrupted.
      My Computers

  6. ArthurDent's Avatar
    Posts : 215
    Windows 10 Pro (x64) 20H2 (OS Build 19042.630)
    Thread Starter
       #6

    Problem is Denis, I can't access D: drive at all.

    Always get 'Access is denied'

    Checked permissions (Right-click > Properties > Security Tab > Select 'Administrators' in the Group Window

    Under 'Permissions for Administrators', all of the boxes are now checked, yet I still cannot access this drive.

    Only one user (my wife) and she is an Administrator.

    Enabled and then logged onto the Built-in Administrator account and D: drive is accessible.

    Firmly convinced it is a Permissions issue.

    (and yes, the drop is more than 2m)

    Art
      My Computers

  7. Fabler2's Avatar
    Posts : 2,958
    Windows 10 preview 64-bit Home
       #7

    Have a look at this video YouTube
      My Computers

  8. Barman58's Avatar
    Posts : 3,930
    Windows 10 Pro x64 2004 - 19041 - 264 XP/Vista/Win7/Win8.1 in VM for testing
       #8

    OK there is a difference between cloning and Copying, cloning is treated as a Move operation, which retains the original NTFS File access rights, from the original install. a Copy uses the new rights. The issue with rights is that they follow their own rules, not ours ...

    If you have a user called "Wife" and you reinstall the Operating System, and create a new user also called "Wife" although to us humans they are the same the computer allocates a number to each user that is unique, and does not recognise the rights of the old user on the new drive.

    What you need to do is take ownership of the whole data drive using the new user - there are many ways of doing this but there is a tutorial on this site ... Add Take Ownership to Context Menu in Windows 10 just install this go to the root of the data drive and right click and use the take ownership option.

    Be aware you should never use this method on the local system drive as it would likely render Windows unusable
      My Computers

  9. ArthurDent's Avatar
    Posts : 215
    Windows 10 Pro (x64) 20H2 (OS Build 19042.630)
    Thread Starter
       #9

    Thank you Fabler 2

    That sorted it.

    Kind regards

    Art
      My Computers

  10. Berton's Avatar
    Posts : 10,526
    Win10 Pro Versions 2004 and 2009/20H2, Win10 Pro IP_Dev, Win10 Home 1909
       #10

    [QUOTE=ArthurDent;1872689]Forgive me for not being accurate./QUOTE]
    I guess my language being somewhat convulated English didn't explain my thought correctly enough that anytime a device displays information that is incorrect that device must be considered as suspect, may not work properly.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:11.
Find Us




Windows 10 Forums