Autoplay (or is it autorun?) issue with mounted images inf ignored


  1. Posts : 681
    Windows 10 x64 Pro
       #1

    Autoplay (or is it autorun?) issue with mounted images inf ignored


    So after re-installing daemon tools (i didnt get the memo that sptd got perma broken with windows 1903) I discovered (likely an issue prior, just noticed now) that I wasnt getting the icon in my navigation pane for whatever iso I mounted.

    this was further determined to not be presenting me with the context menu items for "Install or run program from your media" and "Open AutoPlay" etc.

    the only related context menu item I would see is "Eject"

    I thought it may be Daemon tools specifically, so i re-associated iso's with windows and the result was the same (which is likely the crux of the issue) as even when associated with DT windows context menu should be presenting that stuff.

    I did test on another PC with DT installed, and it worked properly. Tested on a clean VM, worked properly.

    Anyone able to see where the issue would lay? Autoplay settings are the same between them. Im fortunate enough to at least have multiple environments to compare against but im stuck.

    - - - Updated - - -

    well, been working on it. Turns out like most things windows 10 has half arsed, they fragmented the settings for it between settings, and between control panel.

    It does in fact work (the autorun(play?)) if i set a default in the control panel section.

    What is not working is im not getting the icon from the autorun.inf, nor am i getting the context menu entries.

    hopefully that narrows it down.

    seeing as though it is autorun'ing the exe which i can assume is only possible via an autorun.inf - that portion does in fact seem valid.

    I just need to ascertain why its not picking up the icon along with everything else, and why its not giving me the context menu items.

    - - - Updated - - -

    seems in this key
    Code:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2
    its not creating a CLSID but a empty key with its drive letter every time i mount something.

    Unsure if that is a cause or symptom, but it should have a CLSID populated with an _Autorun key and a shell key among other things
      My Computer

  2. spunk's Avatar
    Posts : 2,836
    Windows 10 Pro 64 Bit 20H2
       #2

    Did you try uninstalling Daemon Tools restarting and then Reinstalling?
      My Computer


  3. Posts : 681
    Windows 10 x64 Pro
    Thread Starter
       #3

    spunk said:
    Did you try uninstalling Daemon Tools restarting and then Reinstalling?
    nope, but i might as well. On the other pc's a simple unassociation with DT will swap the context menu from DT's handling, to Windows handling. Either way regardless of which one is handling the open Autoplay and Install or run program from your media context menu items show though.

    Will give it an uninstall and see if it changes anything.

    - - - Updated - - -

    well a complete revo uninstaller purge of daemon tools (which resulted in my mmc being broken - fortunately i have a restore point) ended up with the result being the same. What did i learn? that ive been lucky in the past with revo uninstaller and to approach it 10x more cautiously now.

    wherever the context menu handler that takes care of those items is located - its still a no go though. Shaping up to be one of those days. a solid 6 hours into this atrocity now lol.

    brb while i restore my mmc back into functionality :P

    - - - Updated - - -

    and as magically as it appeared, it resolved.

    I restored from a macrium image after the revo uninstaller butchering (restore point didnt cut it). I mounted a few iso's and removed a few usb sticks and mounted a new iso i had just created to compare to an older version and noticed it was showing the proper icon for the executable which was absent previously.

    right clicked on it. voila. i magically have the context menu back.

    while im glad i can move on. Salty i fried so many hours today pouring through group policy, registry, settings, the google, these forums.

    Wish i knew what was causing it because god fooooorbid! :P
      My Computer

  4. spunk's Avatar
    Posts : 2,836
    Windows 10 Pro 64 Bit 20H2
       #4

    I restored from a macrium image
    Whenever you have a software computer issue, virus, a program not reinstalling or trouble uninstalling. Restoring your image is the fastest solution. If your computer is running great now, consider creating a New Image for today.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:10.
Find Us




Windows 10 Forums