problem with "sysprep" and language  

Page 1 of 2 12 LastLast

  1. Posts : 10
    windows 10 pro
       #1

    problem with "sysprep" and language


    Greetings!


    i have small problem with sysprep

    im using this answer file

    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OEMInformation>
                    <Logo>C:\Windows\System32\oemlogo.bmp</Logo>
                    <Manufacturer>Ten Forums</Manufacturer>
                    <SupportHours>24/7</SupportHours>
                    <SupportPhone>+44 123 456789</SupportPhone>
                    <SupportURL>https://www.tenforums.com</SupportURL>
                </OEMInformation>
                <CopyProfile>true</CopyProfile>
                <OEMName>Ten Forums</OEMName>
                <RegisteredOrganization>Ten Forums</RegisteredOrganization>
                <RegisteredOwner>Kari</RegisteredOwner>
            </component>
        </settings>
    </unattend>

    the problem with this is

    i download two languages French and English in the audit mode and the main system language is English but after running the sysprep and do the OOBE restart then i enter the PC as a client
    the problem is if i choose the french language in the startup menu the language remain English and i have to go settings then Language and choose french language .

    how to prevent this from happening please help me, thank you

    im doing this in Windows 10 Pro version 1909 with its latest updates.
    Last edited by captobaid; 17 Feb 2020 at 10:15.
      My Computer


  2. Posts : 3,750
    several
       #2

    Perhaps try this:

    if not exist %systemroot%\panther mkdir %systemroot%\panther
    if not exist %systemroot%\panther\unattend.xml copy %systemroot%\setup\scripts\unattend.xml %systemroot%\panther\unattend.xml


    <?xml version="1.0" encoding="utf-8" ?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="oobeSystem">
      My Computer


  3. Posts : 10
    windows 10 pro
    Thread Starter
       #3

    SIW2 said:
    Perhaps try this:

    if not exist %systemroot%\panther mkdir %systemroot%\panther
    if not exist %systemroot%\panther\unattend.xml copy %systemroot%\setup\scripts\unattend.xml %systemroot%\panther\unattend.xml


    <?xml version="1.0" encoding="utf-8" ?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="oobeSystem">
    kindly can you please explain it, and where i will put this codes ?

    im not expert in windows codes i just copy paste
      My Computer


  4. Posts : 1,656
    Windows 10 Pro x64
       #4

    See if there is anything in here that can help:
    Customize Windows 10 Image in Audit Mode with Sysprep
      My Computers


  5. Posts : 10
    windows 10 pro
    Thread Starter
       #5

    Golden said:
    See if there is anything in here that can help:
    Customize Windows 10 Image in Audit Mode with Sysprep
    i cant find what im looking for
      My Computer


  6. Posts : 1,656
    Windows 10 Pro x64
       #6

    @Kari : are you able to help here please?
      My Computers


  7. Posts : 1,656
    Windows 10 Pro x64
       #7

    captobaid said:
    i download two languages French and English in the audit mode and the main system language is English but after running the sysprep and do the OOBE restart then i enter the PC as a client
    the problem is if i choose the french language in the startup menu the language remain English and i have to go settings then Language and choose french language .
    Doesn't Step 3.5 in the tutorial answer your query?

    Create media for automated unattended install of Windows 10
      My Computers


  8. Posts : 10
    windows 10 pro
    Thread Starter
       #8

    Golden said:
    Doesn't Step 3.5 in the tutorial answer your query?

    Create media for automated unattended install of Windows 10
    i dont want a default language setting for all the users. i want the customer to choose his language and when the PC boot to the desktop it shows the language he chosen in the welcome page not the language i set in the answer file.

    - - - Updated - - -

    any help please ??
      My Computer


  9. Posts : 4,224
    Windows 10
       #9

    Just FYI, @Kari's been indisposed lately, owing to a bout of influenza. I'll bring this thread to his attention. Not sure he'll be back to his usual routine for another couple of days, though.
    --Ed--
      My Computers


  10. Posts : 17,661
    Windows 10 Pro
       #10

    captobaid said:
    i download two languages French and English in the audit mode and the main system language is English but after running the sysprep and do the OOBE restart then i enter the PC as a client
    the problem is if i choose the french language in the startup menu the language remain English and i have to go settings then Language and choose french language.
    I I must admit I have not a clue about why it doesn't work, I make regularly multilingual Windows images, never had any issues with them.

    In screenshot the OOBE language selection screen using my latest image with English, Finnish (Suomi), Swedish (Svenska), and German (Deutsch). If you can see a similar screen when booting to OOBE, showing French and English, it should work:

    problem with &quot;sysprep&quot; and language-oobe-language-selection.jpg

    Kari
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:58.
Find Us




Windows 10 Forums