MKLINK not working  


  1. Posts : 10
    Windows 10 64-bit Home Ver 2004 (Build 19041.450)
       #1

    MKLINK not working


    winver 18363.628

    Never had any problems with this before. Re-checked the MKLINK tutorial, trying cmd and PowerShell. Added the quotes to target and link too, but same result

    So here are the commands in cmd with error messages. Note that I tried the hard link option too (/h). The link is being made to a target on the same logical drive (volume). Drive D: is FAT32 and is a partition on an SSD physical disk with the C: logical drive (NTFS-formatted, of course). I see no indication that symlinks (soft or hard) are not supported on FAT32 drives

    Code:
    D:\service.web.mySite> mklink /d  "style" "D:\service.web.Root\style"
    The device does not support symbolic links.
    
    D:\service.web.mySite> mklink /d /h "style" "D:\service.web.Root\style"
    Local NTFS volumes are required to complete the operation.
      My Computer


  2. Posts : 14,019
    Windows 11 Pro X64 22H2 22621.1848
       #2

    Links (Symbolic or Hard) require NTFS, don't work on FAT32.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:18.
Find Us




Windows 10 Forums