Hi! Let me tell you the whole enchilada:

On Q4 2017 I upgraded my PC: AMD Ryzen 7 1700, ASUS Prime x370-Pro, 500GB Samsung NVMe M.2 (and a 4TB Seagate HDD for media and file storage), 16GB (2x8gb) DDR4 G.Skillz TridentZ 3200mhz RAM, EVGA 600W Bronze PSU, Zotac's NVIDIA GTX1060. I use my pc mainly for Photoshop, web browsing, watch movies/series, and some gaming (witcher 3, GTA Online, Diablo III, a lot of old RTS like Age of Empires II or Age of Mythology, etc). Sometimes I experienced a black screen, and the motherboard and CPU lights were still on, as the system and CPU fans. It was very random (it could happen as I was playing, or working, or even idling), it wasn't often, and I just thought it may be caused by drivers or BIOS, as it was a 1st gen Ryzen, the platform was new, etc. I could have experienced a black screen and restart the pc, and play GTA Online for hours without an issue.

Time passed by, and the black screens were becoming more frequent. My system got the 1909 update, and things got worse: the black screen could appear daily, and soon, I wasn't able to get to the desktop. I tried safe mode, and it was stable. I ran some malware tests, I downloaded Autoruns, I didn't noticed anything strange. As it didn't let me login to my account, I decided to do a clean install.

I had the latest Windows iso (1909) on a usb, and began to install. The first stage (selecting where Windows will be installed, copying files, etc) went quickly and without issues. The setup launched a message saying it needed to reboot. I got to the next stage, the one who asks about language, keyboard settings, etc. Aaaaand... the black screen appeared again. As soon as I click to confirm my language settings, the screen goes black and I'm in a loop. If I restart the pc, the win 10 setup says the pc didn't shutdown properly and asks for troubleshooting or a restart. I can't do troubleshooting as it asks for the password for the "defaultuser0" account. If I restart my pc, the setup goes again to the second stage, and the black screen appears as soon as I click to confirm my language settings.

I got a nice deal on a MSI B450 Carbon Gaming Pro, and I thought my asus motherboard was probably the culprit, so I went ahead and bought the B450 Carbon. I installed my hardware, went to the BIOS, loaded default settings and began a clean install again (I left connected only my M.2 ssd). It did the exact same thing as the old motherboard: black screen on a clean install, on the Language settings screen. Now, this motherboard has a feature named "EZ debug led". As soon as the black screen appears, a red led turns on, signaling a CPU fault. According to the manual, it says the led turns on as the CPU is not detected or fails. (By the way, when I removed my Ryzen to the MSI board, I cleaned it up and applied new thermal paste, and made sure it had no bent or broken pins, and the heatsink is snuggly fitted)

I tested again, removing my m.2 ssd and tried with a brand new, sealed WD HDD. Black screen again, same stage.
I got an old Nvidia GTX 750Ti (it works without the extra power cables), and tried again. Black screen on the language settings... again

A friend offered to test my usb drive with the Windows 10 1909 ISO for a fresh install in his pc. It worked just fine, so a corrupt ISO can be discarded. My friend told me to try another OS. I had an old usb drive with a win 8.1 ISO. Guess what? It finished. I got to the desktop, I could download updates. I went yo youtube and started playing random videos, and it was stable. So much for that debug led on my motherboard...

So I tried my luck, and began the process to upgrade win 8.1 to win 10. The microsoft tool downloaded whatever was needed, and started to install. It all went well, until it rebooted some times and I got to the language settings screen... which, as you can assume, got me the black screen as soon as I clicked to confirm my language. (and the EZ debug led for the CPU got turned on again)

I'm really frustrated. Do I have to buy a new CPU? Memory? PSU? If anyone has encountered the same situation, what did you do? I guess I could reinstall windows 8.1, but a lot of drivers for my system are missing, and a message appears every time I logged in, nagging me to upgrade to windows 10 as my hardware is not supported by win 8.1. Thanks in advance!!