"ms-settings:" URI doesn't work in Windows 10


  1. Posts : 4
    windows 10 Pro
       #1

    "ms-settings:" URI doesn't work in Windows 10


    Hello tenforumers,

    I have a Windows 10 Pro - 10.0.18363 on a Lenovo Ideapad 720s

    Since a few weeks, all my "ms-settings:" URI doesn't work:
    • From contextual menu: display, personnalisation-background, etc.
    • From driver updates on Device Manager link's "search windows update"
    • From any "ms-settings:" start command in explorer, cmd, powershell , etc.


    BUT, contrary to many similar cases found on the internet, I have access to the settings from the start menu.
    It seems that the generic URI/variable linking "ms-settings" to windows 10 settings menu are missing somewhere giving me some error message like "this file does not have a program associated..." or
    "explorer.exe - application not found" (but explorer.exe is working).
    I really tried many things before posting here: WSReset, SFC, DSIM, Get-AppXPackage, uninstall last Windows update and install it back etc.
    I've done a virus scan, a malware scan, settings restore.
    I created a new account, gave it administrative rights and had no issue on this new account.
    I can copy my files to this new account and delete my original admin account but I really want to understand what's going on and where is this "ms-settings:" variable stored in Windows 10 Pro.

    If someone can share some details on how and where is stored the "ms-settings:" URI link in windows, it will be appreciated.
      My Computer


  2. Posts : 69,615
    64-bit Windows 11 Pro for Workstations
       #2

    Hello biroutex, and welcome to Ten Forums.

    I'm not sure where the registry value is for this, but you could see if a repair install of Windows 10 may be able to fix this without losing anything if wanted.

    Repair Install Windows 10 with an In-place Upgrade
      My Computers


  3. Posts : 43,282
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #3

    I created a new account, gave it administrative rights and had no issue on this new account.
    That's a good diagnostic check, and suggests that an in-place upgrade repair may well not help- but you might be lucky.

    Since a few weeks,
    - do you have any idea what happened at that time (a few weeks ago)?

    Did you try using a system restore point when you discovered that had happened?


    This problem is known on the internet. For example I searched for
    Start ms-settings:about file does not have a program associated
    Fix: this file does not have a program associated with it for performing this action - Appuals.com
    How to fix MS-SETTINGS DISPLAY This File does not have a Program Associated with it (Windows 10) - wintips.org - Windows Tips & How-tos

    This may help:
    Restore Default File Type Associations in Windows 10
      My Computers


  4. Posts : 4
    windows 10 Pro
    Thread Starter
       #4

    Thank you both Brinks and dalchina for your feedback. I appreciate.

    @Brinks: I'm considering doing an in-place upgrade or even a full fresh install but I wanted to understand the "behind the scene" of this very strange issue as it's due to a very simple missing URI link somewhere (as I have access to settings directly from the start menu).
    I already tried to DSIM and Get-AppXPackage to recover original settings. The issue is probably due to something else.
    I also can use the second account I created to use it as my main account but I'm afraid that this will lead me to some rights/privileges issues.

    @dalchina: The second account not being affected by the issue gave me hope first but I can't understand what to copy from first to second account in order to recover my URI links.

    - do you have any idea what happened at that time (a few weeks ago)?
    I had a windows update (that I uninstalled and reinstalled) but I can't be sure as I don't use those ms-settings URI everyday.

    Most of the posts found on the internet are talking about ms-settings URI and the start menu not working.
    I'll try to do the file type associations restoration thing as I already tested the other methods listed on the wintips website.

    I'll keep you updated
      My Computer


  5. Posts : 4
    windows 10 Pro
    Thread Starter
       #5

    I tried today to do an in-place upgrade but it didn't solve my issue. I only tried the simple in-place upgrade keeping my programs and settings.

    dalchina said:
    Did you try using a system restore point when you discovered that had happened?
    Unfortunatly I disable this feature when I setup a computer to save some space because I'm used to solve the drivers, infections, etc, issues by myself. I also usually do some full image backup on my local network. But this time I did not...
    This issue just proves that I am so wrong about that.

    I also tried to restore file type association without any luck.

    I will probably use the second account I created and copy my desktop and documents on it.
    But I'm really frustrated to not find the probably simple entry point of this ms-settings URI
      My Computer


  6. Posts : 43,282
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #6

    As I suggested, that you only see this in one account indicates it's just a problem in that user profile. An in-place upgrade repair typically does NOT fix issues particular to a user profile.

    I did post links previously that may help.

    You might also simply consider abandoning the damaged user account and transferring everything to a new one as you say.

    You say you don't have system restore enabled- it is unreliable when restoring, but can do no harm.

    Given that, and that tenforums members so often advocate the routine use of disk imaging which can give you a second chance to restore Windows or any imaged partition to a previous good state, I suggest for the future you should look into that. Macrium Reflect (free-paid) + large enough external storage. But note- that's quite different to system restore. The nearest thing I know to that is Rollback RX.
      My Computers


  7. Posts : 4
    windows 10 Pro
    Thread Starter
       #7

    dalchina said:
    As I suggested...
    You were right about the in-place upgrade. I can confirm that
    I also usually have the full image backup routine in a raid 5 array on my home network, but I did not have access to it for months.

    I also tried all the solutions listed in your post and the only working solution is to use another account.
    I'm in the process of having everything working like on my main account.
    But it's a very time consuming and painful process to solve a very tiny issue that is ms-settings URI not working.
    I have access to the parameters (even from the icon in explorer.exe) , the start menu, etc...
    I'm pretty sure that it's just a sort of -hard- coded variable somewhere and to not find any info about it anywhere surprises and frustrated me a lot.

    But I'd like to thank you again for your answers
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:07.
Find Us




Windows 10 Forums