Reagentc failed

Page 3 of 3 FirstFirst 123

  1. Posts : 2
    Windows 10 Pro
       #21

    cognus said:
    I was in the same situation but I had a hard time to set the path; eg: reagentc /setreimage /path D:\Recovery\WindowsRE

    It wouldn't let me. I had to do the following inside DISKPART (Using your snapshot for the syntax):
    - "select disk 0"
    - "select volume 0" (your partition listed #1 as the Recovery)
    - "assign letter = D"
    Note: commands without double quote

    After above steps, "reagentc /setreimage /path D:\Recovery\WindowsRE" will work.

    The file ReAgent.xml under C:\Windows\System32\Recovery will be updated (if you made a backup prior, you will notice the updated timestamp)

    Another way instead of using Drive letter, syntax is as follow:

    "reagentc /setreimage /path \\?\GLOBALROOT\device\harddisk0\partition1\Recovery\WindowsRE"
    (note the bolded variable that matches the information from DISKPART)

    When REAGENTC.EXE: Operation Successful. Windows RE status will always be disabled still.

    In order to enable Windows RE status, you need to reboot into the Bios then turn off Legacy Bios in CSM and Secure Boot will automatically pickup the Windows EFI System Partition. Save the Bios and boot into Windows.

    Once started, Windows RE status will be Enabled automatically. No need to enable it.

    In System Information Bios Mode will be UEFI.

    Hope this explain a bit more of the final step as I was struggling why I couldn't enable the RE status when "reagentc /setreimage /path D:\Recovery\WindowsRE" was successfully completed.

    Good luck!
      My Computer


  2. Posts : 39,954
    windows 10 professional version 1607 build 14393.969 64 bit
       #22

    Has the reagentc problem been solved or does it still need troubleshooting?
      My Computer


  3. Posts : 2
    Windows 10 Pro
       #23

    I'm happy to resurrect this, because I'm dealing with the same thing.

    Here's the catch, tho: when I do reagentc /setreimage, it says the operation was successful, I KNOW I got the path right, and I KNOW the partition is good, but it still doesn't show a path when I do reagentc /info, which means when I try to /enable I still get told that I'm unable to update BCD.

    Potentially related issue: my machine displays two Windows Boot Managers in the UEFI BIOS, but only one of them works, the other gets me stuck in a boot loop. I would very much like to get rid of that second faulty entry as well as I suspect that would help me fix this issue.

    Can someone let me know what information I can provide? To start, here's my bcdedit -enum -v:

    Code:
    C:\windows\system32>bcdedit -enum -v
    
    Windows Boot Manager
    --------------------
    identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
    device                  partition=\Device\HarddiskVolume2
    path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI
    description             Windows Boot Manager
    locale                  en-us
    inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
    default                 {75f8ddc5-c00d-11eb-8a5f-88a7e57703b2}
    resumeobject            {75f8ddc4-c00d-11eb-8a5f-88a7e57703b2}
    displayorder            {75f8ddc5-c00d-11eb-8a5f-88a7e57703b2}
    toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
    timeout                 30
    
    Windows Boot Loader
    -------------------
    identifier              {75f8ddc5-c00d-11eb-8a5f-88a7e57703b2}
    device                  partition=C:
    path                    \windows\system32\winload.efi
    description             Windows 10
    locale                  en-us
    inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
    recoverysequence        {690e4318-bdbf-11eb-b4fe-d57578dbc911}
    recoveryenabled         Yes
    isolatedcontext         Yes
    allowedinmemorysettings 0x15000075
    osdevice                partition=C:
    systemroot              \windows
    resumeobject            {75f8ddc4-c00d-11eb-8a5f-88a7e57703b2}
    nx                      OptIn
    bootmenupolicy          Standard
    Thanks much!

    -- Chris
      My Computer


  4. Posts : 17,246
    Windows 11 Pro
       #24

    Open Run by pressing Win + R. Run MSCONFIG. Under the boot tab, do you see two entries? Delete the extra entry there.
      My Computer


  5. Posts : 2
    Windows 10 Pro
       #25

    NavyLCDR said:
    Open Run by pressing Win + R. Run MSCONFIG. Under the boot tab, do you see two entries? Delete the extra entry there.
    Nope, just the one entry.

    If I look at Visual BCD, I see two entries under "Loaders", one, for "Windows 10," has the same data as "Windows Boot Loader" above, and "Windows Boot Manager" has the same data in both.
      My Computer


  6. Posts : 1
    Windows 10
       #26

    NavyLCDR said:
    Having reagentc disabled will neither prevent the system from booting nor will it make recovery impossible. There are probably 100's of thousands of computers out there with reagentc disabled and the users have no idea at all about it. All of the functions of the recovery environment can still be used by booting from a Windows 10 installation USB flash drive or DVD.
    Thanks for this post, God bless you :)

    I used the mbr2gpt and had reagentc disabled and I was worrying trying to enable it and was failing miserably xD
    I was afraid to make a reboot even xD but when I finally did, everything worked, my problem (Windows didn't want to send audio through HDMI) was solved and - surprisingly - reagentc is now enabled

    PS I registered here just to write this (probably not gonna stay longer, bye )
      My Computer


  7. Posts : 17,246
    Windows 11 Pro
       #27

    bratmucha said:
    PS I registered here just to write this (probably not gonna stay longer, bye )
    Oh come on now! We're a decent group of people to hang out with!
      My Computer


  8. Posts : 25
    Win 10 64 Pro
       #28

    For me, post #2 was the answer, all you had to do to reenable RE was boot back to BIOS, get rid of CSM and then enable worked. There were a couple of trip points, but easily overcome.

    First, I used MiniTools MiniTool Partition Wizard | Best partition magic alternative for Windows PC and Server to see that, of the two RE partitions I had, the last one was half size and had no data. So I deleted it. That let MBR2GPT run with same outcome as OP. For who knows what reason, Win 10 64 DriveManager wouldn't let me assign a letter to this recovery partition, but MiniTools would. So I did per post 2 and it worked, obviously swapping F: for the letter I assigned.

    Still wouldn't enable RE, and the message is the clue. So shutdown and start up in bios. Change CSM to UEFI. startup just fine. Elev cmd and now enable works. Presumably that is 'job done', although I am left wondering if the RE is in good order, but hey, not so important as get it off install disk if needed.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:26.
Find Us




Windows 10 Forums