Search broken?

Page 1 of 2 12 LastLast

  1. Posts : 51
    W10 Home 64-bit
       #1

    Search broken?


    Some strangeness going on with my PC.

    I was having a problem with our HP printer, and kept getting an 'error state'. I could not remedy the problem, so I restored the system back to an earlier point yesterday.

    Now, I have noticed when in the Windows Settings, typing something in the search bar brings back no results. It was working fine up until yesterday.

    I don't think the search bar on the Taskbar (?) is affected oddly enough, it can do it from there.

    Can anyone offer any solutions with this problem please?
      My Computer


  2. Posts : 4,551
    Windows 11 Pro 64-bit
       #2

    Within opened Powershell type below command and press Enter key:

    Code:
    Get-AppxPackage –AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}



    This tells Windows to install those default apps again. Give it some time and allow it to finish, even if nothing appears to happen at first. Even if you see an error message, restart and examine your Settings app.
      My Computer


  3. Posts : 35,531
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #3

    It's possible you have a problem with indexed search which search there relies on. Is normal indexed search working properly?
    Have you ever disabled it? (IMHO there's no real justification for doing so although mythology born of XP days persists).

    Check to see if the number of indexed items show in Indexing Options increments if you add an item to an indexed folder.

    And see:
    Windows 10 Settings Search not working
      My Computers


  4. Posts : 51
    W10 Home 64-bit
    Thread Starter
       #4

    Freebooter:

    I did run that command as you said, quite a few error messages usually of a 'higher version already exists' (from what I could tell with my limited knowledge). I think in one case it said "AppManifest.xml does not exist" or something.

    It hasn't fixed it yet though.

    - - - Updated - - -

    Dalchina:

    I haven't knowingly disabled search indexing. From Explorer, searching works as usual. Also on the task bar (Cortana?), that seems to work OK as well, I get the same results from typing (say) "Create a Restore Point", as what used to happen in the Window Settings search bar.

    - - - Updated - - -

    I have just tried Dalchina's link where it talks about

    C:\Users\<username>\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

    In that folder, there should be another folder called Indexed, but instead there is nothing.

    I will now try a sfc /scannow, and see what that tells me.

    - - - Updated - - -

    sfc found no integrity violations, so now I am going to try the three dism commands as suggested.

    - - - Updated - - -

    OK, the three DISM checks (scanhealth, checkhealth and restorehealth) have now completed, and no problems with those.
      My Computer


  5. Posts : 35,531
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #5

    Thank you for your reply.

    From Explorer, searching works as usual
    This isn't proof, as given, that indexed search on your PC is actually working. Remember that search (non-indexed) also occurs from there.

    Please see my previous post on that.

    Search in Settings also depends on your not having changed certain defaults in [Control Panel] Indexing Options.

    You could try Option 3 here if you believe that's a possibility:

    Rebuild Search Index in Windows 10

    Windows 10 Settings Search not working
    It looks as if this may be obsolete- usually reliable source. Sorry, should have checked mine as well I suppose.


      My Computers


  6. Posts : 51
    W10 Home 64-bit
    Thread Starter
       #6

    Thanks for replying.

    I haven't changed anything as far as I'm aware. I'll now try option 3 as suggested.

    - - - Updated - - -

    - - - Updated - - -

    I have tried that as instructed (BAT file ran as administrator), though it doesn't seem to have made any difference.
    Last edited by mjbj403; 20 Oct 2019 at 07:34.
      My Computer


  7. Posts : 35,531
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #7

    If the necessary items were already in Indexing Options it wouldn't have fixed the problem, as I indicated, but that's one possibility down.

    Please
    a. Try this troubleshooter:
    Search broken?-1.png
    (I've given it from Control Panel- also available via Settings- which you can't search).

    b. Re-register Settings
    Reinstall and Re-register Apps in Windows 10
    (search that for Settings and follow instructions at top of the section)

    c. Confirm indexing is complete and a number of items are shown as indexed in Indexing Options.


    Some find that it's necessary to perform an in-place upgrade repair install which keeps all progs and data to resolve this.

    Here are further things people have done:
    How can I make Windows 10 search my settings/control panel items? - Super User
      My Computers


  8. Posts : 51
    W10 Home 64-bit
    Thread Starter
       #8

    Apologies for the delay (I've had to do something).

    Tried the troubleshooter (found in Update & Security), but it wasn't able to help me.

    I do have W10 1903 on a USB stick to do a in-place repair upgrade anyway, but I will now try steps b and c first.

    Before I do continue: in step b is it option one, two, or three I need please?

    Thanks for your assistance.
      My Computer


  9. Posts : 35,531
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #9

    To confirm, do you mean
    a. The troubleshooter showed no problems
    or
    b. The troubleshooter found problems and couldn't fix them?
      My Computers


  10. Posts : 51
    W10 Home 64-bit
    Thread Starter
       #10

    The troubleshooter found no problems.

    - - - Updated - - -

    Just to be clear I have understood, according to Option 2, I open a command prompt.

    Then, for Settings which I found in the instructions, I copy and paste that.

    Is that correct, please?

    - - - Updated - - -

    OK, well I tried the above command, and no success.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:03.
Find Us




Windows 10 Forums