Cannot Delete or Rename .fff (Hasselblad scanner) Files

Page 1 of 3 123 LastLast

  1. Posts : 1
    michaelmiller
       #1

    Cannot Delete or Rename .fff (Hasselblad scanner) Files


    I am using am using a Hasselblad scanner attached to an Apple computer to scan old b&w negatives. The scanner creates .fff files, which is apparently a TIFF file by another name. When I move the files to my Windows 10 PC, I am unable to delete or renames the files or a directory that hold the files. When I try Explorer often hangs up and I have to close it. I can copy the files.


    This is not a permissions issue. I've tried repeatedly after rebooting to insure that the files are not open in another program. Using the Command Prompt does not help. In Safe Mode I was able to delete a directory of the files, but not rename an individual file.
      My Computer


  2. Posts : 35,448
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #2

    Hi, can't really help.. FWIW here's what I see:
    I created a dummy.fff file (obviously not a genuine one) on my desktop.

    I noted it was associated with the Photos app.
    I could delete, recover, and rename it.

    Similarly if located in Pictures.

    I wonder what happens if you create a dummy file (e.g. rt click, new, txt file then rename it as dummy.fff ).
    Would Windows treat that any differently to the ones you've copied from your Apple device?

    What are your fff files associated with?
      My Computers


  3. Posts : 6
    Windows 10
       #3

    I've got the same problem as MPMiller. FFF-Files from my Hasselblad Scanner can't be renamed or deleted in Windows 10. All Admin-permissions are given. Neither the command prompt "del" nor third-party Software is able do delete these files. The only workaround so far, is to change the properties of Trash to instantly delete and not move the files. Only then can I (with a few attempts and luck) delete them. Really nasty.
    Has someone found another way yet? Or any Ideas why only Windows 10 is handling these files this way?
    As for dalchinas answer: The association of these Files is by default "flexcolor" (the Scannersoftware) but it doesn't change a thing to change the association to something else.

    Thankful for any suggestions!
      My Computer


  4. Posts : 35,448
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #4

    Thank you for your post. Note that with over 1000 views, it seems yours is an unusual situation, perhaps somehow related to the software in use so without that, others don't have this experience.

    You've not tried quite the experiment I suggested, it seems.

    A somewhat more sophisticated tool like Emco Unlockit (free) allows you both to check for anything locking files and to delete them on restart (i.e. free of implications of permission or other programs running).
    Cannot Delete or Rename .fff (Hasselblad scanner) Files-1.png

    Emco MoveonBoot supports rename, move and delete on boot: also free.
    Download EMCO MoveOnBoot 3.0.1 Build 3569
      My Computers


  5. Posts : 6
    Windows 10
       #5

    Thank you for your fast response. UnLock IT was one of the third-party software solutions I tried to delete these files with. It tells me that the files are not locked and crashes when I try do delete the file (same as the explorer). Seriously I tried everything. And also I can't find a pattern in the behaviour. Sometimes I'm able to delete some files, sometimes none and sometimes only some if they are enclosed within a folder. It does not seem to be related to the software, that generates them (flexcolor) as I have uninstalled it and ended up with the same result. Look, here is a File: WeTransfer it is about 500mb. See if you can rename or delete it on your machine and if you can make any sense out of it.

    Cheers!
      My Computer


  6. Posts : 1,513
    X
       #6

    Can you try to delete these files from a DOS prompt?
    Or ... how about deleting from a Linux shell?
      My Computer


  7. Posts : 6
    Windows 10
       #7

    Tried the DOS prompt - It just freezes. Also I just freshly installed Win10. That also did not help. But I just got a complete new error while trying to delete a FFF file. It said, that the action can't be finished because the File is opened in "COM Surrogate". So it might have something to do with the integrated preview picture? Well, I guess I'll go back to quitting the windows-explorer task over and over again until - randomly - it lets me delete the files. Thanks anyway, kind stranger!
      My Computer


  8. Posts : 3,678
    Windows 11 Pro 64 Bit 21H2
       #8

    Right click the Taskbar and open Task Manager Take the drop down arrow and choose More Details. Under Processes tab look for COM Surrogate, select it and press End Task. Go to the Services tab, and find dllhost.exe and End task. Try deleting again.
      My Computer


  9. Posts : 35,448
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #9

    Specifically did you try using Unlockit to delete on restart?

    And do try the dummy file trick- the content is then not that of a valid .fff file so Windows' action may be different.

    Downloaded your file- as you say, explorer hangs, crashes and restarts if I try to delete it.
    Oddly, nothing in Reliability History.
    It's associated with Photos in my case by default.

    In my case Emco Unlockit deleted it without a restart. (And there was nothing locking it).

    N.B. I used the Delete button in Emco Unlockit to select the file
    - not drag 'n drop.
      My Computers


  10. Posts : 6
    Windows 10
       #10

    As for ending the tasks "COM Surrogate" and "dllhost.exe" - it does not help.

    I just installed the latest version (5.0.2) of Unlockit (did use an out of date one before) and it seems to delete the files reliably now.

    Thats a plus - but still the Problem remains, that I can't handle the files properly. My workflow usually contains renaming the files (sometimes just the ending *.fff to *.tif in oder to open them in Photoshop) moving them around and so forth. All that has never been an issue in an unix environment (MACOS). As I am dealing with these file-types on a daily bases this remains a real pain - even though beeing able to delete them now is an upgrade.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:18.
Find Us




Windows 10 Forums