Cannot Delete or Rename .fff (Hasselblad scanner) Files

Page 3 of 3 FirstFirst 123

  1. Posts : 35,428
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #21

    Thank you for your reply.

    If you read what I found for you, that was what worked and simpler attempts didn't.

    It's easy enough to try, and you can always reinstall it. Up to you- clearly others have struggled with the same thing.

    Doesn't look like you'll get more here - I imagine relatively few will be in exactly the same situation.
      My Computers


  2. Posts : 6
    Windows 10
       #22

    Yaaay!! I've got a reply from Hasselblad. The fix they recommend works - in part - for me and might be a suitable solution for most users with that specific Problem. So I want to share:

    "The cause does not seem to involve FlexColor. It seems to be that the “.fff” extension has been mapped to the standard Windows “PhotoMetadataHandler.dll", which apparently does not handle that file type, so when the Windows Explorer tries to read metadata from the file using that handler it locks up. I am not sure what sets up that mapping, as it does not seems to be something FlexColor nor Phocus does.



    To check if the mapping is set on your computer run “ reg query "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers\.fff" ” from a command prompt. I have attached a zip-file with two .reg-files. “Remove fff-handler.reg" can be run to remove the fff-mapping, to see if that resolves the issue. "

    Here is that File: https://hasselblad.zendesk.com/attac...ff-handler.zip

    What it does is basically fix the Problem for all fff files. After running the reg they can be deleted and renamed again.
    BUT! - the problem persits for me, since I usually rename the fff into tif to then open them in Photoshop (there is no fff plugin since CS6) and these tif files now behave just in the same manner as the fff files used to.

    So is there anybody out there, that can tell me how I can change the mapping of my tif files just as that reg file did to the fff?

    That would be amazing! I keep you posted if i hear back from the R&D team from Hasselbald, that is supposedly now involved.

    But already thanks to eveyone breaking their heads with me!

    - - - Updated - - -

    ps.: deleting the photos app didn't do the trick at all
    pps.: running process monitor was inconclusive - to say the least :)
      My Computer


  3. Posts : 7,484
    Windows 10 Home 20H2
       #23

    USERX1 said:
    I have attached a zip-file with two .reg-files. “Remove fff-handler.reg" can be run to remove the fff-mapping, to see if that resolves the issue.
    One line of commands will do the job.

    To remove .fff
    Code:
    (REG Delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers\.fff" /F)

    To restore .fff
    Code:
    (REG Add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\PropertySystem\PropertyHandlers\.fff" /T REG_SZ /D "{a38b883c-1682-497e-97b0-0a3a9e801682}" /F)

    The commands work on both Command Prompt and PowerShell with administrative privileges.
      My Computer


  4. Posts : 1
    Windows 10
       #24

    Confirming fff-handler fix


    Big thanks to UserX1 for following up with Hasselblad and getting the fix. I had started (and wasted) a few hours trying to fix same situation, with various approaches tried by amending permissions. I tried the file handling fix listed above from Hasselblad and this immediately worked for me.

    To hopefully benefit other users, my own experience was this:

    Situation: FFF files recently transferred from MacOS (10.13) to Windows 10 Pro (20H2; OS Build 19042.964) via File Sharing (SMB). No issue getting the files onto the Windows 10 box initially; only the next steps mentioned below.

    Issue:
    A. when attempting to move the the FFF files via drag / drop or cut / paste, the file browser would freeze. Even cancelling that file transfer would freeze, with only option being to kill the process.
    B. I was trying moving the files within a storage drive, not on the main OS drive, and only from one folder to another in that storage drive.
    C. I did manage to move some files onto the desktop (OS drive), but once they were there I wasn't able to delete them. This makes me think that the deletion aspect of the file move might be the issue; i.e. that the files can be copied to a new location, but when the deletion part of the move action tries to execute, that's when the failure might be occurring.

    Solution: Using the "Remove fff-handler" from above ZIP from Hasselblad immediately resolved all issues


    Some observations from my experience:

    1. I'm not sure this is a niche experience, as was highlighted as a potential scenario earlier in the thread. It's just that a lot of Hasselblad users (cameras and scanners) are also long-time Mac users, so maybe there aren't too many instances of this experience on Windows 10 yet. Some of us (well, me anyway) have got sick of paying $6500 for a base level MacPro these days, and are migrating to Windows 10 since custom-build PCs are so much easier to access these days (at half the price). The issue might pop up more frequently if Hasselblad users are migrating.

    2. Interestingly, I definitely did some macro changes to folder structures before I started interacting with these files and getting the issue. i.e. I renamed and / or moved master folders (maybe 3-4 levels up in the folder hierarchy) and didn't experience any issues with making those changes. It was only once I got down to the file level and started to move individual files / groups of files from folder to folder that I got the issue.

    3. In my case the files were originally shot on Hasselblad cameras, not source from scanners. It appears that Flexcolor (scanning) source can be ruled out as issue, and focus on FFF file format as the root cause.

    4. I'm using a Storage Spaces RAID set-up (Parity) on Windows 10, and initially I started looking at whether I had set up something incorrectly. Once the registry patch was applied there were no issues, so I think software RAID is not a problem for this (in my case at least)
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:23.
Find Us




Windows 10 Forums