Windows 10 Enterprise Answer File not using WinPE settings


  1. Posts : 1
    Windows 10 Enterprise 1903
       #1

    Windows 10 Enterprise Answer File not using WinPE settings


    I downloaded Windows 10 Enterprise 1904 x64 (English) from the Microsoft Volume Licensing site. I am trying to create a USB drive that will select Enterprise as the version, wipe and partition the drive, answer the license agreement and then install Windows 10 and use the autounattend.xml file for the OOBE settings as well. I have followed the instructions on this site and built the autounattend.xml file (and placed it on the root of the USB drive that I use to install which I created from the Windows 10 ISO from the Microsoft VL site with Rufus) but with Windows 10 1903 it does not seem to read the settings for the WinPE settings to select Windows 10 Enterprise, partition the drive, and accept the EULA. If I do these steps manually the setup will continue and then will use the autounattend.xml file to finish the setup using the settings specified. I am wondering if something changed in the 1903 version? I did notice that the processor architecture for the section that sets the drive partitions is now set to wow64 instead of amd64 by the Windows System Image Manager but not sure if that has anything to do with it.

    Here were the instructions that I followed:
    Windows 10 Unattended install media – Part 2: Answer file for Windows Setup – Win10.Guru
    Windows 10 Enterprise Answer File not using WinPE settings Attached Files
      My Computer

  2. Kari's Avatar
    Posts : 17,580
    Windows 10 Pro
       #2

    You have a typo in the answer file. Although just one single digit is wrong, it's a game-changing typo which invalidates the whole partitioning section.

    Here's your original ModifyPartitions module:

    Code:
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Format>NTFS</Format>
                                <Label>WinRE</Label>
                                <Order>1</Order>
                                <PartitionID>2</PartitionID>
                                <TypeID>DE94BBA4-06D1-4D40-A16A-BFD50179D6AC</TypeID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Format>FAT32</Format>
                                <Label>System</Label>
                                <Order>2</Order>
                                <PartitionID>2</PartitionID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Order>3</Order>
                                <PartitionID>3</PartitionID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Format>NTFS</Format>
                                <Label>Windows</Label>
                                <Order>4</Order>
                                <Letter>C</Letter>
                                <PartitionID>4</PartitionID>
                            </ModifyPartition>
                        </ModifyPartitions>

    You have partition order correct in all partitions 1 through 4, but then you set the same ID (2) for both partitions 1 and 2. Two partitions cannot have same ID. Changing the partition ID for first partition to 1, the answer file works perfectly (I tested it, of course).

    Original:

    <ModifyPartition wcm:action="add">
    <Format>NTFS</Format>
    <Label>WinRE</Label>
    <Order>1</Order>
    <PartitionID>2</PartitionID>


    Typo corrected:

    <ModifyPartition wcm:action="add">
    <Format>NTFS</Format>
    <Label>WinRE</Label>
    <Order>1</Order>
    <PartitionID>1</PartitionID>


    And yes, ProcessorArchitecture should be amd64, not wow64.

    Kari
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:35.
Find Us




Windows 10 Forums