This has happened on 2 of my devices; a home built PC & Acer Laptop previously running Windows 7 Pro x64 & Windows Home Premium x64 respectively. Both have previously experienced little to no problems running Windows 7.

The PC was upgraded from Windows 7 Pro, then a clean build was successfully installed & ran for a couple of days. On the subsequent boot the Windows logo appeared with the rotating dots but it then stopped. On the reboot it went through diagnostics & I tried all options but there was no way to recover things.

Fortunately, I made a Macrium Reflect backup which I duly made & the PC re-booted successfully & has done ever since.

The Laptop was also upgraded, but from Windows 7 Home Premium with exactly the same thing happening. As it was an upgrade, I even tried reverting back to Windows 7 Home Premium which couldn't be done. When I checked the contents of the HD (having removed it from the Laptop) the Old Windows directory was missing! I've just restored things with a Macrium Reflect backup & await to see what happens.

I find this somewhat disappointing as I've been using the Insider Builds for several months without experiencing any start-up issue but to have this occur on 2 different devices within as many days makes we wonder if the retail version has been rushed out & is flawed.