Microsoft Text Input Application/Inicio (Start in English) processes

Page 3 of 4 FirstFirst 1234 LastLast

  1. Posts : 201
    Windows 10 Pro 64-bit
       #21

    empleat said:
    Ok it seems it is working, after restart long enough time. And it is not popping up, while it always shows little bit after booting windows... Thank you very much!

    How did you even found this key? I knew it will probably have name of app, or process in itself, but there are still many permutations to go through and many keys and values...
    I found this last year from this link. WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe blocks : Windows10

    Someone from Reddit posted the solution 2 years ago actually. But last year I found the link and decided to take the plunge. I didn't have the guts at first to try this, so I made a system restore point and then attempted it. To my surprise this solved it permanently!

    I too was wasting my time renaming this folder/ .exe file, but this was stupid as it was simply triggering errors on Event Viewer. Plus when I did SFC/ Scannow it will always restore back the file and then you'd have trouble deleting the renamed file.

    But now SFC/ Scannow does not find integrity violations anymore. All thanks to this proper fix. Nor does the error appear on Event Viewer log.
      My Computer


  2. Posts : 511
    Windows 10 Pro 64 bit 19042.985
       #22

    BLaZiNgSPEED said:
    I found this last year from this link.
    Noooooooooooo. It is baaaaack!

    I used commands you gave me, I included screenshot of registry. Tho I by a mistake wrote echo off, before echo done. No idea, if it could do anything.
    Attached Thumbnails Attached Thumbnails Microsoft Text Input Application/Inicio (Start in English) processes-textinptapp.png  
      My Computer


  3. Posts : 201
    Windows 10 Pro 64-bit
       #23

    You must have done something wrong! There is no echo off. You must copy and paste the entire code as shown from reg add to echo done, all off it...

    reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe" /v Debugger /d "%SystemRoot%\system32\systray.exe" /f
    taskkill /im "WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe" /t /f
    echo done

    This includes reg add from beginning to end. Also try and go to Services and disable Touch Keyboard and Handwriting Panel Service TabletInputService and see if that helps.

    Now, I don't know whether it is related to the version of your Windows 10. Mine is 1903. If yours is 2004 maybe there are some changes that Microsoft made.

    Is your .exe file name WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe ? If it differs slightly in the name then maybe you need to change the code name.

    After doing this, you can verify by pressing Windows+H key to see if it is returning back. This is the way to know if it is fixed.
      My Computer


  4. Posts : 511
    Windows 10 Pro 64 bit 19042.985
       #24

    I am on 20H2.

    In my case it is called "TextInputHost.exe", strange it was called like this since I can remember!

    Touch keyboard service is disabled, also all privacy setting and pen & ink. Tho something somewhere could be enabled, there are a lot of setting. But it tried a lot of articles to disable it...

    I will try paste commands again and will see...

    Code:
    ERROR: The process "WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe" not found.

    Wonder why you are supposed to kill it afterwards. Wouldn't changes apply after restart? I closed it using task manager. I mean i could change name. I will try next time, if it appears. Doubt tho it will matter...
      My Computer


  5. Posts : 201
    Windows 10 Pro 64-bit
       #25

    If this is indeed the case, then here's what you can try!!

    reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\TextInputHost.exe" /v Debugger /d "%SystemRoot%\system32\systray.exe" /f
    taskkill /im "TextInputHost.exe" /t /f
    echo done

    Try this code! Basically what I have done is replaced WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe with TextInputHost.exe from the code. This is why the original code is not working for you. Because you have TextInputHost.exe in your latest version of Windows 10 while I have WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe

    Old .exe file name from Windows 10 1903 is not applicable for your file name, so of-course this will not work. Let's see if this new code will work, I'm optimistic that it will.
      My Computer

  6. atinfo's Avatar
    Posts : 171
    Windows 10 21H1 Enterprise (x64)
       #26

    empleat said:
    Oh no i thought it worked. And it is baaaaaaaaack
    Calm down!.. It's back to me... again... It's all about "Microsoft"..
      My Computer



  7. Posts : 511
    Windows 10 Pro 64 bit 19042.985
       #27

    Even with this command, errors in Event Log are pilling up, because i disabled "TextInputHost.exe" in regedit. Touch input service is also disabled and everything in Windows Setting under typing.
    Had 127 errors yesterday:

    Code:
    Unable to start a DCOM Server: MicrosoftWindows.Client.CBS_120.2212.551.0_x64__cw5n1h2txyewy!InputApp as Unavailable/Unavailable. The error:
    "2147942402"
    Happened while starting this command:
    "C:\Windows\SystemApps\MicrosoftWindows.Client.CBS_cw5n1h2txyewy\InputApp\TextInputHost.exe" -ServerName:InputApp.AppX9jnwykgrccxc8by3hsrsh07r423xzvav.mca
    Seems it is caused as windows tried to start the app, but it is unavailable. Have no idea how to resolve it.

    I think it needs to be turned off in DCOMcnfg.exe so it doesn't try to start DCOM server. But I can't find TextInputHost by guid.
    Code:
    <Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
    There is no APPID/CLSID. Only provider GUID and correlation activity ID. I saw it from picture from another site, this is not APPID, or CLSID, i did think so. No idea how to find it...

    EDIT:
    I found from this site juicy-potato/CLSIDs.csv at master . ohpe/juicy-potato . GitHub
    APPID of InputService, however I have no idea: whether or not this is TextInputHost's service. Because they are changing names of these often! After disabling it, I opened this DCOM component and under location unchecked run on this computer, also removed launch permissions, but it seems it is still trying to start DCOM server as same error was logged in Event Viewer again!

    EDIT2:
    after renaming folder to .bak, seems it stopped now, 3 days no more errors... Still have DCOM 10010 tho, not sure, if related...

    Anyone knows how to safely disable this? Without generating errors, or editing dcomcnfg.exe???
    Last edited by empleat; 08 Mar 2021 at 16:12.
      My Computer


  8. Posts : 16
    Windows 10
       #28

    im on windows 20h2.

    how do i permanently disable TextInputHost.exe?
      My Computer

  9. GuyInDogSuit's Avatar
    Posts : 335
    Windows 10 Pro x64
       #29

    There's gotta be a safe and surefire way to do this. Because I'm one of the people who this affects adversely, too.

    It pops up randomly, and I usually catch it when I try Alt-Tabbing, because I usually have a game running with either Firefox or Discord on my other monitor. Time and time again, it's tripped that up, getting in the middle, and it throws me off (usually when I tab to Discord and try responding to a message, and... it's not the active app, for some reason. MS Text Input is.

    Sometimes it throttles my CPU or GPU usage, too. And I do not like that, at all. It's gotta go.
      My Computer


  10. Posts : 201
    Windows 10 Pro 64-bit
       #30

    Dear @empleat I saw your post process - Windows 10 - how to prevent Microsoft Text Input Application from starting? - Super UserYou mentioned denying all permissions for "InputService" APPID = {730BFCEC-E4BF-4D3A-9FBB-01DD132467A4} in DCOMcnfg.exe

    I noticed I get a new error despite using the previous method for debugger. Microsoft Text Input Application/Inicio (Start in English) processes-app-did-not-register-dcom-within-required-timeout.jpg

    How do we get rid of this error? I noticed that when I press Windows+H or use CCleaner to run clean I am met with this. App did not register with DCOM within the required timeout. CCleaner is what basically tries to initiate the Microsoft Text Input causing this error.

    This is pretty annoying. I don't know if you or anyone has experienced this. Because while debugger prevents the Input Application from starting. If I use CCleaner then this will trigger with error.

    If I try to deny permission for "InputService" APPID = {730BFCEC-E4BF-4D3A-9FBB-01DD132467A4} in DCOMcnfg.exe then it vanishes from the DCOM Config list. I then can go to regedit and add myself as an Administrator again. But this seems to have no effect on getting rid of the error in my screenshot.

    Anyone has a solution for this?
      My Computer


 
Page 3 of 4 FirstFirst 1234 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:35.
Find Us




Windows 10 Forums