Blank screen when entering BIOS, but Windows Boots fine on ASUS CH7 Solved


  1. Posts : 6
    Windows 10 64bit always newest update
       #1

    Blank screen when entering BIOS, but Windows Boots fine on ASUS CH7


    Hello,

    I wanted to check the bios settings and I have suddenly found out, that when I press DEL to enter BIOS, the display is blank. Monitor is On, it has signal, but with blank black screen. Computer starts normally, beeps, displays the AMI initial screen and normally boots into Windows. If I press DEL however, instead of going to BIOS, I get blank screen.

    Baseline:
    • AMD Ryzen 2700X / ASUS Crosshair 7 WIFI
    • BIOS 2008
    • Windows 10 PRO 1809


    Troubleshooting done:
    • Monitor to any other display output (only this one is on, others are off)
    • Different VGA
    • BIOS reset - did not help, although it was reset. I got message that BIOS was reset, press F1 to enter bios, but then - the same issue.
    • BIOS Flashback update - After pressing the button, it blinks 3 times, then turns on, which should be OK. BUt nothing is happening - the led on USB stick does not blink. Whan I interrupt, the PC works as before.
    • EZ Update in Windows - after submitting to update the bios, it restarts, but then enters the BIOS, which is - blank. After restart, all works as before (with black BIOS)
    • Entering BIOS from Windows (Shift-Restart) does have the same effect


    I am out of ideas now - the PC works, just can't get into BIOS to change anything. Of course, now, I have the default settings loaded because of few BIOS resets.

    Interesting is, that when in BIOS, I am getting 0d on the postcode - changes to this after entering the BIOS. In the manual, this value should be reserved for future AMI BIOS errors.

    Any hints?
      My ComputerSystem Spec

  2. thomaseg1's Avatar
    Posts : 2,109
    Windows 10 Professional (x64) Version 1903
       #2

    Have you tried going through Windows?
    Settings/update and security/recovery/advance startup
    the computer will reboot
    and bring you to the repair menu choose troubleshoot/advance options/ uefi firmware settings (or bios)
    restart
    that should take you into the bios.
      My ComputersSystem Spec


  3. Posts : 6
    Windows 10 64bit always newest update
    Thread Starter
       #3

    Follow-up


    Yes, i did (last bullet point in "Troubleshooting section". and the result was the same, BIOS entered, however with blank screen.

    But I have just tried again the Bios Flashback function - pressing button on the back plate with USB flash in and this time, it worked and I can get into the bios now. Not sure, maybe I misspelled the name before while renaming or the flash drive needed clean format.

    I am not sure however what caused the issue - the computer normally worked and this behavior could be for longer time, I just discovered it yesterday, when I tried to enter to BIOS after some time.

    Not sure if it was issue of the 2008 version or if it can happen anytime again.
      My ComputerSystem Spec

  4. thomaseg1's Avatar
    Posts : 2,109
    Windows 10 Professional (x64) Version 1903
       #4

    Do what I do .. keep a notebook of methods ,tweaks,tips and solutions
      My ComputersSystem Spec


  5. Posts : 6
    Windows 10 64bit always newest update
    Thread Starter
       #5

    yeah, i will definitely keep that flash disk working for bios update
      My ComputerSystem Spec


 

Related Threads
I did this to myself but I want to know if thereís anyway to recover or have I killed my tablet. Iíve got a ASUS VivoTab Smart tablet with Windows 10 installed. Recently it kept rolling back a big update saying I didnít have enough space on...
Hi, I have been facing with this strange issue lately. On pressing the power button the laptop powers up with the lenovo logo then it again goes blank, then it again comes with the same lenovo screen and then boots fine directly into the welcome...
I have an Asus AiO ET2221A upgraded from Win8.1 to 10 3 months ago, and today only boots into the EUFI BIOS screen. There are no errors reported on Boot, just the BIOS screen I was able to run Memtest from a DVD - fine, but couldn't boot into...
Hello people, It has been a while since I posted. I have a Dell Inspiron N5050 laptop that is giving me fits. It was having an issue with explorer restarting continuously after it was upgraded from windows 7 by the customer. I recommended a clean...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:18.
Find Us