taskmgr, regedit and other functions not running: error: the parameter Solved

Page 1 of 3 123 LastLast
  1.    #1

    taskmgr, regedit and other functions not running: error: the parameter


    Hello everyone!
    Two days ago I noticed something very strange with my computer: I tried to open Task Manager (right click on the task bar) and I got an error: The parameter is incorrect. I get the same error when trying to open it from C:\Windows\System32.
    Someone suggested that I should modify the registry, so I tried to open regedit, but got the same error.
    When I tried to run sfc/scannow (Windows+R), it showed me a black window for about a tenth of a second and nothing else happened.
    I read some posts on the internet and found out that I could fix my problem by running a DISM command. but the DISM.exe would not open either .
    When I click on the Start button (or press Windows key) nothing happens.
    I tried fixing it using a Windows 10 USB drive, managed to run the sfc scan from it, but detected no problems.
    None of these .exe files work in safe mode either.
    Sometimes Chrome cannot access any other website but google (I can do searches, but no other site is accessible). There are some programs that run without problem, but some other would not.
    Is there any way I can fix this, without reinstalling Win10?
    Thanks.
      My ComputerSystem Spec

  2.    #2

    Hi Thyan
    You can try to repair system files of Windows by use the "program-image-health".
    It uses windows "Dism" commands to "fix" your system, it is simple to use ...

    Download the image-health_17.01.05.7z file (Thank to Kyhi) ...

    Once in your PC, unzip it by clicking 2 times on it and then extract it where you want (on the desktop, it's easier to find later), it will create a folder "image-health_17.01.05"...

    (If you are having trouble decompressing the file, you will find 7zip totally free for almost all the compressed files in Windows.)

    Open the folder creates and launch "ImageHealth.cmd", accept by "Yes" to "Admin access" then Choose the 3 options for the minimal, more if you want.
    1) Option 1, wait the end (while take some times )
    2) Option 2, wait until the end...
    3) Option 5, wait until the end...
    4) Restart your computer.

    You can use the same program for SFC then choosing the Option 7.

    A+
    Jean-Claude
      My ComputerSystem Spec

  3. Ztruker's Avatar
    Posts : 7,463
    Windows 10 Pro X64 1809 17763.348
       #3

    Unlikely to work if DISM won't work from a Command Prompt, but worth a try.

    Sounds like a Repair Install is the next thing to try: Repair Install Windows 10 with an In-place Upgrade
      My ComputersSystem Spec

  4.    #4

    Hi Ztruker
    Off course !! DISM work with a Command Prompt. The best reason to use the image-health of Kyhi.
    A+
    Jean-Claude
      My ComputerSystem Spec

  5.    #5

    Well, DISM is not running (just a black window for a split second, and then nothing) and the In-place upgrade did not work either (tried it with a USB flash drive): I got the same error window: D:\setup.exe the parameter is incorrect .
    I also tried to copy the exe files for taskmgr, regedit and DISM from another computer, but I still get that error. Either something was erased from my Win10 (by a malicious attack), or some running process is preventing Windows from running .exe files (which I cannot stop, since taskmgr would not run). Thanks for your suggestions, but so far I can do none of the things you suggested.
      My ComputerSystem Spec

  6.    #6

    1. Suggest you check your disk. As you presumably can't install programs, try a portable version of HD Tune which you can run from a flash drive.

    Download Portable HD Tune 2.55

    Health and Error Scan tabs
    Please post the result.
    To post a screenshot, please use the Insert Image icon above your post.

    2. Have you discovered the value of disk imaging, so often recommended here - e.g. Macrium Reflect (free) - if you have a recent disk image of Windows you can restore that.

    Using disk imaging
    - lets you recover from many problems without technical help
    - lets you recover even if your disk fails or is unbootable
    - gives you a full backup

    3.
    In-place upgrade did not work either (tried it with a USB flash drive): I got the same error window: D:\setup.exe the parameter is incorrect .
    Presumably your flash drive was a bootable Win 10 installation medium.

    Note that an in-place upgrade repair install requires an iso or bootable disk of the same base build and language as your installed Windows. Please confirm that is true.

    4. What is your Windows build?
    Windows key + r, winver
      My ComputersSystem Spec

  7.    #7

    @dalchina
    1. I get the same error: The parameter is incorrect
    2. No... I never used disk imaging.
    3. Yes, the flash drive I used is the same I installed the Win10 from, 2 years ago .
    4. Win10 Enterprise, version 1709, build 16299.904.

    I guess there's not much I can do... It seems that most (I haven't tried them all) programs work, except for those that are OS-related. I also can't uninstall any program or app. Since the start button won't work, I can't access apps from windows store (I don't know any other way of accessing them ). I guess I will have to reinstall Windows. But I don't have time for that anytime soon, that's why I asked you guys for help .
      My ComputerSystem Spec

  8.    #8

    Hi Thyan
    Try to launch image-health with the right button, use Admin launch !
    A+
    Jean-Claude
      My ComputerSystem Spec

  9.    #9

    Yes, the flash drive I used is the same I installed the Win10 from, 2 years ago
    Are you saying that you installed Win 10 2 years ago, and never had a feature update (upgrade)? That's the only way you'd be able to use an old disk for it to be compatible.

    If you never had a feature update, then I'd ask 'why?' - Have you blocked updates for up to 2 years?

    To do an in-place upgrade repair install, as your current build is 1709, you need a 1709 iso or bootable disk. Using an older build won't work.

    ** Please see my previous post about testing your disk and post the result. Thanks.
      My ComputersSystem Spec

  10.    #10

    well, I did updated windows every time it asked for it . I mean, I always updated windows when the notification "You need some updates" showed up. Last update took place just before I posted here for the first time, that is, after I begun having the problems described in my first post.
    I don't really know much about versions and builds, so that's why I asked for help . Anyway, thing is that no .exe file works, so I think it would not matter whether I have the latest .iso or not. As for the disk check, that doesn't work either. I guess I'm almost hopeless :))).
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
Alright.. Got another one kicking my butt here. First, let me start by saying, I know that 1803 has disabled SMB 1.0 by default. I have re-enabled it and this problem started prior to 1803. Best I can tell, the first time it happened was in...
Could someone tell me specficially what is wrong with the following command? It looks to me to be concordant with the instructions I'm trying to follow: C:\Windows\system32>netsh interface ip add dns name="Ethernet" static 8.8.8.8 index=2 The...
Bitlocker - The parameter is incorrect in AntiVirus, Firewalls and System Security
I have one data drive that is Bitlocker protected and it has always worked fine. Now it seems to unlock, but when I try to access the drive I get "The parameter is incorrect". The am running Windows 10 Pro 1607 14393.105. Does anyone have any...
So recently I upgraded from 7 to 10, the thing is its already crazy buggy when it first started. so first Edge doesn't work... then after 1 hour, I gave up and restart the computer and reset my PC. Afraid of losing my stuff, I choose to keep my...
Taskmgr.exe missing in General Support
Friends I have a Win 10 Pro 64 bit system that was upgraded from Win 7 Pro 64 bit. It has been working well for a couple of months now, but now recently I ran into a strange problem. When I chose the Taskmanager from the "Start" menu...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:41.
Find Us