Windows Focus Logger Indicates Process "PMA" is Stealing Focus Solved

  1.    #1

    Windows Focus Logger Indicates Process "PMA" is Stealing Focus


    I have been having this problem for maybe a month and a half now, and have only recently seriously begun attempting to solve it. During normal use of any application, be it games, coding software like GMS2, or any other application that has my focus, my focus will be taken away from that application with no indication of what stole the focus. This results in me typing and having my text not appear because focus is lost and minimization of games in the middle of play often resulting in crashes. Yesterday I downloaded "Windows Focus Logger" from Adminscope to get a look at the problem. I left an application running and came back after it was minimized, and was told that a process named "PMA" had stolen focus several times.

    The only major changes I've made to my computer have been the installation of an Epson Workforce WF-2860 printer. I have seen a claim online that installation of one of the printer's programs solved the problem, but they did not specify what program.

    What is PMA? How do I found out where it is, and how do I stop it? I'll be happy to provide any additional information as requested.
      My ComputerSystem Spec

  2. Ztruker's Avatar
    Posts : 8,539
    Windows 10 Pro X64 1903 189362.439
       #2

    https://answers.microsoft.com/en-us/...0-2476ca5fa45e
    It turns out that PMA was a process for my Epson printer. Uninstalled An Epson program and that fixed it.
      My ComputersSystem Spec

  3.    #3

    Yes, that was the solution that I referenced in my post, but as I said it does not specify which program was causing the issue. I don't want to have to uninstall my entire printer to solve the problem. (Obviously if that is the only solution I will but there aren't really any other places I can install my printer)
      My ComputerSystem Spec

  4.    #4

    Click image for larger version. 

Name:	Capture.PNG 
Views:	23 
Size:	5.9 KB 
ID:	225543

    This is Windows Focus Logger reporting on PMA's interference. No data is given for "Main Window Title"
      My ComputerSystem Spec

  5. Try3's Avatar
    Posts : 2,318
    Windows 10 Home x64 and Pro x86
       #5

    Add the Process name & Command line columns to Task manager, Processes tab by right-clicking on any existing column header.

    Find PMA and look at its command line entry. That should tell you which utility is running it.

    Denis
      My ComputerSystem Spec

  6.    #6

    Thank you very much for your help, I identified PMA.exe as a process called "Epson ReadyInk Agent (A) (32 bit)" doing what you instructed. Not wanting to just end the task because it might be important for my printer, I right clicked > Properties > Compatibility then checked the box "Disable fullscreen optimizations". Hopefully this will solve the problem, I will let Windows Focus Logger run overnight and report if any similar errors occur.
      My ComputerSystem Spec


  7. Try3's Avatar
    Posts : 2,318
    Windows 10 Home x64 and Pro x86
       #7

    And, unless you feel that you will benefit from ReadyInk, you could find its entry in Control panel, Progs & features [or Settings, Apps] & uninstall it according to an online discussion that you might already have seen.

    Denis
      My ComputerSystem Spec

  8.    #8

    Thank you for linking me to that forum, it was quite helpful. It turns out Epson ReadyInk Agent is a service that automatically detects when you're low on ink and has it shipped to you. Which, obviously, is insane, and I was at no point even prompted to sign up for the service so it was just running in the background stealing focus once an hour because I'm low on black ink. After looking it up, no harm comes from simply uninstalling the program, so I headed to Add or Remove Programs and uninstalled it. I'll let Windows Focus Logger run for another 12 or so hours just to make sure, but I'm pretty confident that was the culprit.
      My ComputerSystem Spec

  9.    #9

    No errors to report! Uninstalling Espon ReadyInk Agent was the solution, thank you very much for your help Try3, I could not have accomplished this without your help! I now deem this issue solved.
      My ComputerSystem Spec

  10. Try3's Avatar
    Posts : 2,318
    Windows 10 Home x64 and Pro x86
       #10

    Glad I could help.

    At the top of this webpage, you will see a green button to mark the thread as solved. Marking it helps others who are searching for answers on TenForums.

    All the best,
    Denis
      My ComputerSystem Spec


 

Related Threads
turn off focus stealing in General Support
Hey, how do i turn off focus stealing ? i have already in regedit under ForegroundLockTimeout set 30d40, but still when i am in game for example, pop out windows steal focus and minimizes the game. I don't know about anything else. Is there any...
I don't use Microsoft Edge (except on special occasions). So, it is always not loaded on my PC. However, when I wake my PC from "sleep", Edge is on and has the focus. How can I stop this from happening? I don't like Microsoft forcing Edge on me!!! ...
Newbie, forgive my stupid questions. I will have a few things running in the background and tend to flick between them. Firefox, a word document and say music. I click on a work file (usually excel) and can see it may take a few moments to download...
I'm recently upgraded form windows 7 to windows 10. I'm facing the annoying issue that windows explorer steals the application focus after it finishes copying files and comes to front. Can anyone tell me if there is any option to disable this...
I installed Win 10 x64 Home the other day and since then I have had nothing but problems. At random, explorer.exe will steal focus from the active task (can be firefox, can be Word doesn't matter what it is) making the system almost unusable. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:01.
Find Us