Unable to copy anything to external storage devices (No permission) Solved

  1.    1 Week Ago #1

    Unable to copy anything to external storage devices (No permission)


    Hello,

    I have a PC in my office running Windows 10 Pro Version 1803.

    Whenever I try to copy anything from that PC to a pen drive, hard disk, anything, I just get an error saying "You need permission to perform this action"

    Even if I check permissions of the files as well as the pen drive I am trying to copy to, the permissions say that "Everyone" has "Full control"

    Why is this happening?

    Even group policy has not blocked external storage devices.

    Is there some other setting I am missing?


    EDIT:
    I have already watch all those YouTube videos telling me to take ownership of the file / pen drive. It has not work.
    I still get the error message saying "You need permission to perform this action".
      My ComputerSystem Spec

  2.    1 Week Ago #2

    Hi, what happens in Safe Mode? Same or not?
    Are you logged in as admin or as a standard user?
    Do you receive the same message if you copy a file back onto the same disk internal to your PC?
    From what path are you trying to copy a file? (What folder?)

    A basic question is whether the message refers to the source or the destination.

    Basic ideas- please check there's nothing you've not tried:
    FIX: You need permission to perform this action - Appuals.com
      My ComputersSystem Spec

  3.    1 Week Ago #3

    Are the drives NTFS or fat32 if it's fat it doesn't have permission so it's not that if it's NTFS check any folders above as permission may be coming from above
      My ComputerSystem Spec

  4.    1 Week Ago #4

    Who has the owner permission for the external drive?
      My ComputerSystem Spec

  5.    1 Week Ago #5

    Problem solved guys, it was the antivirus actually.
    Someone activated USB write protection from the antivirus. -_-
      My ComputerSystem Spec

  6.    1 Week Ago #6

    Thanks for letting us know... which AV?
      My ComputersSystem Spec

  7.    1 Week Ago #7

    dalchina said: View Post
    Thanks for letting us know... which AV?
    QuickHeal antivirus.
      My ComputerSystem Spec


 

Related Threads
How to Move or Copy Games and Apps Between Storage Devices on Xbox One The Xbox One is equipped with a 500 GB or 1 TB internal hard drive depending on which console you purchased. Most of this space is available for storing games and apps, though...
Good morning, I hope someone can help me with the problem. I get the following errors when connecting any USB storage to my laptop: You don't currently have permission to access this folder & You have been denied permission to access this...
I don't know why, but I have no access to create or copy files directly in d:\. Creating directory works though. When I want to copy or create for example a txt file, explorer says: http://i.imgur.com/SEDohJ7.png Looking into NTFS rights, I...
SMB to external storage in Drivers and Hardware
Does anyone know how to access shares on USB-connected drives via SMB/Samba from another network device? I can see them from another Windows PC, but not from anything else. Used to work under W7.
USB Storage Devices in Drivers and Hardware
I've been using Win10 since the general release. This was an update install on a Win7 laptop. Apart from a few issues (waking from sleep on scheduled tasks, lack of control on updates) I have a problem with external devices. If I use several USB...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:40.
Find Us