Settings Metro App - Instantly Closes - Cant Diagnose The Issue. Solved


  1. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
       1 Week Ago #1

    Settings Metro App - Instantly Closes - Cant Diagnose The Issue.


    Hi Guys,

    I'm at a loose end, my computer has one problem which is driving me crazy. My settings app, opens and then immediatly closes. I'm trying to avoid a fresh install as I have terabytes of data stored.

    (Other standalone merto apps are working perfectly apart from the ones that are dependant on) SystemSettings.exe

    What I have already tried

    Virus and system checks all passed - (Malwarebytes/ Windows Defender)
    Harddrive Scans/Defrags - (No errors)
    Chkdsk -
    (Windows has scanned the file system and found no problems.
    No further action is required.
    )
    Sfc /scannow -
    (Windows Resource Protection did not find any integrity violations.)
    Dism Repairs - (Online & From ISO Source)
    (No component store corruption detected.)
    Reset ImmersiveControlPanel Manualy (Renamed to ImmersiveControlPanel.bak)
    (Regenerated Applications Via Powershell) -
    With Command-
    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRootImmersiveControlPanelAppxManifest.xml
    Results
    cmdlet Add-AppxPackage at command pipeline position 1
    Supply values for the following parameters:
    Path:C:\Windows\ImmersiveControlPanel\appxmanifest.xml
    PS C:\Windows\system32>
    Created new user account (Issue still persists)
    MemTest86 - (No errors)
    Created new WindowsRE for refresh (Mounted Install.wim, extracted Winre.wim and enabled recovery and updated BCD) - Reset Failed

    Sorry it's my first post and I dont know how to copy and paste result logs into spoilers/extendables.

    Any further sugesstions would be greatly appreciated.
      My ComputerSystem Spec

  2.    1 Week Ago #2

    Welcome to tenforums.

    Looks like you've already tried re-registering the Settings app
    Reinstall and Re-register Apps in Windows 10 | Tutorials
    - search that for Settings, decide if for current or all users, and follow the instructions at the top of the relevant section.

    Try
    Settings menu closes as soon as I open it. Help? - Windows 10 Forums


    Otherwise:
    Do you have System Restore enabled, and any relevant restore points?
    - if you were lucky and restoring completed successfully, that could help.

    Noting your comment about not wanting to do a clean install, do you use disk imaging routinely as is frequently recommended here? E.g. Macrium Reflect (free) + external storage for image files.

    Using disk imaging can help you avoid a clean install - even if you need to replace your system disk.

    If so you could restore a disk image.

    Threads with apparent solutions:
    Windows 10 Settings keeps closing instantly - Windows 10 Forums
    Settings doesnt launch, or launches the Store instead - Microsoft Community

    --------------------------------------------------
    As you've confirmed the problem exists for a new user, then I suggest you may need to do an in-place upgrade repair install which keeps all programs, data and most settings.
    Windows 10 Help Forums that you will need an iso of the same build installed.
    What is your Windows build? Windows key + r, winver
      My ComputersSystem Spec


  3. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
    Thread Starter
       1 Week Ago #3

    Hi Dalchina,

    Thank you for you reply!

    I have followed the link you provided me with, and Re-Registed all Windows Apps for All Accounts.
    Then I completed the standalone, settings app re-register individually. (Second attempt)
    Rebooted sytem = (Same Problem)

    Sorry I failed to metion, that I have also system restored back to the oldest version previously.
    (I will try to edit my original post to include this)

    I do have a back up of my entire system however, it is located on a hidden encrypted partition via Veracrypt. (Its a replica of my current system and also has the same SystemSettings.exe issue) I have disconnected this drive whilst troubleshooting

    Windows 10 Version = 1809 - (OS Build 17763.253)

    (I do have a final option in mind, should this issue not be resolvable)
    *New Partition
    *Fresh Install
    *Merge all Data, and registry entries etc to the new partition.
    *Delete old windows (partition).

    Ideally like to avoid this as it would take multiple hours, and also would not be a easy and effective repair for other users that may also facing this issue.

    Do you know of any third party debugging software, that could monitor the .exe in verbose mode in order to identify what is causing the error?

    I had the same issue, but noticed in my application logs I kept getting a Side by Side error that "C:\Windows\ImmersiveControlPanel\Application.manifest" had invalid xml syntax. I opened the file in notepad and saw it was empty. All you need to do is delete this file (I just renamed it). My settings worked immediately as soon as this file was out of the way. I hope this helps someone.
    -

    Once again thanks for your support and assistance.
      My ComputerSystem Spec


  4. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
    Thread Starter
       1 Week Ago #4

    - (Application.manifest - This file does not exist in my directory?)
    Attachment 223931
    Attached Thumbnails Attached Thumbnails Capture.PNG  
      My ComputerSystem Spec

  5.    1 Week Ago #5

    Here's a copy of my .manifest file as shown in your screenshot:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <assembly
    xmlns="urn:schemas-microsoft-com:asm.v1"
    xmlns:asmv3="urn:schemas-microsoft-com:asm.v3"
    manifestVersion="1.0">
    <dependency>
    <dependentAssembly>
    <assemblyIdentity
    type="win32"
    name="Microsoft.Windows.Common-Controls"
    version="6.0.0.0"
    processorArchitecture="*"
    publicKeyToken="6595b64144ccf1df"
    />
    </dependentAssembly>
    </dependency>
    </assembly>

    Note there are 2 other xml files which given the comment might be worth having a look at.

    I have also system restored back to the oldest version previously.
    = in-place upgrade repair with an iso?

    You could look at your Reliability History or if you were brave, use Process Monitor (procmon) free from MS to capture EVERY activity.

    There are plenty of results for this problem: worth taking a look:
    Click image for larger version. 

Name:	1.jpg 
Views:	1 
Size:	110.2 KB 
ID:	223935

    Example:
    The Settings app crashes in Windows 10 April 2018 Update [FIX]
      My ComputersSystem Spec


  6. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
    Thread Starter
       1 Week Ago #6

    Right ok, Thanks i'm with you!

    I was looking for Application.manifest instead of SystemSettings.exe.manifest.
    I have now opened SystemSettings.exe.manifest via notepad.exe (the contents of the script is identical to your version)

    Just on a side note, I have watched them videos, and researched most of them forums for two days with no luck.

    Before posting to you guys.
      My ComputerSystem Spec


  7. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
    Thread Starter
       1 Week Ago #7

    I have debugged the program and this is the output, if anyone has any knowledge to share

    Event Time Event Type Thread ID Memory Address Filename More Information
    00:00:00.009 Create Process 11556
    00:00:00.009 Load DLL 11556 00007fff`35b10000 C:\Windows\SYSTEM32\ntdll.dll
    00:00:00.009 Load DLL 11556 00007fff`33190000 C:\Windows\System32\KERNEL32.DLL
    00:00:00.009 Load DLL 11556 00007fff`32a70000 C:\Windows\System32\KERNELBASE.dll
    00:00:00.015 Load DLL 11556 00007fff`32f50000 C:\Windows\System32\msvcrt.dll
    00:00:00.020 Create Thread 3684 00007fff`35b5ff80
    00:00:00.020 Load DLL 11556 00007fff`35500000 C:\Windows\System32\combase.dll
    00:00:00.020 Load DLL 11556 00007fff`32000000 C:\Windows\System32\ucrtbase.dll
    00:00:00.024 Load DLL 11556 00007fff`33060000 C:\Windows\System32\RPCRT4.dll
    00:00:00.024 Load DLL 11556 00007fff`32230000 C:\Windows\System32\bcryptPrimitives.dll
    00:00:00.024 Load DLL 11556 00007fff`35990000 C:\Windows\System32\SHCORE.dll
    00:00:00.029 Create Thread 2252 00007fff`35b5ff80
    00:00:00.029 Load DLL 11556 00007fff`31b30000 C:\Windows\System32\kernel.appcore.dll
    00:00:00.035 Load DLL 11556 00007fff`35080000 C:\Windows\System32\clbcatq.dll
    00:00:00.049 Load DLL 11556 00007fff`27e70000 C:\Windows\System32\Windows.UI.Xaml.dll
    00:00:00.055 Load DLL 11556 00007fff`31d80000 C:\Windows\System32\msvcp_win.dll
    00:00:00.060 Load DLL 11556 00007fff`348b0000 C:\Windows\System32\user32.dll
    00:00:00.060 Load DLL 11556 00007fff`321b0000 C:\Windows\System32\win32u.dll
    00:00:00.064 Load DLL 11556 00007fff`352b0000 C:\Windows\System32\GDI32.dll
    00:00:00.064 Load DLL 11556 00007fff`31be0000 C:\Windows\System32\gdi32full.dll
    00:00:00.069 Load DLL 11556 00007fff`2ea10000 C:\Windows\System32\CoreMessaging.dll
    00:00:00.069 Load DLL 11556 00007fff`35a40000 C:\Windows\System32\sechost.dll
    00:00:00.069 Load DLL 11556 00007fff`29380000 C:\Windows\System32\Bcp47Langs.dll
    00:00:00.078 Load DLL 11556 00007fff`27bc0000 C:\Windows\System32\iertutil.dll
    00:00:00.078 Load DLL 11556 00007fff`35440000 C:\Windows\System32\advapi32.dll
    00:00:00.078 Load DLL 11556 00007fff`2f5b0000 C:\Windows\System32\dcomp.dll
    00:00:00.078 Load DLL 11556 00007fff`35830000 C:\Windows\System32\OLEAUT32.dll
    00:00:00.085 Load DLL 11556 00007fff`308a0000 C:\Windows\System32\dxgi.dll
    00:00:00.089 Load DLL 11556 00007fff`35900000 C:\Windows\System32\IMM32.DLL
    00:00:00.109 Load DLL 11556 00007fff`2a390000 C:\Windows\WinSxS\amd64_microsoft.windows.common-controls_6595b64144ccf1df_6.0.17763.253_none_05b2388e0721fece\Comctl32.dll
    00:00:00.115 Load DLL 11556 00007ffe`fde40000 C:\Windows\ImmersiveControlPanel\SystemSettings.dll
    00:00:00.120 Load DLL 11556 00007fff`322b0000 C:\Windows\System32\windows.storage.dll
    00:00:00.120 Load DLL 11556 00007fff`31b50000 C:\Windows\System32\profapi.dll
    00:00:00.120 Load DLL 11556 00007fff`31b80000 C:\Windows\System32\powrprof.dll
    00:00:00.125 Load DLL 11556 00007fff`32d40000 C:\Windows\System32\shlwapi.dll
    00:00:00.125 Load DLL 11556 00007fff`333a0000 C:\Windows\System32\shell32.dll
    00:00:00.125 Load DLL 11556 00007fff`32a00000 C:\Windows\System32\cfgmgr32.dll
    00:00:00.129 Load DLL 11556 00007fff`32a50000 C:\Windows\System32\cryptsp.dll
    00:00:00.129 Load DLL 11556 00007fff`352e0000 C:\Windows\System32\ole32.dll
    00:00:00.129 Load DLL 11556 00007fff`31a40000 C:\Windows\SYSTEM32\SspiCli.dll
    00:00:00.134 Load DLL 11556 00007fff`2e560000 C:\Windows\SYSTEM32\PROPSYS.dll
    00:00:00.134 Load DLL 11556 00007fff`29240000 C:\Windows\SYSTEM32\MrmCoreR.dll
    00:00:00.140 Load DLL 11556 00007fff`293e0000 C:\Windows\SYSTEM32\wincorlib.DLL
    00:00:00.140 Load DLL 11556 00007fff`30a90000 C:\Windows\SYSTEM32\slc.dll
    00:00:00.145 Load DLL 11556 00007fff`2b770000 C:\Windows\SYSTEM32\policymanager.dll
    00:00:00.145 Load DLL 11556 00007fff`30a60000 C:\Windows\SYSTEM32\sppc.dll
    00:00:00.149 Load DLL 11556 00007fff`2ef60000 C:\Windows\SYSTEM32\msvcp110_win.dll
    00:00:00.154 Load DLL 11556 00007fff`29100000 C:\Windows\System32\Windows.UI.dll
    00:00:00.160 Load DLL 11556 00007fff`28f90000 C:\Windows\System32\TextInputFramework.dll
    00:00:00.160 Load DLL 11556 00007fff`29030000 C:\Windows\System32\InputHost.dll
    00:00:00.165 Load DLL 11556 00007fff`2dbf0000 C:\Windows\System32\CoreUIComponents.dll
    00:00:00.165 Load DLL 11556 00007fff`30360000 C:\Windows\System32\twinapi.appcore.dll
    00:00:00.169 Load DLL 11556 00007fff`2eff0000 C:\Windows\System32\d2d1.dll
    00:00:00.169 Load DLL 11556 00007fff`2e710000 C:\Windows\System32\d3d11.dll
    00:00:00.174 Load DLL 11556 00007fff`2da90000 C:\Windows\SYSTEM32\wintypes.dll
    00:00:00.174 Load DLL 11556 00007fff`30c10000 C:\Windows\SYSTEM32\ntmarta.dll
    00:00:00.178 Load DLL 11556 00007fff`30310000 C:\Windows\System32\RMCLIENT.dll
    00:00:00.178 Load DLL 11556 00007fff`30090000 C:\Windows\system32\uxtheme.dll
    00:00:00.189 Load DLL 11556 00007fff`28f70000 C:\Windows\SYSTEM32\languageoverlayutil.dll
    00:00:00.194 Load DLL 11556 00007fff`28f40000 C:\Windows\SYSTEM32\bcp47mrm.dll
    00:00:00.206 Debug String 11556 Windows.UI.Xaml.dll!00007FFF27F48D2C: (caller: 00007FFEFDE58A5F) FailFast(1) tid(2d24) 8000FFFF Catastrophic failure

    00:00:00.206 Debug String 11556 Windows.UI.Xaml.dll!00007FFF27F48D2C: (caller: 00007FFEFDE58A5F) FailFast(1) tid(2d24) 8000FFFF Catastrophic failure

    00:00:00.206 Debug String 11556 Windows.UI.Xaml.dll!00007FFF27F48D2C: (caller: 00007FFEFDE58A5F) FailFast(1) tid(2d24) 8000FFFF Catastrophic failure

    00:00:04.495 Exit Thread 11556 Exit Code: 0xc0000409
    00:00:04.505 Exit Thread 2252 Exit Code: 0xc0000409
    00:00:04.509 Exit Process 3684 Exit Code: 0xc0000409

    (Trying to take ownership of Windows.UI.Xaml.dll and replace it with a working version) - I will update with progress
      My ComputerSystem Spec


  8. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
    Thread Starter
       1 Week Ago #8

    Solved!


    (Trying to take ownership of Windows.UI.Xaml.dll and replace it with a working version)
    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    DO NOT ATTEMPT THE ACTION ABOVE
    -----------------------------------------------------------------------------------------------------------------------------------------

    If you have tried, all of the above suggestions and nothing has worked like in my situation. This is how to fix the problem.

    SOLUTION

    As you can't update via the settings app, follow these instructions.

    1. Hold Windows key & press R
    Type in winver (this will show you your windows version)
    Mine was (Version 1809 OS Build 17763.253)
    2. Check if there is a higher update available e.g (Version 1809 OS Build 17763.292)
    You can do this here
    HTML Code:
     https://docs.microsoft.com/en-us/windows/windows-10/release-information
    3. Click on the KB article that is relevant to you.
    Click image for larger version. 

Name:	Kb Article.PNG 
Views:	0 
Size:	25.1 KB 
ID:	223976
    4. Scroll to the bottom and download the standalone update by clicking on Microsoft Update Catalog.
    Click image for larger version. 

Name:	stand.PNG 
Views:	16 
Size:	7.8 KB 
ID:	223977
    5. Download the correct system architecture.
    Click image for larger version. 

Name:	UPDATES.PNG 
Views:	0 
Size:	56.9 KB 
ID:	223978

    Install and this should resolve your problems - if it does (CREATE A NEW SYSTEM RESTORE POINT)

    Hope it helps
      My ComputerSystem Spec

  9.    1 Week Ago #9

    Glad that worked out for you.
      My ComputersSystem Spec


  10. Posts : 7
    Windows 10 Professional 64-bit (Build 17763)
    Thread Starter
       1 Week Ago #10

    dalchina said: View Post
    Glad that worked out for you.
    Thank you for all your support 👍
      My ComputerSystem Spec


 

Related Threads
If you have Chrome set to automatically download files, it may be a good thing to change that option to ask you where to save. You should disable automatic downloads in Chrome right now - gHacks Tech News
Help--i can't change my lock screen settings...when i open lock screen settings, it closes automatically after one second and it won't allow me to change settings...desktop wallpaper settings does not have the same problem
My computer has all updates - running windows 10. Have been having bsod daily though each day the time it occurs gets later and later through the day. am attaching the dmp file for advice if someone can figure out what the cause is. thanks
Windows 10 Metro UI closes after opening any app. Start menu properties tab missing from taskbar properties window. Some say it has been removed... some show its usage in configuring Startup? Thank you
The other day I was setting up this: C:\Python27 in the environment variable path so I can access Python from the command prompt. Usually in the previous builds and in Win8/Win7 you just perform the set up in the PC/Computer properties and when...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:53.
Find Us