widows explorer is slow to open content on drives

  1. glacourse's Avatar
    Posts : 6
    Windows 10 1903
       #1

    widows explorer is slow to open content on drives


    all three of the drives are usb 3.0 and are plugged into a daughter card, and are slow to access. Have a fourth 1 terabyte drive found and dropped and then found again by windows explorer. this one has since been plugged into main board and now seems fine. I plugged the there into the daughter card because they were being dropped and found again.
      My Computer

  2. spunk's Avatar
    Posts : 2,844
    Windows 10 Pro 64 Bit 20H2
       #2

    If all of the drives work when plugged into the motherboard directly but not the daughter board, then the daughter board is the problem.
    If having Problems attaching directly;Try different SATA data cables,. Different SATA power plugs, try different SATA Data ports on the motherboard.
    Also download Crystal Disk Info to view the health of each drive.
      My Computer

  3. glacourse's Avatar
    Posts : 6
    Windows 10 1903
    Thread Starter
       #3

    Brexit said:
    This is not typical, but it can happen. It depends on the size and contents of the folder, and the power of your hardware. Explorer is a bit slower than a DIR command because Explorer gives you much more detail about each file, including thumbnails of pictures and video. It is also performing many other functions, depending on how that particular folder is optimized.
    In fact, changing the folder optimization can often speed things up amazingly.
    as i said they are all usb3. right after creating this thread they started behaving perfectly. long story short i started having issues with a am3 machine i built, and my roommate offered to get my am4 running once and for all, and he did. he's on linux mint and so the only win 10 boot media we had was from when 1803 first came out. i think because of the amount of updates to bring it current may have caused the problem, cause how directly on the main board or plugged into the daughter card all the drives are nice and responsive. i agree explorer is know to be slow compared to other file managers. hell nemo and launching apps under mint on a am3 machine is faster than doing either in 10 on a am4 machine, go figure. don't get me wrong the am4 machine does blow the win am3 machine out of the water. thank you both for your suggestion, appreciated. going to mark solved since everything seems to behaving like it should. thanks again.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:02.
Find Us




Windows 10 Forums