Windows 10: bat files not being run when double clicked

Page 2 of 2 FirstFirst 12

  1. Posts : 7
    Windows 10 pro 18.06
    Thread Starter
       #11

    Bree said:
    Well, you live and learn. Didn't know that TAB trick

    I can confirm that in my Home x64 17763.134 double-clicking on a .bat works normally, as does TAB in a command prompt. Repeated TABs cycle through all existing extensions, including (in my test for 'M' in my user folder) .rtf, .bak, .bat and the link to "My Documents".

    Try another user account, does it behave the same way?

    Try adding a PAUSE statement as the first line in the .bat. Does it get that far? Or does it fail before even opening the .bat?

    Maybe Controlled Folder Access is blocking it? Try temporarily turning it off and see if it makes a difference.

    Enable or Disable Controlled Folder Access in Windows 10 | Tutorials

    Controlled Folder Access was disabled already, it did not make any diff.

    But while experimenting with this I noticed something important...so far I was testing everything in Total Commander (I dont use Explorer for anything, always TC), so I tested Explorer and the bat files run fine! Only from TC they dont run... I run TC as administrator just to double check but no luck, still don't get run...

    thanks!
      My Computer

  2. das10's Avatar
    Posts : 2,759
    Win 10 pro 20H2
       #12

    Have you tried and enabled the "Log File" in TotalCommander Configuration (tick all boxes) , and see if it shows any errors after you try to run .bat files.

    Additionally, have you looked at the wincmd.ini file to see what if there is extraneous under the [Extensions] section.
    Last edited by das10; 27 Nov 2018 at 17:12.
      My Computer


  3. Posts : 7
    Windows 10 pro 18.06
    Thread Starter
       #13

    das10 said:
    Have you tried and enabled the "Log File" in TotalCommander Configuration (tick all boxes) , and see if it shows any errors after you try to run .bat files.

    Additionally, have you looked at the wincmd.ini file to see what if there is extraneous under the [Extensions] section.
    I cannot get any log output, and I dont seem to have a [Extensions] section. But now that I know the issue is limited to TC, I think I'll get more effective help in their forums.

    Hold on, but it is not limited to TC, in cmd bat files do not get completed on TAB...something is wrong outside TC I guess...
      My Computer


 
Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:00.
Find Us




Windows 10 Forums