Why does Powershell return an error for Get-MpComputerStatus ?

  1.    2 Weeks Ago #1

    Why does Powershell return an error for Get-MpComputerStatus ?


    Instead it returns
    "Get-MpComputerStatus : The extrinsic Method could not be executed. at line:1 char:1
    + Get-MpComputerStatus
    + ~~~~~~~~~~~~~~~~~~~~~~~~~
    + Categorylnfo : MetadataError: (MSFT_HpComputerStatus:ROOT\Microsoft\...pComputerStatus) [Get-MpComputer Status], CimException
    + FullyQualiFiedErrorId : MI RESULT 16,6et-MpComputerStatus.
      My ComputerSystem Spec

  2. Ztruker's Avatar
    Posts : 6,750
    Windows 10 Pro X64 1809 17763.134
       2 Weeks Ago #2

    Works fine for me:

    Code:
    PS C:\Users\ztruk> Get-MpComputerStatus
    
    AMEngineVersion                 : 1.1.15400.5
    AMProductVersion                : 4.18.1810.5
    AMServiceEnabled                : True
    AMServiceVersion                : 4.18.1810.5
    AntispywareEnabled              : True
    AntispywareSignatureAge         : 0
    AntispywareSignatureLastUpdated : 11/26/2018 4:10:03 PM
    AntispywareSignatureVersion     : 1.281.893.0
    AntivirusEnabled                : True
    AntivirusSignatureAge           : 0
    AntivirusSignatureLastUpdated   : 11/26/2018 4:10:04 PM
    AntivirusSignatureVersion       : 1.281.893.0
    BehaviorMonitorEnabled          : True
    ComputerID                      : 148D0B73-2782-48B0-9841-C8B95255B416
    ComputerState                   : 0
    FullScanAge                     : 120
    FullScanEndTime                 : 7/29/2018 8:32:04 PM
    FullScanStartTime               : 7/29/2018 8:31:08 PM
    IoavProtectionEnabled           : True
    LastFullScanSource              : 1
    LastQuickScanSource             : 2
    NISEnabled                      : True
    NISEngineVersion                : 1.1.15400.5
    NISSignatureAge                 : 0
    NISSignatureLastUpdated         : 11/26/2018 4:10:04 PM
    NISSignatureVersion             : 1.281.893.0
    OnAccessProtectionEnabled       : True
    QuickScanAge                    : 0
    QuickScanEndTime                : 11/26/2018 2:31:39 AM
    QuickScanStartTime              : 11/26/2018 2:29:27 AM
    RealTimeProtectionEnabled       : True
    RealTimeScanDirection           : 0
    PSComputerName                  :
    I have Win 10 Pro X64 Ver 1809 Build 17763.134 (as reported by winver).
      My ComputersSystem Spec

  3.    2 Weeks Ago #3

    Good for Ztruker.

    How can I also get that result ? It should not depend on the version - I am still running v1803, since there is NO sign of it updating to v1809. I have two systems - one 32bit and one 64bit - they BOTH return that error.
      My ComputerSystem Spec

  4.    2 Weeks Ago #4

    It looks like this depends on Defender being active. Do you have another anti-malware installed?
      My ComputerSystem Spec

  5.    2 Weeks Ago #5

    why Powershell error ?


    Yes, I have AVAST, but had disabled it.
    On the x64 v1803, I had tried to disable Defender because it was attacking files I wanted to run. Hence my interest in Powershell. With both Avast & Defender disabled, PUPs are still being prevented from running.

    In the v1803 x32, I have Avast running, which I believe disables Defender.
      My ComputerSystem Spec

  6.    1 Week Ago #6

    I can confirm presence of Defender makes a difference on my machines. I get the same error as the OP on my production PC where I run NIS. I get the same kind of output on my Lenovo T520 as @Ztruker because that machine has always and only run Defender. Interesting!
    --Ed--
      My ComputersSystem Spec

  7. Berton's Avatar
    Posts : 5,668
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       1 Week Ago #7

    Works fine for me using PowerShell as Admin on latest Win10 with Windows Defender running.
    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	37.0 KB 
ID:	215394
      My ComputerSystem Spec

  8. Ztruker's Avatar
    Posts : 6,750
    Windows 10 Pro X64 1809 17763.134
       1 Week Ago #8

    Found this: How to use PowerShell to investigate Windows Defender's malware signature definitions database

    Code:
    The 12 Defender cmdlets are described in this table.
    
    Cmdlet Description
    Add-MpPreference Modifies settings for Windows Defender.
    Get-MpComputerStatus Gets the status of anti-malware software on the computer.
    Get-MpPreference Gets preferences for the Windows Defender scans and updates.
    Get-MpThreat Gets the history of threats detected on the computer.
    Get-MpThreatCatalog Gets known threats from the definitions catalog.
    Get-MpThreatDetection Gets active and past malware threats that Windows Defender detected.
    Remove-MpPreference Removes exclusions or default actions.
    Remove-MpThreat Removes active threats from the computer.
    Set-MpPreference Configures preferences for Windows Defender scans and updates.
    Start-MpScan Starts a scan on the computer.
    Start-MpWDOScan Starts a Windows Defender offline scan.
    Update-MpSignature Updates the anti-malware definitions on the computer.
    That seems to indicate these are Defender specific Cmdlets.
      My ComputersSystem Spec

  9.    1 Week Ago #9

    So Powershell should report the status of those cmdlets, rather than return an error message.
      My ComputerSystem Spec


 

Related Threads
Annoying error in PowerShell in General Support
I have a directory E:\Documents\Steve's\New Documents\Tax If I navigate to this directory in explorer, and then use the File->Open Windows Powershell mechanism, then Windows PowerShell opens with the error: The string is missing the terminator:...
I am trying to cleat all the events in my event viewer as I had so many errors in the past 7 days. I opened powershell & ran as administrator & use this command wevtutil el | Foreach-Object {wevtutil cl $_} & I had some access denied errors....
Some pictures return this error. They can be accessed on the ONE Drive site. What does this error mean. Chkdsk does not fins any errors.
Ever since 10130 came out I've had this problem where you simply cant access the start menu or Cortana. Running edge or the store returns with an error from explorer.exe claiming that it's an invalid value for the registry. Looking in other places,...
Can someone tell what the powershell errors means? when i put this commend ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:10.
Find Us