Device manager fails to open with error 0xc0000043

  1.    #1

    Device manager fails to open with error 0xc0000043

    Device manager fails to open with error 0xc0000043. Win 64 Pro. Have done the usual DISM and sfc /scannow and no change. Have also tried reimage and no luck. PC is a Lenovo ThinkCentre. Discovered the error when I tried to open Device Manager to see why a smart USB stick wasn't found. Problem still occurs when all external USB devices are disconnected from the PC.

    How do I fix this error?

    Thank you,

      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 13,774
    Windows 10 Pro x64 Build 1809

    Hi John. Welcome to the TenForums @smoketoxdoc

    Not sure exactly what you mean reimage. I assume this means you are using a tool like Macrium to restore an Image of your system to an earlier time. Did I get this right?

    Or does reimage mean you've reset the device?

    Either way, and I trust you are on V1803, I would use an inplace repair / upgrade. Assuming you are on V1803 it will be a repair, if older version it will be an upgrade. This is a non destructive process but I always recommend you back up your data before executing.

    Repair Install Windows 10 with an In-place Upgrade

    I also assume you done the obvious and scanned for unwanted visitors with an alternate AV tool.

      My ComputerSystem Spec

  3.    #3

    Thank you, Ken. Win 64 pro versions on my PCs are 1709. Reimage is a proprietary program that replaces bad Windows files and looks for malware, etc. PC covered by Windows Defender as are all the rest in my solo scientific consulting business. One PC is running 1803 (new), others are 1709. How do I do simple update to 1803?. john
      My ComputerSystem Spec

  4.    #4

    If you go into Control Panel, you'll probably find that some other items don't run.
    It's usually a sign of a failing hard drive, malware etc when system files get corrupted.

    Since you have already done a: sfc /scannow

    Have you done a:

    chkdsk C:/r

    Other than that. A system restore is often an easy first place to start.
      My ComputerSystem Spec

  5. Caledon Ken's Avatar
    Posts : 13,774
    Windows 10 Pro x64 Build 1809

    If you want to do a simple update then just do the inplace repair / upgrade I mentioned.

    Assuming you get the tool today it should be 1803. Need 8GB USB Key. (at least I just use the USB option.)

    Here is the download page for the tool. Then you execute the download and follow the instructions. When you land on page make sure it says April and not October. Don't know when 1809 will be released, again, and I strongly recommend people defer this update for at least a few weeks. Since you are in business even longer. There is no prize for being in the first million users.

    Click image for larger version. 

Name:	image.png 
Views:	2 
Size:	48.6 KB 
ID:	208046

    Since you are on Pro you can defer in your Advance Options. These must already be on if you are still on 1709. You could reset dates to zero and you should just naturally pick up 1803 in Windows updates.

    Start > Settings > Updates and Security > Advance Options

    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	32.3 KB 
ID:	208047

    Then lock down the top date to prevent 1809.

    I think Stigg and I have both mentioned malware / visitors. You could go with MalwareBytes. Certainly wouldn't hurt to check disk.
      My ComputerSystem Spec


Related Threads
In another thread, I showed a screenshot of my Device Manager with yeoow triangles against the Display Adapter and the Storage Controllers: ...
Is it possible to create a shortcut to Open Device Manager with the Ports branch expanded?
Good afternoon guys my name is Tamara. I'm a Mac girl so forgive me if this is a dumb question. I just purchased a 24" all in one desktop from Dell with Windows 10 for video/picture editing. Anyways, when I connected my WD My Book (that has worked...
Hi, On Windows 8. 1, I had no issues with this speaker. It's a JBL Charge. After upgrading to 10 it worked fine until a reboot when it failed to connect (it pairs, but won't connect, and the speaker doesn't appear as an audio-out option in Sound...
During Windows backup, which wants to backup the 'C' drive and my games drive 'E' (for some reason), I get the following error message after the 'C' backup has completed but not the 'E': 'The backup operation that started at...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:57.
Find Us